summaryrefslogtreecommitdiff
path: root/app-vim/lustyexplorer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-vim/lustyexplorer
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-vim/lustyexplorer')
-rw-r--r--app-vim/lustyexplorer/Manifest2
-rw-r--r--app-vim/lustyexplorer/lustyexplorer-5.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/app-vim/lustyexplorer/Manifest b/app-vim/lustyexplorer/Manifest
index f0fecda35f2b..5cb851b11753 100644
--- a/app-vim/lustyexplorer/Manifest
+++ b/app-vim/lustyexplorer/Manifest
@@ -1,3 +1,5 @@
+DIST lusty-explorer-5.0.zip 21036 BLAKE2B 6f9918242b5a12a2fd58017c54f10489113b21858e1522e0ff74a7cca41045c08144cb7b69bef2aa5e67998d74bb8472d547421cb737d2fdf79ec1ce4c51db9d SHA512 42aa2dea2d96c88cf65891a08a798c185849695c49663260fd133c34b63311d1db9073d3db2d6e4d1fd6907fdd4cf89335dacb0a5bbaa994924751f5a1be66cf
DIST lustyexplorer-4.3.tar.bz2 17373 BLAKE2B 643eb4c7573932fa63030766670d7c398e307b72e08e93e53e31b7f21086a80196c8d4d7811032b8b945306fcdc7d86d59eb6b48ce0b79f38e628d6b4bec7519 SHA512 24ffa1fe5c1698dfa6093c7cfed2f08540ce130258df5e8ec135356ecea4c1f607f11e643ab859f551e63ecbbf6fc8a615a9514e1d4798b752cc97146c29c661
EBUILD lustyexplorer-4.3-r1.ebuild 848 BLAKE2B 6593f7a5b016f867337acbef13f41c14861b2e22b2e15e4ca94d819adb8f3f98dad8fd335ba085a7fd711a803685fa948818439018b8b9798e295a005cf9606c SHA512 de1b05e0265a1eaac5c6f3b5b8338d6a7742a79fee37dce5d0d2f7487630b17d0259ff46fe1969ee12af19b4ebc346ce187759b39aba4c90d456ead88a451720
+EBUILD lustyexplorer-5.0.ebuild 1029 BLAKE2B c0bbd463db531070c74ba2d10597b1b3c865eb9302e9856a844b328026ffb6104153fb53f4122929a4a6058bdd104b3b8ef3b63f47f7379d0f94178c7792ff8b SHA512 b87de28c5abd97dcf5913cba60306975765cd005e50c322183b370a03c61c7a241f60efa3f3716462e37c89e4bb015717e029e7a0af924ebace0c7d6034f891e
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/lustyexplorer/lustyexplorer-5.0.ebuild b/app-vim/lustyexplorer/lustyexplorer-5.0.ebuild
new file mode 100644
index 000000000000..c2f6ad8affa6
--- /dev/null
+++ b/app-vim/lustyexplorer/lustyexplorer-5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+MY_PN="lusty-explorer"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="vim plugin: dynamic filesystem and buffer explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1890"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=26146 -> ${MY_P}.zip"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="lusty-explorer.txt"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="|| (
+ app-editors/vim[ruby]
+ app-editors/gvim[ruby]
+)"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc || die
+ sed -e '0,/"$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e "s/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/" \
+ plugin/lusty-explorer.vim > doc/lusty-explorer.txt
+}