summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-vim
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31939 -> 31940 bytes
-rw-r--r--app-vim/bash-support/Manifest2
-rw-r--r--app-vim/bash-support/bash-support-4.3.ebuild25
-rw-r--r--app-vim/gentoo-syntax/Manifest6
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild42
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20211208.ebuild (renamed from app-vim/gentoo-syntax/gentoo-syntax-20210911.ebuild)0
-rw-r--r--app-vim/lustyexplorer/Manifest2
-rw-r--r--app-vim/lustyexplorer/lustyexplorer-5.0.ebuild37
-rw-r--r--app-vim/tlib/Manifest3
-rw-r--r--app-vim/tlib/files/tlib-1.27-fix-error-E1208-vim-8.2.3141.patch29
-rw-r--r--app-vim/tlib/tlib-1.27.ebuild30
11 files changed, 130 insertions, 46 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index de109998d5c3..403f6768989c 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/bash-support/Manifest b/app-vim/bash-support/Manifest
index 5cb7c6784de0..66402b55d1d1 100644
--- a/app-vim/bash-support/Manifest
+++ b/app-vim/bash-support/Manifest
@@ -1,3 +1,5 @@
DIST bash-support-4.2.1.tar.bz2 115200 BLAKE2B 2fab4f1bb0897af389a206051e63d2fe7a8cd89367298b1be51146eed7c0d788b23cec7bc81ce3056d26b5efc920043e67be003e4e6bfe25b503d532c74d9c07 SHA512 12ab39f5cffb58e4adb2137265d6c4f1a61b5f2e360f6866c21ead0a67e02a5445bd12fec5b00b26e5d6102b3aaab99b8b13539a67575067c3ef9b26c4ef8fba
+DIST bash-support-4.3.zip 249238 BLAKE2B 46fa031b4ba927e5a229fa9dc93a3dbe005322a1de494bc8cbeb56138f2c580ea5b39b203d46b59013e1985930422c2e4217234a317fbf8ee6209889c4047323 SHA512 fd9294e467129990bc9796cda309a5b0ec5af3ddbda7f141939622ec0d96c1573b35d9a20e99040d6a4e83b1e98c1f6b847c77d055cca9492922e1080dc64118
EBUILD bash-support-4.2.1.ebuild 464 BLAKE2B b598a5072daf40141ea9fcd43dbbe203a5e330ee5c3ef6b9ee900b2d0cdd90108b8b72b39aea85ce9ea750fee7334cc18a4b21744494239ea85929febd1e464a SHA512 cf8a86c5ffcfcbede66d496f11225928ff31f4dfd30411c5e562340df8da856ae7381163a5d387be26d7293a192c62610521569bcafe4d77f040425dbcb6c4f6
+EBUILD bash-support-4.3.ebuild 591 BLAKE2B cd4708298939d237eb5e2aad39f8c50a9498d913df2c78e08e2b223911d1e680f451a465b55eaa1cb2dcc5214038c21ae3c81aa7f0d7ad87a544f46536c46ac7 SHA512 b74635aa284a48f9a54ab00c66681b003a8ce0d65917335afd2b40f43786eebcbbc8bb20f4022c9d1a18dcc6433fef62cc8d4ca56535301b103a6321fbf6ba86
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/bash-support/bash-support-4.3.ebuild b/app-vim/bash-support/bash-support-4.3.ebuild
new file mode 100644
index 000000000000..6de7fb8f0321
--- /dev/null
+++ b/app-vim/bash-support/bash-support-4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: write and run bash scripts using menus and hotkeys"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=365"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=24452 -> ${P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc doc/{ChangeLog,bash-hotkeys.pdf}
+ rm -rf ${PN}/doc || die
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 61551072d046..0705261b7fee 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,6 +1,4 @@
-DIST gentoo-syntax-20210911.tar.bz2 18865 BLAKE2B 14dfe4b1eaab39a7de11c9b2e00c6a39385cd81d5717522dbac1f9ff265047c9ded745c335cca88413f6ad622f2858d996bdb39c5f4b1b4796ef7740c48c5f68 SHA512 b7ac7aba50c086e1e550692426bb38dbca5bf4770c148ff4989686ef043a2d990710bec782f1baba582ff67da3b3db007a4dbc6dec16f69830312205f1a45d3c
-DIST gentoo-syntax-20211116.tar.bz2 18849 BLAKE2B 7d9ebe080d09dc604a0847285d1cda90d4d5538360bce122bba054b66e2be9afcd8fed7098664447e0f07adc1ae6c4feff08e48884995fbbe3abd925e5d7bf67 SHA512 ff13926998e6d5b530bdf7ab8a6427264980d194b13c16811cc6380b0aa4edc7445ffa157afe3c19b536bcd42208d85a36e92921b1c2c8c3e4c136295b00f770
-EBUILD gentoo-syntax-20210911.ebuild 1237 BLAKE2B e4376fc40d3d7c829e253383c0744e4369d312657a539b5d82387128c50c2ae35431207171d9f9a312e7350485c7f2c417d07c665fa345b5193964489a1727f5 SHA512 e692cfa8d4e37e9bfa6bea96c7948e1230a6ebf7bdb7601980e3f918fdec8e69d7e7273e6979ea3ac36446c2c7040e79e09e42d185e8e915d00286cd6c693521
-EBUILD gentoo-syntax-20211116.ebuild 1245 BLAKE2B 4de7b82e15d0e8e0716fa3b419297d3ce15bbe12d7fc8007e231bc09cd3d9236af4c5d08e7c6dec0c1058150eec401c37a24d3b5bade0319947617db9d358bb6 SHA512 9a14cb1d43d22cde53c0f7c9598bfdbb2cd1f0417bc69b604823f595b6f1a59a95aeb47cd61a68707abe8412a2ca44d71a67a51c731d7e083b2f4cab299e6584
+DIST gentoo-syntax-20211208.tar.bz2 18844 BLAKE2B 52e7025d46f5101f2e1c44afcbf3cba0756a1ec9c626f7af312bb5bbae518645c06c94bfc48822a721e2e3c1ed5f61376e88a074a9688cf4b5b3c352a99c87c9 SHA512 f1cfe2af440f7ed3042cbaa16558cb6df8038f439a2c3e7067f81751a37098854a3afb1653c7c3656ef85ad1874d2db9271429b92a25f494da6ee5c68819e631
+EBUILD gentoo-syntax-20211208.ebuild 1237 BLAKE2B e4376fc40d3d7c829e253383c0744e4369d312657a539b5d82387128c50c2ae35431207171d9f9a312e7350485c7f2c417d07c665fa345b5193964489a1727f5 SHA512 e692cfa8d4e37e9bfa6bea96c7948e1230a6ebf7bdb7601980e3f918fdec8e69d7e7273e6979ea3ac36446c2c7040e79e09e42d185e8e915d00286cd6c693521
EBUILD gentoo-syntax-99999999.ebuild 1084 BLAKE2B cbe1d6aa8eca271a997dec67ba8ba3725e3c50d97ff2f1f18c169bd3ea84ed568390ffef00742d20748dec2ec9b98468a119fc10b62bd55cd05e0506227e58cd SHA512 e59ceccbaaeb0947a66c079380269acd431d9694a20b851c13d5772a610306db1ddb04e8d8173ad5b84723077dae034a60ac7d53ba448ae00e816fdc03dc9f61
MISC metadata.xml 586 BLAKE2B 9425e6a21617f806a0232c7f0ff75f148dc6855679236c9c2b88270db48161d3bffcb32066b372dc6af9cbac594f9d9dce6447d03fc675c151e75982f86ba598 SHA512 cb343dede228edd5c51dc2b2f6b8a1f09e4847365284218d5eb0c23c675f32fe4ab5025c6671f1dafbb63a87b83763a9caf97b04945329c32a1898123149d04b
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild
deleted file mode 100644
index 72f25ef766b6..000000000000
--- a/app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit vim-plugin
-
-DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
-HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
-SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
-
-LICENSE="vim"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="ignore-glep31"
-
-VIM_PLUGIN_HELPFILES="gentoo-syntax"
-VIM_PLUGIN_MESSAGES="filetype"
-
-src_prepare() {
- default
- if use ignore-glep31 ; then
- for f in ftplugin/*.vim ; do
- ebegin "Removing UTF-8 rules from ${f} ..."
- sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
- || die "waah! bad sed voodoo. need more goats."
- eend $?
- done
- fi
-}
-
-pkg_postinst() {
- vim-plugin_pkg_postinst
-
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- if use ignore-glep31 1>/dev/null ; then
- ewarn "You have chosen to disable the rules which ensure GLEP 31"
- ewarn "compliance. When editing ebuilds, please make sure you get"
- ewarn "the character set correct."
- fi
- fi
-}
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20210911.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20211208.ebuild
index 9a1891798a14..9a1891798a14 100644
--- a/app-vim/gentoo-syntax/gentoo-syntax-20210911.ebuild
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20211208.ebuild
diff --git a/app-vim/lustyexplorer/Manifest b/app-vim/lustyexplorer/Manifest
index f0fecda35f2b..5cb851b11753 100644
--- a/app-vim/lustyexplorer/Manifest
+++ b/app-vim/lustyexplorer/Manifest
@@ -1,3 +1,5 @@
+DIST lusty-explorer-5.0.zip 21036 BLAKE2B 6f9918242b5a12a2fd58017c54f10489113b21858e1522e0ff74a7cca41045c08144cb7b69bef2aa5e67998d74bb8472d547421cb737d2fdf79ec1ce4c51db9d SHA512 42aa2dea2d96c88cf65891a08a798c185849695c49663260fd133c34b63311d1db9073d3db2d6e4d1fd6907fdd4cf89335dacb0a5bbaa994924751f5a1be66cf
DIST lustyexplorer-4.3.tar.bz2 17373 BLAKE2B 643eb4c7573932fa63030766670d7c398e307b72e08e93e53e31b7f21086a80196c8d4d7811032b8b945306fcdc7d86d59eb6b48ce0b79f38e628d6b4bec7519 SHA512 24ffa1fe5c1698dfa6093c7cfed2f08540ce130258df5e8ec135356ecea4c1f607f11e643ab859f551e63ecbbf6fc8a615a9514e1d4798b752cc97146c29c661
EBUILD lustyexplorer-4.3-r1.ebuild 848 BLAKE2B 6593f7a5b016f867337acbef13f41c14861b2e22b2e15e4ca94d819adb8f3f98dad8fd335ba085a7fd711a803685fa948818439018b8b9798e295a005cf9606c SHA512 de1b05e0265a1eaac5c6f3b5b8338d6a7742a79fee37dce5d0d2f7487630b17d0259ff46fe1969ee12af19b4ebc346ce187759b39aba4c90d456ead88a451720
+EBUILD lustyexplorer-5.0.ebuild 1029 BLAKE2B c0bbd463db531070c74ba2d10597b1b3c865eb9302e9856a844b328026ffb6104153fb53f4122929a4a6058bdd104b3b8ef3b63f47f7379d0f94178c7792ff8b SHA512 b87de28c5abd97dcf5913cba60306975765cd005e50c322183b370a03c61c7a241f60efa3f3716462e37c89e4bb015717e029e7a0af924ebace0c7d6034f891e
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/lustyexplorer/lustyexplorer-5.0.ebuild b/app-vim/lustyexplorer/lustyexplorer-5.0.ebuild
new file mode 100644
index 000000000000..c2f6ad8affa6
--- /dev/null
+++ b/app-vim/lustyexplorer/lustyexplorer-5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+MY_PN="lusty-explorer"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="vim plugin: dynamic filesystem and buffer explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1890"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=26146 -> ${MY_P}.zip"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="lusty-explorer.txt"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="|| (
+ app-editors/vim[ruby]
+ app-editors/gvim[ruby]
+)"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc || die
+ sed -e '0,/"$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e "s/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/" \
+ plugin/lusty-explorer.vim > doc/lusty-explorer.txt
+}
diff --git a/app-vim/tlib/Manifest b/app-vim/tlib/Manifest
index f159e3248642..4e6ae077cf66 100644
--- a/app-vim/tlib/Manifest
+++ b/app-vim/tlib/Manifest
@@ -1,5 +1,8 @@
+AUX tlib-1.27-fix-error-E1208-vim-8.2.3141.patch 1112 BLAKE2B 66456c43d0b840ec0bbec69404ac209ec5475274571ba0fda0a1e32af71677c860daa81dc9a775f7c1ccbfc8012e6119441da114d1bd38f1db6a351055d84f89 SHA512 7fec706e8a6b9b46e559236c6ba4f784411d078e21f634a8f84bec7df1c2d8e670cdb9330230f63879c3ee71ab05d2324055e55a26520e2428f284f40369021a
DIST tlib-1.22.tar.gz 119979 BLAKE2B 2fe1231b6a075989c41aa2cf38d0964b6d9ada390d0729ea417aa1c2ef1a105a07d569f80c75ba91a55f7e68f349faab2dcda66741b0b1da59f76d68a5467e24 SHA512 b7fc7e3741876c92bbccc116d4e170663e3d178aa8fb546f969475723cd82e07d9470af37574f8f97cfd23b8ca8f5dd5daa2e7bef50e2f62beec0015a2355908
DIST tlib-1.23.tar.gz 120827 BLAKE2B 7b86a1b0e22e499390239e5898d81c90ac1b3b989b929e3bde3ea516d05419fc8af19e72d5313df36ce856a4c7ee2cddbdbecbace835f24adefb1883d4e76e46 SHA512 5fd5d6e6ccd36117abcfca35173d28602a73b0773e5fc77cb8c1c8660f13dd7882c8a8de9b4335927b807c7d643c480f1371926b4ffb1758e53948132dee1d75
+DIST tlib-1.27.tar.gz 124891 BLAKE2B d8d79d1d7bc71e38d2315ab30df414521122cae8c8dfe2e43c8e87bad30685703e09a905d97a00cc2ef01a51369acfde75c37290d971a72d40ec61bce8f1fe31 SHA512 c7037a4aaa4bbb1fede9baea45644a8d1575c5813bc387a293856d8acbe2929cb641d317a4323b295dcc1c0e05091984e6b6eb9a3968503c4cde53580baf994d
EBUILD tlib-1.22.ebuild 585 BLAKE2B b5d087fe5ea43d086e303462e0ed22b813799288b63ce97c6839a59f834ff769f45f2344144fb858125e28f4065c7596a7be881eb5fd2874b4990e9b6a82911f SHA512 71ed5d14775b3b39dd858c91f18c75e23bbc2f22f2b5f2fde18ef8a10d20a38890c02e15d0a8044a5c4e779e40012ef7ce43937c22a06f16ba486a7545cba733
EBUILD tlib-1.23.ebuild 594 BLAKE2B b7b0952a34889833f147814fd3797c1666be3489d87d29cc3872f5c41dd0b246229987dd7cd176047fdfce747b6804d7485080c17f934986377b5ddc12cc3884 SHA512 8e9591d02a2cbc93e0a85cea2fef1903996d809d872dd7488450bab03b4d16cfdf045d67fb5516f9609bc71bdae55cc188b7f7a169919106ccb89182c844199c
+EBUILD tlib-1.27.ebuild 664 BLAKE2B 7e1dc96135703bdf19a9fee8d505712cf7a681c0266f81940119a8ee5e71b5c2ea3d38f3313d518279c0ed64d251c78b0452ee897643fa5cebdb0d7aeeeea34e SHA512 084eed573d567e7cd16868f911831c546e44cd7a857a21f0b9cf82dcce655ceddc74870718d5893eb34fffb78db01335338ec51b2e06177f6f33ee29c187ad27
MISC metadata.xml 330 BLAKE2B 5bc04c4d654f684a4cbc8ab22e825d2704cf62226422deac9f32cb237f78c9b423e671f38df890ddf16e40e6c8228d5a0d29fd1207ac66daf5c1afde2162e947 SHA512 88a742c784330c95d95acd8043847f9f863c89c644de81439a12beaf06afe5e91a974d3ff2426d27d1b837271efe1f56029416fc5e84979927475cfac6612f7c
diff --git a/app-vim/tlib/files/tlib-1.27-fix-error-E1208-vim-8.2.3141.patch b/app-vim/tlib/files/tlib-1.27-fix-error-E1208-vim-8.2.3141.patch
new file mode 100644
index 000000000000..d52314fd6987
--- /dev/null
+++ b/app-vim/tlib/files/tlib-1.27-fix-error-E1208-vim-8.2.3141.patch
@@ -0,0 +1,29 @@
+https://github.com/tomtom/tlib_vim/commit/b5f9f6c83ade9b5640580bf9792a332dd453dfd0
+https://bugs.gentoo.org/828429
+
+From: Laurent Stacul <laurent.stacul@gmail.com>
+Date: Mon, 12 Jul 2021 15:51:16 +0200
+Subject: [PATCH] Fix error E1208 raised by vim >=8.2.3141
+
+Starting vim 8.2.3141 with the tlib_vim plugin will raised the following
+error message at startup:
+
+ Error detected while processing .vim/pack/stac/start/tlib_vim/plugin/02tlib.vim:
+ line 77: E1208: -complete used without -nargsPress ENTER or type command to continue
+
+The reason is the following change in vim:
+
+ https://github.com/vim/vim/commit/de69a7353e9bec552e15dbe3706a9f4e88080fce
+
+Which forbid the com[mand] command with -nargs=0 and -complete options.
+--- a/plugin/02tlib.vim
++++ b/plugin/02tlib.vim
+@@ -74,7 +74,7 @@ command! -nargs=1 -complete=command TBrowseOutput call tlib#cmd#BrowseOutput(<q-
+ "
+ " EXAMPLES: >
+ " TBrowseScriptnames
+-command! -nargs=0 -complete=command TBrowseScriptnames call tlib#cmd#TBrowseScriptnames()
++command! -nargs=0 TBrowseScriptnames call tlib#cmd#TBrowseScriptnames()
+
+
+ " :display: :Texecqfl CMD
diff --git a/app-vim/tlib/tlib-1.27.ebuild b/app-vim/tlib/tlib-1.27.ebuild
new file mode 100644
index 000000000000..aac06503bc74
--- /dev/null
+++ b/app-vim/tlib/tlib-1.27.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+MY_PN=${PN}_vim
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: a library of utility functions"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1863 https://github.com/tomtom/tlib_vim"
+SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+DOCS=( README CHANGES.TXT )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-error-E1208-vim-8.2.3141.patch
+)
+
+src_prepare() {
+ default
+ rm -r test samples || die
+}