summaryrefslogtreecommitdiff
path: root/app-vim/gundo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-vim/gundo
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-vim/gundo')
-rw-r--r--app-vim/gundo/Manifest4
-rw-r--r--app-vim/gundo/files/gundo-2.6.2-python3.patch13
-rw-r--r--app-vim/gundo/gundo-2.6.2-r1.ebuild32
-rw-r--r--app-vim/gundo/gundo-2.6.2.ebuild4
4 files changed, 50 insertions, 3 deletions
diff --git a/app-vim/gundo/Manifest b/app-vim/gundo/Manifest
index 62ffc4c37304..f6e8a3a04fdb 100644
--- a/app-vim/gundo/Manifest
+++ b/app-vim/gundo/Manifest
@@ -1,3 +1,5 @@
+AUX gundo-2.6.2-python3.patch 395 BLAKE2B b39d17b6046f59d9a89fc89f4f6b941fb78777a98525993a046241f780087cf3450833cd966a42354a3d1f26a0171c5ed0d57aa11606ab42c9f04d44aaeafbfc SHA512 0fc80a6ade3a2b53843444a4ec9404d4d1ae54d5add0c5807a49c7a6818282f73c5635df69167a7f5b02da8b198bf83466f7b4da17f5d16f225a72081bd61df5
DIST gundo-2.6.2.tar.bz2 144107 BLAKE2B 7915a60a77e07e49cc1a214c6e250028e61ff33e6f085960836a3e49c1562f4ff713ff4c57125f677d352ae3477bb514fd94d636ee5ba9afac5d23c4ecd70029 SHA512 e03450a1bfb0a7f5013c1493f1b25b963c2bbb37fc8fa24c1b85237bd12847c3edd7b9465caae7bdadf8923dbdcdb24930b160d7824f835417bf30725fa910b4
-EBUILD gundo-2.6.2.ebuild 719 BLAKE2B 53f8930e8cfe0fb472caa944e4533671b4dfabd62beaf2eb3ac5e7a4e2a2a25bcffc168ead957814ac1b8797fcb10d87fcaf138015bfc1f5f65c21b6a6c21a52 SHA512 53a2a407857b8d9d606ada5aae027ba1e525178de1a976122ed0d6960ef886da30313188cfdff5bb09d61d7af6ecedfc6bbb9b2db30c0272ee0e0f81630cc23b
+EBUILD gundo-2.6.2-r1.ebuild 763 BLAKE2B 475944514327afa9c6ded866d535b4087e068ae8bd6f47f61501912f2101628fb011e8ec919da9946524fb10216a29845c228f77af1d783b83e4121b02a8171d SHA512 0d512e790e4cb81ea73e1015c40d86084a485cd084003b71a2fa98465134a6937dbfff649b88eb4300a78cab5b6da63684368504f0a41f545a145e1980c6b3a2
+EBUILD gundo-2.6.2.ebuild 715 BLAKE2B d17f051fd9c56d9e20b91b63ecfc1c14231fe74c22d9847ee01151cf3662810324437d1c44aa7fdbaf57727b5013de447719cff542de3bbc632b4e9a10567d27 SHA512 cc9056ab97e1e31a34176960c782f0f86f242affdc7863c9562f1eee4c623082eda7c91c922dd655808d30985e348bdb923c133bf565c875fa978df8783b11b3
MISC metadata.xml 337 BLAKE2B 08b3c90ab9c289b83c58c3c67fa09f3306082e9d660b8ac81e75f14a44d434fec2657ca4f21ef6660ae46923abe92053a22b404ee9fd443b34775191a999a7e8 SHA512 14459476fa97a611646909941de602646af184e1de555dfff407e71b8fa935c23b5f863b58432be84c31378badabecf8893eafd454d06f8c57759a3bb8035854
diff --git a/app-vim/gundo/files/gundo-2.6.2-python3.patch b/app-vim/gundo/files/gundo-2.6.2-python3.patch
new file mode 100644
index 000000000000..89b7706c8190
--- /dev/null
+++ b/app-vim/gundo/files/gundo-2.6.2-python3.patch
@@ -0,0 +1,13 @@
+Force defaulting to python3.
+
+--- sjl-gundo.vim-6918f8da3839/autoload/gundo.vim
++++ sjl-gundo.vim-6918f8da3839/autoload/gundo.vim
+@@ -44,7 +44,7 @@
+ let g:gundo_close_on_revert = 0
+ endif"}}}
+ if !exists("g:gundo_prefer_python3")"{{{
+- let g:gundo_prefer_python3 = 0
++ let g:gundo_prefer_python3 = 1
+ endif"}}}
+ if !exists("g:gundo_auto_preview")"{{{
+ let g:gundo_auto_preview = 1
diff --git a/app-vim/gundo/gundo-2.6.2-r1.ebuild b/app-vim/gundo/gundo-2.6.2-r1.ebuild
new file mode 100644
index 000000000000..3140f0d8ba4b
--- /dev/null
+++ b/app-vim/gundo/gundo-2.6.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: visualize your vim undo tree"
+HOMEPAGE="https://sjl.bitbucket.io/gundo.vim/"
+SRC_URI="https://bitbucket.org/sjl/gundo.vim/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+ ${PYTHON_DEPS}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=( "${FILESDIR}"/${P}-python3.patch )
+
+src_prepare() {
+ rm -r .gitignore .hg* package.sh README* site tests || die
+ default
+}
diff --git a/app-vim/gundo/gundo-2.6.2.ebuild b/app-vim/gundo/gundo-2.6.2.ebuild
index f9820ba1c6e2..0c3b69a6049a 100644
--- a/app-vim/gundo/gundo-2.6.2.ebuild
+++ b/app-vim/gundo/gundo-2.6.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_6} )
inherit vim-plugin python-single-r1 vcs-snapshot