summaryrefslogtreecommitdiff
path: root/app-vim/gundo/gundo-2.6.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/gundo/gundo-2.6.2-r1.ebuild')
-rw-r--r--app-vim/gundo/gundo-2.6.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-vim/gundo/gundo-2.6.2-r1.ebuild b/app-vim/gundo/gundo-2.6.2-r1.ebuild
new file mode 100644
index 000000000000..3140f0d8ba4b
--- /dev/null
+++ b/app-vim/gundo/gundo-2.6.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: visualize your vim undo tree"
+HOMEPAGE="https://sjl.bitbucket.io/gundo.vim/"
+SRC_URI="https://bitbucket.org/sjl/gundo.vim/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+ ${PYTHON_DEPS}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=( "${FILESDIR}"/${P}-python3.patch )
+
+src_prepare() {
+ rm -r .gitignore .hg* package.sh README* site tests || die
+ default
+}