summaryrefslogtreecommitdiff
path: root/app-vim/gentoo-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-vim/gentoo-syntax
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20220126.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 0705261b7fee..4c572a1db013 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-20211208.tar.bz2 18844 BLAKE2B 52e7025d46f5101f2e1c44afcbf3cba0756a1ec9c626f7af312bb5bbae518645c06c94bfc48822a721e2e3c1ed5f61376e88a074a9688cf4b5b3c352a99c87c9 SHA512 f1cfe2af440f7ed3042cbaa16558cb6df8038f439a2c3e7067f81751a37098854a3afb1653c7c3656ef85ad1874d2db9271429b92a25f494da6ee5c68819e631
+DIST gentoo-syntax-20220126.tar.bz2 19267 BLAKE2B c18f50e29f4aa75e4cc8d629b5086de3cef629b99454389bfe5eecbc61288e4344921360a2d64ea021be7f0269178e6348abf0d1481e0fc8b88e16a16fb73215 SHA512 bbedf2bf98eaf7b80abac2e6a66dcbba2f5024f1a4327535e5d956c4c034fa9be0395a36784a576caeaee81df27eb153687238388bfc2aeaf210498d8377c99d
EBUILD gentoo-syntax-20211208.ebuild 1237 BLAKE2B e4376fc40d3d7c829e253383c0744e4369d312657a539b5d82387128c50c2ae35431207171d9f9a312e7350485c7f2c417d07c665fa345b5193964489a1727f5 SHA512 e692cfa8d4e37e9bfa6bea96c7948e1230a6ebf7bdb7601980e3f918fdec8e69d7e7273e6979ea3ac36446c2c7040e79e09e42d185e8e915d00286cd6c693521
+EBUILD gentoo-syntax-20220126.ebuild 1245 BLAKE2B 71ea9ab3c87dd575d19f1f7986907935bf4c79453e81f5cad8d0024d699235ba31fbf46e1744c66415db38a227efd429707e5f0b7db44b338d628629755c282c SHA512 b5051f6010ce59f50ed6d2ff9746634ec7c41bd942e7fb41143dfc73791b2be9009d56c2aea06762428be47a84b9f84ef563b15c262281b198b8ead24a81be67
EBUILD gentoo-syntax-99999999.ebuild 1084 BLAKE2B cbe1d6aa8eca271a997dec67ba8ba3725e3c50d97ff2f1f18c169bd3ea84ed568390ffef00742d20748dec2ec9b98468a119fc10b62bd55cd05e0506227e58cd SHA512 e59ceccbaaeb0947a66c079380269acd431d9694a20b851c13d5772a610306db1ddb04e8d8173ad5b84723077dae034a60ac7d53ba448ae00e816fdc03dc9f61
MISC metadata.xml 586 BLAKE2B 9425e6a21617f806a0232c7f0ff75f148dc6855679236c9c2b88270db48161d3bffcb32066b372dc6af9cbac594f9d9dce6447d03fc675c151e75982f86ba598 SHA512 cb343dede228edd5c51dc2b2f6b8a1f09e4847365284218d5eb0c23c675f32fe4ab5025c6671f1dafbb63a87b83763a9caf97b04945329c32a1898123149d04b
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20220126.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20220126.ebuild
new file mode 100644
index 000000000000..cc256f13f274
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20220126.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}