summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-vim
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31946 -> 31944 bytes
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20220126.ebuild42
-rw-r--r--app-vim/puppet-syntax/Manifest2
-rw-r--r--app-vim/puppet-syntax/puppet-syntax-3.0.1.ebuild4
5 files changed, 47 insertions, 3 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index cb3f25579961..0971028785eb 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 0705261b7fee..4c572a1db013 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-20211208.tar.bz2 18844 BLAKE2B 52e7025d46f5101f2e1c44afcbf3cba0756a1ec9c626f7af312bb5bbae518645c06c94bfc48822a721e2e3c1ed5f61376e88a074a9688cf4b5b3c352a99c87c9 SHA512 f1cfe2af440f7ed3042cbaa16558cb6df8038f439a2c3e7067f81751a37098854a3afb1653c7c3656ef85ad1874d2db9271429b92a25f494da6ee5c68819e631
+DIST gentoo-syntax-20220126.tar.bz2 19267 BLAKE2B c18f50e29f4aa75e4cc8d629b5086de3cef629b99454389bfe5eecbc61288e4344921360a2d64ea021be7f0269178e6348abf0d1481e0fc8b88e16a16fb73215 SHA512 bbedf2bf98eaf7b80abac2e6a66dcbba2f5024f1a4327535e5d956c4c034fa9be0395a36784a576caeaee81df27eb153687238388bfc2aeaf210498d8377c99d
EBUILD gentoo-syntax-20211208.ebuild 1237 BLAKE2B e4376fc40d3d7c829e253383c0744e4369d312657a539b5d82387128c50c2ae35431207171d9f9a312e7350485c7f2c417d07c665fa345b5193964489a1727f5 SHA512 e692cfa8d4e37e9bfa6bea96c7948e1230a6ebf7bdb7601980e3f918fdec8e69d7e7273e6979ea3ac36446c2c7040e79e09e42d185e8e915d00286cd6c693521
+EBUILD gentoo-syntax-20220126.ebuild 1245 BLAKE2B 71ea9ab3c87dd575d19f1f7986907935bf4c79453e81f5cad8d0024d699235ba31fbf46e1744c66415db38a227efd429707e5f0b7db44b338d628629755c282c SHA512 b5051f6010ce59f50ed6d2ff9746634ec7c41bd942e7fb41143dfc73791b2be9009d56c2aea06762428be47a84b9f84ef563b15c262281b198b8ead24a81be67
EBUILD gentoo-syntax-99999999.ebuild 1084 BLAKE2B cbe1d6aa8eca271a997dec67ba8ba3725e3c50d97ff2f1f18c169bd3ea84ed568390ffef00742d20748dec2ec9b98468a119fc10b62bd55cd05e0506227e58cd SHA512 e59ceccbaaeb0947a66c079380269acd431d9694a20b851c13d5772a610306db1ddb04e8d8173ad5b84723077dae034a60ac7d53ba448ae00e816fdc03dc9f61
MISC metadata.xml 586 BLAKE2B 9425e6a21617f806a0232c7f0ff75f148dc6855679236c9c2b88270db48161d3bffcb32066b372dc6af9cbac594f9d9dce6447d03fc675c151e75982f86ba598 SHA512 cb343dede228edd5c51dc2b2f6b8a1f09e4847365284218d5eb0c23c675f32fe4ab5025c6671f1dafbb63a87b83763a9caf97b04945329c32a1898123149d04b
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20220126.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20220126.ebuild
new file mode 100644
index 000000000000..cc256f13f274
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20220126.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}
diff --git a/app-vim/puppet-syntax/Manifest b/app-vim/puppet-syntax/Manifest
index 6c238cfa0971..7700f238a2c6 100644
--- a/app-vim/puppet-syntax/Manifest
+++ b/app-vim/puppet-syntax/Manifest
@@ -1,3 +1,3 @@
DIST puppet-syntax-3.0.1.tar.gz 3548 BLAKE2B b053234203b45cf1748cc72e329c35322dfa48a4d7b39261301398a8d1026035e929a7afe3fa80d59ef67472ebfc317442250e0aa0292047ab38eda9860600b9 SHA512 fb96360e784da578d2ab77a021befe874644cf964c1ca2d8b34b316296872a67679606ad0dfd4ab90027b7d259900af20d831d5e3359d76649e0c6f43546938b
-EBUILD puppet-syntax-3.0.1.ebuild 556 BLAKE2B a21416a8914d63d3547c1d119ef1012c6a8995d9eae892ff5111833e397241a7d348da8b2f2c9f3151c7ed00c724f235412916dff035ba6fd1aca9080861a60e SHA512 32eb1a56d6ca70e2fbfc0629c82b7144e7917fd96736b73a42230c0e44067d105915774e0849c19963dc0cd7c099f3100a11be8701bf5c46ca2b421b533830f0
+EBUILD puppet-syntax-3.0.1.ebuild 563 BLAKE2B e6136f98b4a82a98818b2c66b19c2ca307989fdbf988597c27a5ba2200d7e31f87ce1c673ddf90d462adad6dd8df33a734a9ba4964838a464f8367737715bac8 SHA512 3a556adfbd9fae00b100b9028475710b50235eea974f5d611176343f0edca886078ca34d02da3df5b5ec516ebd18d8cffb789623feb94adbf9c1e968f5de32a6
MISC metadata.xml 364 BLAKE2B 02e595eed1d040b52b80d0c63f576873a2f775bef8565a7c433382d294c36eb69d2104850701414800e9e4e66f89dd8908983821ffda334e8d32b40a9690a3b8 SHA512 066d6586798789d1d35d20ab12d38d3328575730bb55f5fe9ebe9da541106e1cdb7b00f144d71c124319ca3bd5e6ecd1537b4b3e323cffb2dcc07bf861799350
diff --git a/app-vim/puppet-syntax/puppet-syntax-3.0.1.ebuild b/app-vim/puppet-syntax/puppet-syntax-3.0.1.ebuild
index a872aab1aad0..937762aa8d22 100644
--- a/app-vim/puppet-syntax/puppet-syntax-3.0.1.ebuild
+++ b/app-vim/puppet-syntax/puppet-syntax-3.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ DESCRIPTION="vim plugin: Puppet configuration files syntax"
HOMEPAGE="http://puppetlabs.com/"
SRC_URI="https://dev.gentoo.org/~tampakrap/tarballs/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
-KEYWORDS="amd64 ~arm ~hppa ppc ~ppc64 sparc x86 ~amd64-linux ~x64-macos ~x64-solaris"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ~ppc64 sparc x86 ~amd64-linux ~x64-macos ~x64-solaris"
VIM_PLUGIN_HELPTEXT=\
"This plugin provides syntax highlighting for Puppet configuration