summaryrefslogtreecommitdiff
path: root/app-vim/fugitive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /app-vim/fugitive
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'app-vim/fugitive')
-rw-r--r--app-vim/fugitive/Manifest4
-rw-r--r--app-vim/fugitive/fugitive-2.3.ebuild22
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild4
3 files changed, 27 insertions, 3 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
index 8848022072cd..ff70228015f8 100644
--- a/app-vim/fugitive/Manifest
+++ b/app-vim/fugitive/Manifest
@@ -1,4 +1,6 @@
DIST fugitive-2.2.tar.gz 30651 BLAKE2B 7e6ecf372661afcfa586097e979c996f19df85bf41d3b2409e26fe9131a48c02946614a15231accecbe8906a458698f89b66cc86f3707f2f7014e00d795786fe SHA512 763fc352e495dae6346fdedee5e3993a11fe402dbad0e9ee4b002b6b416404c46b56a061b3d9e663174b371d2d62e62e22f5a2cf8767fb6aee28b236c77d9d41
+DIST fugitive-2.3.tar.gz 30949 BLAKE2B ff62ad9f5b85fff6a06fe006884901ca0f80a5ee139032955a6af596cadf3dca18d73980da12429706102cbe8105fcbff5fb1dd6375b851f978746a5251f1d22 SHA512 8a176705c0326ac034abaf23423e58d490feb7f11dc45ad23641fafb95279094ed38475a90e7c2e7fc95c615558db75f3587740e2658f3988fa07a1957aa1039
EBUILD fugitive-2.2.ebuild 623 BLAKE2B 3c7b51661511b4492dd76e7d1cf3976a748df0b33f9b096aaf67bc9f71aa7c44e15a94def16d318082852a7566388d71e842231dcb1648a0b05e1a99f0f96a0b SHA512 fe94a114cb46b74cbcbf65287f97d23a037e1fb9472b1e7039735410ce067f623986e4bcbcf3fcf3df459959fdf09f584a2f0e84a27027de3428e3c9f0ed944c
-EBUILD fugitive-9999.ebuild 623 BLAKE2B 3c7b51661511b4492dd76e7d1cf3976a748df0b33f9b096aaf67bc9f71aa7c44e15a94def16d318082852a7566388d71e842231dcb1648a0b05e1a99f0f96a0b SHA512 fe94a114cb46b74cbcbf65287f97d23a037e1fb9472b1e7039735410ce067f623986e4bcbcf3fcf3df459959fdf09f584a2f0e84a27027de3428e3c9f0ed944c
+EBUILD fugitive-2.3.ebuild 625 BLAKE2B 6e7c331e9a28fe7c67b150de5102f0cdca594eeb48a5dcd3baef0bd08463178daf17e1f8e30c8567d9424b2fb17139276ecf8c2b968c3e56cadcc6df84a29229 SHA512 bffbeccb7b980ac471f5b67cc4408aca6ee36e272ec61e7e5eeb205ec89b9999f2358e906aa49033bc2fb981717caa882de3b80086ec94d5c69b1254f6d8d333
+EBUILD fugitive-9999.ebuild 625 BLAKE2B 6e7c331e9a28fe7c67b150de5102f0cdca594eeb48a5dcd3baef0bd08463178daf17e1f8e30c8567d9424b2fb17139276ecf8c2b968c3e56cadcc6df84a29229 SHA512 bffbeccb7b980ac471f5b67cc4408aca6ee36e272ec61e7e5eeb205ec89b9999f2358e906aa49033bc2fb981717caa882de3b80086ec94d5c69b1254f6d8d333
MISC metadata.xml 342 BLAKE2B cef6ff7e21df2703dc1c1138f95ad5f8e478a7c6bbd013791fd7c1b1754a2f7eaac9c84ebb42af9cef1943e7a94a880d0cedc030ff95966ac607a1b0b37dc37f SHA512 4ad3c706ea17ef2ab4e6852c6251cec3b8b5b37b687cd3ed87061adbfb791b8786bb5faa4550a73c707a0013ad8981aeda930eba8d74221cc7ca33d110ceb842
diff --git a/app-vim/fugitive/fugitive-2.3.ebuild b/app-vim/fugitive/fugitive-2.3.ebuild
new file mode 100644
index 000000000000..3ec007ea68be
--- /dev/null
+++ b/app-vim/fugitive/fugitive-2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
index 5f7552c24ee8..3ec007ea68be 100644
--- a/app-vim/fugitive/fugitive-9999.ebuild
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit vim-plugin
if [[ ${PV} == 9999 ]]; then
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]]; then
else
inherit vcs-snapshot
SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
fi
DESCRIPTION="vim plugin: a git wrapper for vim"