summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /app-vim
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin32602 -> 32609 bytes
-rw-r--r--app-vim/fugitive/Manifest4
-rw-r--r--app-vim/fugitive/fugitive-2.3.ebuild22
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild4
-rw-r--r--app-vim/jedi/Manifest2
-rw-r--r--app-vim/jedi/jedi-0.8_p20171015.ebuild4
-rw-r--r--app-vim/pyclewn/Manifest2
-rw-r--r--app-vim/pyclewn/pyclewn-2.1-r1.ebuild2
8 files changed, 32 insertions, 8 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index e966fcbac7ef..181c52d77a8d 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
index 8848022072cd..ff70228015f8 100644
--- a/app-vim/fugitive/Manifest
+++ b/app-vim/fugitive/Manifest
@@ -1,4 +1,6 @@
DIST fugitive-2.2.tar.gz 30651 BLAKE2B 7e6ecf372661afcfa586097e979c996f19df85bf41d3b2409e26fe9131a48c02946614a15231accecbe8906a458698f89b66cc86f3707f2f7014e00d795786fe SHA512 763fc352e495dae6346fdedee5e3993a11fe402dbad0e9ee4b002b6b416404c46b56a061b3d9e663174b371d2d62e62e22f5a2cf8767fb6aee28b236c77d9d41
+DIST fugitive-2.3.tar.gz 30949 BLAKE2B ff62ad9f5b85fff6a06fe006884901ca0f80a5ee139032955a6af596cadf3dca18d73980da12429706102cbe8105fcbff5fb1dd6375b851f978746a5251f1d22 SHA512 8a176705c0326ac034abaf23423e58d490feb7f11dc45ad23641fafb95279094ed38475a90e7c2e7fc95c615558db75f3587740e2658f3988fa07a1957aa1039
EBUILD fugitive-2.2.ebuild 623 BLAKE2B 3c7b51661511b4492dd76e7d1cf3976a748df0b33f9b096aaf67bc9f71aa7c44e15a94def16d318082852a7566388d71e842231dcb1648a0b05e1a99f0f96a0b SHA512 fe94a114cb46b74cbcbf65287f97d23a037e1fb9472b1e7039735410ce067f623986e4bcbcf3fcf3df459959fdf09f584a2f0e84a27027de3428e3c9f0ed944c
-EBUILD fugitive-9999.ebuild 623 BLAKE2B 3c7b51661511b4492dd76e7d1cf3976a748df0b33f9b096aaf67bc9f71aa7c44e15a94def16d318082852a7566388d71e842231dcb1648a0b05e1a99f0f96a0b SHA512 fe94a114cb46b74cbcbf65287f97d23a037e1fb9472b1e7039735410ce067f623986e4bcbcf3fcf3df459959fdf09f584a2f0e84a27027de3428e3c9f0ed944c
+EBUILD fugitive-2.3.ebuild 625 BLAKE2B 6e7c331e9a28fe7c67b150de5102f0cdca594eeb48a5dcd3baef0bd08463178daf17e1f8e30c8567d9424b2fb17139276ecf8c2b968c3e56cadcc6df84a29229 SHA512 bffbeccb7b980ac471f5b67cc4408aca6ee36e272ec61e7e5eeb205ec89b9999f2358e906aa49033bc2fb981717caa882de3b80086ec94d5c69b1254f6d8d333
+EBUILD fugitive-9999.ebuild 625 BLAKE2B 6e7c331e9a28fe7c67b150de5102f0cdca594eeb48a5dcd3baef0bd08463178daf17e1f8e30c8567d9424b2fb17139276ecf8c2b968c3e56cadcc6df84a29229 SHA512 bffbeccb7b980ac471f5b67cc4408aca6ee36e272ec61e7e5eeb205ec89b9999f2358e906aa49033bc2fb981717caa882de3b80086ec94d5c69b1254f6d8d333
MISC metadata.xml 342 BLAKE2B cef6ff7e21df2703dc1c1138f95ad5f8e478a7c6bbd013791fd7c1b1754a2f7eaac9c84ebb42af9cef1943e7a94a880d0cedc030ff95966ac607a1b0b37dc37f SHA512 4ad3c706ea17ef2ab4e6852c6251cec3b8b5b37b687cd3ed87061adbfb791b8786bb5faa4550a73c707a0013ad8981aeda930eba8d74221cc7ca33d110ceb842
diff --git a/app-vim/fugitive/fugitive-2.3.ebuild b/app-vim/fugitive/fugitive-2.3.ebuild
new file mode 100644
index 000000000000..3ec007ea68be
--- /dev/null
+++ b/app-vim/fugitive/fugitive-2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
index 5f7552c24ee8..3ec007ea68be 100644
--- a/app-vim/fugitive/fugitive-9999.ebuild
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit vim-plugin
if [[ ${PV} == 9999 ]]; then
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]]; then
else
inherit vcs-snapshot
SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
fi
DESCRIPTION="vim plugin: a git wrapper for vim"
diff --git a/app-vim/jedi/Manifest b/app-vim/jedi/Manifest
index 5e05f5da398a..3d5a3442c714 100644
--- a/app-vim/jedi/Manifest
+++ b/app-vim/jedi/Manifest
@@ -1,3 +1,3 @@
DIST jedi-0.8_p20171015.zip 43567 BLAKE2B 6065e2df567159054d99ec502ddb8ec8103e0892c9f78f6bbc2e72cad6cb3fe37d86882a72135f238fd47a747e03275aa82edee9d954459194940e8a69e1a775 SHA512 d69fa77ada22b0c75b7ec4ad1765035454312707ffb0f8a0bb0de4928e5fd21b08e39ab28b3f0ff9b37c8eb5389bc44c507fa2a08c0322510a57a91d7de028e6
-EBUILD jedi-0.8_p20171015.ebuild 820 BLAKE2B 483755839274226e13a13dfa02604534e0f2aaa1023cd968e8d513677398a931b4cc14b2f6ce37d1a32ef300088742323f0f68c68702099ab020e082102c85c3 SHA512 c76ac7e9b50476fb566b0f0160f215c5da8db9b80ed401e2d36f8c31bd66a8e9303e40244cbaafa59e77994e2bebf7ed25117660d85ad98457f5df94d0988207
+EBUILD jedi-0.8_p20171015.ebuild 824 BLAKE2B 4f953be2d3ce9601f944e849ad9fd0800304fd32cc5154bbffc4f2198cdfce55a1c6e3cbbe332e32999213a0d63a2e7a89878dfadd531955ea728fefc0111a71 SHA512 056d95e45463e930982698c031510c0b36d6276fd6870a617db179d3e8630a4793d1d3dc773adc20bc36e0ce7bcb34a06e99eb0cbb41239f630c22a91cffa99f
MISC metadata.xml 740 BLAKE2B 82dbee0d839faa814f29236625da3bed8eaf6abf8e286c15800ae43758a017394e0b714896b721104213546554f56597a68556dec22038a730423df9a215963b SHA512 145652296b05261952034b26cf36a6fdabee22cdccf4b85914c383e1fde270ca66fcc0b5cae43294907b0730005eb3ce87feb39b716f89740277a9a133229142
diff --git a/app-vim/jedi/jedi-0.8_p20171015.ebuild b/app-vim/jedi/jedi-0.8_p20171015.ebuild
index da57a94f10e6..f72dd11f5839 100644
--- a/app-vim/jedi/jedi-0.8_p20171015.ebuild
+++ b/app-vim/jedi/jedi-0.8_p20171015.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit vim-plugin python-r1 python-utils-r1
diff --git a/app-vim/pyclewn/Manifest b/app-vim/pyclewn/Manifest
index 3af0b884e723..ceb4ff37d5c7 100644
--- a/app-vim/pyclewn/Manifest
+++ b/app-vim/pyclewn/Manifest
@@ -1,5 +1,5 @@
DIST pyclewn-2.0.1.tar.gz 124914 BLAKE2B e1dc12174d2ac640476a36714a8ef221f64db4b19c9509a179bc0cf573200de0f1f888bcc3bb69f433064e2de2d881845099f609468e12ed72e5c547623d44e5 SHA512 996acbedbb7922109925f188efba4c71e83f1823c029f92dc00bb21449f024232ef55df0c74a9fd4bfa7229523ed9ad4301aa9dbb8a3c20424082fc6939f63db
DIST pyclewn-2.1.tar.gz 129697 BLAKE2B 0dfef92cb36ea9fa89c7f0d85ed45e21c634732fc2d3d888dd792de22529bea86719f8ac8ed870dd5ab00efbfdb08011013a36880781abf9e0c64a62b2aa301a SHA512 346b98a9e37957a5bf97b8901247f56fa8e38bddac38727867773cf4e78e555d6a85848c4c400d1faf1159ba61122cfd4931c95a67e3b2abdfaae7996beb4f1b
EBUILD pyclewn-2.0.1.ebuild 1057 BLAKE2B 1412bfe77432b791290c9a4d707fcc3c41c17384e4f35fb730d920a3c7dec35f4a7c674e2a107ec952413f88d1eb837c262b9fd9dc35c4c3b104bc29a52fcf83 SHA512 729fe02cffcd975dc3735c5c003bfb8db1d5b1044ff395afb776de09efc0c2dac828cb74600acec811a5e311fa27f096641c03cea19f6bd2d92c2e107f1c271e
-EBUILD pyclewn-2.1-r1.ebuild 1116 BLAKE2B 4637900400393b6a8eead88bbc54a31360860c0e98345c137ae9d2072b9663d6697ebf36e678d8b28552be2da1cc06705b8cd309b548bdadc1a558d9636a093f SHA512 11ad4ba21d3cb91139a06c03b9eaf1f75c9df67ea777c48244ab8486c04a8b9a9efc7f78353a1871d766302ea277f13d63de8b58a5d9b5d0cfb223485ab1857a
+EBUILD pyclewn-2.1-r1.ebuild 1120 BLAKE2B 5bb45ffde48cb5571ef0c529b3017bfca6205cf6b0a17a0f111229525b1b76efcb0f741a3ea9f9a1dee5c6c1632521688f33844f4f0f62b7e1b015fbbffafd2c SHA512 d9671d291b255388bb8f6d2de19f6e7177cb6a3f322d72fa640a747c6bfde9e32f8e3d780632902872c5753b6c1f920be5a11fe11196fb647d21888e783a851f
MISC metadata.xml 499 BLAKE2B 4955bd7a080dc2ae909143477040d191cb48ab4badfd47b6b7c11fd4686139bbbe77475f005e10c3b2bba50d0615b94600a55cda57a7d02ecaaffe1e504219dd SHA512 30b127677f0d5a9afce208e5cbb00c9b98f6d7e771ef273155f9acad764da789e71249289104e8006420cf5ff62075bb7572527150f9b339e0e51cb219c76a81
diff --git a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild b/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
index 63b9b959aa2b..403ecdc6fe16 100644
--- a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
+++ b/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit eutils vim-plugin distutils-r1