summaryrefslogtreecommitdiff
path: root/app-vim/fugitive/fugitive-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/fugitive/fugitive-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/fugitive/fugitive-9999.ebuild')
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
new file mode 100644
index 000000000000..71ee67fe65df
--- /dev/null
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"