summaryrefslogtreecommitdiff
path: root/app-vim/fugitive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/fugitive
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/fugitive')
-rw-r--r--app-vim/fugitive/Manifest6
-rw-r--r--app-vim/fugitive/fugitive-2.2.ebuild22
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild22
-rw-r--r--app-vim/fugitive/metadata.xml11
4 files changed, 61 insertions, 0 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
new file mode 100644
index 000000000000..0567fe9aafa7
--- /dev/null
+++ b/app-vim/fugitive/Manifest
@@ -0,0 +1,6 @@
+DIST fugitive-2.2.tar.gz 30651 SHA256 8417dac31c1d444547ac6ae5c016ccafa1f7a061495c2190820d81c8a6244cd0 SHA512 763fc352e495dae6346fdedee5e3993a11fe402dbad0e9ee4b002b6b416404c46b56a061b3d9e663174b371d2d62e62e22f5a2cf8767fb6aee28b236c77d9d41 WHIRLPOOL 3df739ad9bd1ea6562275065fbab973554f4aae2c01c80fffe5d6b2b1a8c4e71ade4ad9c23abc615ab4bdba4b3b83382ec229924bb39acbac934a22568cd1b8c
+EBUILD fugitive-2.2.ebuild 622 SHA256 69450bbc073b450730bda19799761a0ac583e23a9e7deaa5a2ca4896b8e8cb30 SHA512 6853dda72a463010abf304eeed07e68735c2a3da95cb4fe5fca29519b19fd7264ab6f6c3bda1ee607fe5b1c0305e2f4a7497bbf347afe3ea623630067caaf2e7 WHIRLPOOL 2ba1798ca7dcd6335c8ca373d8e2fd99d133cda3ba154dfc2bc4c8a82f5758e3137e41c95db43c65ff02da410f410418be79c409010398a2e176178b23ba6e5d
+EBUILD fugitive-9999.ebuild 622 SHA256 69450bbc073b450730bda19799761a0ac583e23a9e7deaa5a2ca4896b8e8cb30 SHA512 6853dda72a463010abf304eeed07e68735c2a3da95cb4fe5fca29519b19fd7264ab6f6c3bda1ee607fe5b1c0305e2f4a7497bbf347afe3ea623630067caaf2e7 WHIRLPOOL 2ba1798ca7dcd6335c8ca373d8e2fd99d133cda3ba154dfc2bc4c8a82f5758e3137e41c95db43c65ff02da410f410418be79c409010398a2e176178b23ba6e5d
+MISC ChangeLog 2867 SHA256 f95649287c39813a7ee5544371148964220e497a55114fe5958d62b8a03f90b0 SHA512 4de2d3e180e585cdbaa271f8c73d4c666ed0a4d60e2db5f7d933bf9404ca13646775f02b5eb2fa30dbdbda34a5ebac3de38b4a29d5358000b1fa3097bff92b73 WHIRLPOOL fd0090c6316c762a43ddfd686bc31829da85d2104db8a54b3e97b6d20dc5f04e17e94ec7b2efee2efeeec21201966ed59b3d784576372e4d1a2f0d7b0e6e6936
+MISC ChangeLog-2015 1864 SHA256 2aa93e67a0d325283a75316114c04b9f43e93181a83e2b4044bb1f556bbb6e3e SHA512 5a9f7a0a3c10e0af55cf6a94628a24f85a7f043c08a1f98a8f1c0bead4bbf14ce46660a214a278a54d36f48d26c37d290cc8c48a9a8041cbfac6a2141f89a7b9 WHIRLPOOL 9e1c917d2383920c6a9d07fd71866b2ce40a8daf1ca2c7bf3e38cf0e7c3050d3edab2f0815227d1abf4e187e454b03f07e888fbf1526cc48a7dc06499a5c62c8
+MISC metadata.xml 342 SHA256 74413c4c8815375620bba9f2ee00e3d6b6b070c4d8d8a9c8bf1032bb52f61a2b SHA512 4ad3c706ea17ef2ab4e6852c6251cec3b8b5b37b687cd3ed87061adbfb791b8786bb5faa4550a73c707a0013ad8981aeda930eba8d74221cc7ca33d110ceb842 WHIRLPOOL 1b4df42ab5c89568e4f0e00a5ab6acfcd69f015ea04ba3a1bf418afe179c49c3c1fe41a648a4f8fb5893bb51e88643b464f0b2231344d71c48281d61ea9636f3
diff --git a/app-vim/fugitive/fugitive-2.2.ebuild b/app-vim/fugitive/fugitive-2.2.ebuild
new file mode 100644
index 000000000000..71ee67fe65df
--- /dev/null
+++ b/app-vim/fugitive/fugitive-2.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
new file mode 100644
index 000000000000..71ee67fe65df
--- /dev/null
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/metadata.xml b/app-vim/fugitive/metadata.xml
new file mode 100644
index 000000000000..84e14fd03b22
--- /dev/null
+++ b/app-vim/fugitive/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tpope/vim-fugitive</remote-id>
+ </upstream>
+</pkgmetadata>