summaryrefslogtreecommitdiff
path: root/app-vim/fugitive/fugitive-3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-08 23:33:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-08 23:33:13 +0100
commit900dd293f8087dff1643b45d7b836702a9ea8fd9 (patch)
tree0829d8047ff5fda91e78e53de3bd01c094d837b8 /app-vim/fugitive/fugitive-3.7.ebuild
parent02f2b9c649c1687088b6ccb6d30b35f519f107cf (diff)
gentoo auto-resync : 08:04:2023 - 23:33:13
Diffstat (limited to 'app-vim/fugitive/fugitive-3.7.ebuild')
-rw-r--r--app-vim/fugitive/fugitive-3.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/fugitive/fugitive-3.7.ebuild b/app-vim/fugitive/fugitive-3.7.ebuild
new file mode 100644
index 000000000000..e0e4ec9939dc
--- /dev/null
+++ b/app-vim/fugitive/fugitive-3.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+
+LICENSE="vim"
+SLOT="0"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"