summaryrefslogtreecommitdiff
path: root/app-vim/fugitive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-08 23:33:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-08 23:33:13 +0100
commit900dd293f8087dff1643b45d7b836702a9ea8fd9 (patch)
tree0829d8047ff5fda91e78e53de3bd01c094d837b8 /app-vim/fugitive
parent02f2b9c649c1687088b6ccb6d30b35f519f107cf (diff)
gentoo auto-resync : 08:04:2023 - 23:33:13
Diffstat (limited to 'app-vim/fugitive')
-rw-r--r--app-vim/fugitive/Manifest4
-rw-r--r--app-vim/fugitive/fugitive-3.7.ebuild25
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild7
3 files changed, 33 insertions, 3 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
index 657357a1c4d7..66401051e509 100644
--- a/app-vim/fugitive/Manifest
+++ b/app-vim/fugitive/Manifest
@@ -1,4 +1,6 @@
DIST fugitive-3.4.tar.gz 80677 BLAKE2B 7cb341851248eb05a8094617f349e382cb8704f69116d8a00f07db40d96b4cc86b98515a59c489116fe7fdadb9a73a65819bf792005bda316f1a0bca311e6938 SHA512 313f1b06c843f85cfdbee059f1470b1ed062c2055e552fa1e05b01e59d9950c181b19e7553cbbca575b1951949970691081582128be7148885485d4fbed0a4d2
+DIST fugitive-3.7.tar.gz 84271 BLAKE2B 1c00272174bd76a2b4d34aa54a7498b2f75a5322d587e3436d82f21d6188027768bea0475c99fcbc50a82b89d9a9a7697d18106cb1eb2f9788afa81848fe2de8 SHA512 8252b69c6183f5b710739eb68ecb3fbdfad52df3dbee0a3a04ad33f410b489d7fcf1c0bde0cb2d53995a6b4e34191c165c652d08e6145789a88f8c46bfcddf56
EBUILD fugitive-3.4.ebuild 623 BLAKE2B fcc6f0d03de813c484835ec024214307b05f0f19693cedadb3c462937fd5802265002ee94360a15a844466a66067e4cf04e567f15060ae64538589d73f160424 SHA512 433673db4c18480be1e4bf863d344f957353c84c1596cd2107202b24fcb6073cfa99cf0505bf9e7a3585ffbf2f40237ae4fb342dc687cbba7fd33835e7facaa4
-EBUILD fugitive-9999.ebuild 625 BLAKE2B d429d4e0ea98e6d35c91c17cef0c59f1bf27a0fa6adcb120d808cae0e7cec60dd2e438e83a07ed40c401423fbde4ed4f2fe016f54d21ec52ceddd32223d82a84 SHA512 ddc4ccdb0f6e345ef5d20fb53e5e34e02d451934b51c0db99048e4718ca71532a9d842337513f6d897f2b7d84465fd717f90779c7a7f5b2e0803ab9b8addd284
+EBUILD fugitive-3.7.ebuild 636 BLAKE2B b96e40e319f06e9b527c8290ec707d6047ddfe1fe1b8f26c8cd58c8cf57cf43b60ae6775fc7b8edc712cf7c6c5a2e194be85a08efed955d9fd5b2fe376d73797 SHA512 5a39e9f04d72ce81f97d6fdb12b20efc49b168e9f37983b1dcdf94a6e4e17c3a44359ef3ca97118f9f6958bf7265943f6361aa308f2bb654fbe824615aec45cb
+EBUILD fugitive-9999.ebuild 636 BLAKE2B b96e40e319f06e9b527c8290ec707d6047ddfe1fe1b8f26c8cd58c8cf57cf43b60ae6775fc7b8edc712cf7c6c5a2e194be85a08efed955d9fd5b2fe376d73797 SHA512 5a39e9f04d72ce81f97d6fdb12b20efc49b168e9f37983b1dcdf94a6e4e17c3a44359ef3ca97118f9f6958bf7265943f6361aa308f2bb654fbe824615aec45cb
MISC metadata.xml 343 BLAKE2B 14d84b683c5ba0998876e7711a4afb8d5f23bfe72cd54b80d73dfb05eb5fb19dbd9e1927cb9fb56a4eda13292343a8cce56d67476daa4b5262193279517a159b SHA512 00c0719b8ea84f7aac1ea31b852ea2ebb6c724999329f3d0693f447aa1c278924318c0eca12c183340b19e848ce40873f7ec9c3bdf9a3f1c9f7a15fa98d78bd9
diff --git a/app-vim/fugitive/fugitive-3.7.ebuild b/app-vim/fugitive/fugitive-3.7.ebuild
new file mode 100644
index 000000000000..e0e4ec9939dc
--- /dev/null
+++ b/app-vim/fugitive/fugitive-3.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+
+LICENSE="vim"
+SLOT="0"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
index 0d4da8993529..e0e4ec9939dc 100644
--- a/app-vim/fugitive/fugitive-9999.ebuild
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit vim-plugin
if [[ ${PV} == 9999 ]]; then
@@ -15,7 +16,9 @@ fi
DESCRIPTION="vim plugin: a git wrapper for vim"
HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+
LICENSE="vim"
+SLOT="0"
VIM_PLUGIN_HELPFILES="${PN}.txt"