summaryrefslogtreecommitdiff
path: root/app-vim/bufexplorer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/bufexplorer
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/bufexplorer')
-rw-r--r--app-vim/bufexplorer/Manifest6
-rw-r--r--app-vim/bufexplorer/bufexplorer-7.4.18.ebuild19
-rw-r--r--app-vim/bufexplorer/bufexplorer-7.4.19.ebuild19
-rw-r--r--app-vim/bufexplorer/bufexplorer-9999.ebuild25
-rw-r--r--app-vim/bufexplorer/metadata.xml11
5 files changed, 80 insertions, 0 deletions
diff --git a/app-vim/bufexplorer/Manifest b/app-vim/bufexplorer/Manifest
new file mode 100644
index 000000000000..f86f4d8ff46c
--- /dev/null
+++ b/app-vim/bufexplorer/Manifest
@@ -0,0 +1,6 @@
+DIST bufexplorer-7.4.18.tar.gz 25117 BLAKE2B 2768f7fdc31b4678147d492f3322cf12f97384f3fab4f5219f7237263e83060d24b476c25dabc6850aa6b6168f98b4350c3dfe0fd61a3975a6e607ac4e11e3e4 SHA512 420e3d352bb31a80311c3ab8ad62f7a6530fdcf78eb0bc45717e075f81a3d1a42fef18d756c129d2c25e8d5f7d8e1161affae905cfa7d8b0d1d3c9245c9f1bea
+DIST bufexplorer-7.4.19.tar.gz 25679 BLAKE2B 814adb79fc196174a9915643a3617e3c324f963792a2706f59f35699289524d0b93e7337ec3697d03e3a98b9f15018d40dbf9c0d4f35d6cebde8ea6de4cf1b23 SHA512 d38bcb52a50cfcf6d0b66ca6f1290a6be53d5cee98b3d2d7a93e01b5ef904af53c6cc8256e667bdeeb23a58344f5d69838bb7b5d71d225a83d1e173b99344888
+EBUILD bufexplorer-7.4.18.ebuild 504 BLAKE2B ee68329b9446ebf1c7571af162de167dae2ea85fcdbc1b9ac88cbb623bdf9cb728d1ef7fe296be1309542dd5ea01c68a72effaf920274f2a8b731ef26db4c168 SHA512 90dc950091b57c65896ff66b77e3b65671cbb21ae37f878445b3771153ce9509dcc5984fe0c3734ae693ca04518328b8517312188eb691a03ef4066df06752ff
+EBUILD bufexplorer-7.4.19.ebuild 506 BLAKE2B 8bd50099f3da4d4841089e63f9634f480190c4e5ef0a73ddb3d7f181ebb3ae32a72970fc51df72d7c3e31e46c288f69ac470095e246855f36838f82235670038 SHA512 b396c84c4fda3fbd12d1a91a96012c1cae337c8db7bd2eef56e70b79ac3d45645e20139f049c8749cec6d146eac0487c6469b6d97d67a30674a15c24e67ca5cc
+EBUILD bufexplorer-9999.ebuild 629 BLAKE2B 1bb452f22f906ffa14e6dec853dd5dfe14a478cde4c4e7a47984d42ac12e14b338423bdce9869c5643d4a4f30efab691018f6c8c11fff5714dfbd60e110965dc SHA512 7fe257c7df973c65d80920d2af28c710e21a8f3337628b517faa546de954b27b1303be55334b0c89cbbcb814b8cc40c4a6a75d667b501df8018de803764d919b
+MISC metadata.xml 337 BLAKE2B 1f7ff65f6508fb9463322cbf6d76f55455dd281dbc5b1227fea6f066e0c197216cbc775373fef3a8d8bece89f39b84ff5546ab5b3ee0ffe6244ddb482e51d2ef SHA512 31c66f4059fd32f6521fa33b6d655d6d006a71b6d14fc008e4dbe2cc1b93bd3fe5a8055105afcef07f38845377ebee7ecb41d0f92cf7da73e020dcf72216590e
diff --git a/app-vim/bufexplorer/bufexplorer-7.4.18.ebuild b/app-vim/bufexplorer/bufexplorer-7.4.18.ebuild
new file mode 100644
index 000000000000..c286927dffc5
--- /dev/null
+++ b/app-vim/bufexplorer/bufexplorer-7.4.18.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easily browse vim buffers"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=42 https://github.com/jlanzarotta/bufexplorer"
+SRC_URI="https://github.com/jlanzarotta/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm LICENSE README.md || die
+}
diff --git a/app-vim/bufexplorer/bufexplorer-7.4.19.ebuild b/app-vim/bufexplorer/bufexplorer-7.4.19.ebuild
new file mode 100644
index 000000000000..9447a5bc849d
--- /dev/null
+++ b/app-vim/bufexplorer/bufexplorer-7.4.19.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easily browse vim buffers"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=42 https://github.com/jlanzarotta/bufexplorer"
+SRC_URI="https://github.com/jlanzarotta/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm LICENSE README.md || die
+}
diff --git a/app-vim/bufexplorer/bufexplorer-9999.ebuild b/app-vim/bufexplorer/bufexplorer-9999.ebuild
new file mode 100644
index 000000000000..e285e23f86cd
--- /dev/null
+++ b/app-vim/bufexplorer/bufexplorer-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jlanzarotta/bufexplorer.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jlanzarotta/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: easily browse vim buffers"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=42 https://github.com/jlanzarotta/bufexplorer"
+LICENSE="BSD"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm LICENSE README.md || die
+}
diff --git a/app-vim/bufexplorer/metadata.xml b/app-vim/bufexplorer/metadata.xml
new file mode 100644
index 000000000000..5c41162e1690
--- /dev/null
+++ b/app-vim/bufexplorer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jlanzarotta/bufexplorer</remote-id>
+ </upstream>
+</pkgmetadata>