summaryrefslogtreecommitdiff
path: root/app-vim/bash-support
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-vim/bash-support
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-vim/bash-support')
-rw-r--r--app-vim/bash-support/Manifest2
-rw-r--r--app-vim/bash-support/bash-support-4.3.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/bash-support/Manifest b/app-vim/bash-support/Manifest
index 5cb7c6784de0..66402b55d1d1 100644
--- a/app-vim/bash-support/Manifest
+++ b/app-vim/bash-support/Manifest
@@ -1,3 +1,5 @@
DIST bash-support-4.2.1.tar.bz2 115200 BLAKE2B 2fab4f1bb0897af389a206051e63d2fe7a8cd89367298b1be51146eed7c0d788b23cec7bc81ce3056d26b5efc920043e67be003e4e6bfe25b503d532c74d9c07 SHA512 12ab39f5cffb58e4adb2137265d6c4f1a61b5f2e360f6866c21ead0a67e02a5445bd12fec5b00b26e5d6102b3aaab99b8b13539a67575067c3ef9b26c4ef8fba
+DIST bash-support-4.3.zip 249238 BLAKE2B 46fa031b4ba927e5a229fa9dc93a3dbe005322a1de494bc8cbeb56138f2c580ea5b39b203d46b59013e1985930422c2e4217234a317fbf8ee6209889c4047323 SHA512 fd9294e467129990bc9796cda309a5b0ec5af3ddbda7f141939622ec0d96c1573b35d9a20e99040d6a4e83b1e98c1f6b847c77d055cca9492922e1080dc64118
EBUILD bash-support-4.2.1.ebuild 464 BLAKE2B b598a5072daf40141ea9fcd43dbbe203a5e330ee5c3ef6b9ee900b2d0cdd90108b8b72b39aea85ce9ea750fee7334cc18a4b21744494239ea85929febd1e464a SHA512 cf8a86c5ffcfcbede66d496f11225928ff31f4dfd30411c5e562340df8da856ae7381163a5d387be26d7293a192c62610521569bcafe4d77f040425dbcb6c4f6
+EBUILD bash-support-4.3.ebuild 591 BLAKE2B cd4708298939d237eb5e2aad39f8c50a9498d913df2c78e08e2b223911d1e680f451a465b55eaa1cb2dcc5214038c21ae3c81aa7f0d7ad87a544f46536c46ac7 SHA512 b74635aa284a48f9a54ab00c66681b003a8ce0d65917335afd2b40f43786eebcbbc8bb20f4022c9d1a18dcc6433fef62cc8d4ca56535301b103a6321fbf6ba86
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/bash-support/bash-support-4.3.ebuild b/app-vim/bash-support/bash-support-4.3.ebuild
new file mode 100644
index 000000000000..6de7fb8f0321
--- /dev/null
+++ b/app-vim/bash-support/bash-support-4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: write and run bash scripts using menus and hotkeys"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=365"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=24452 -> ${P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc doc/{ChangeLog,bash-hotkeys.pdf}
+ rm -rf ${PN}/doc || die
+
+ vim-plugin_src_install
+}