summaryrefslogtreecommitdiff
path: root/app-text/xmlformat/xmlformat-1.04.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/xmlformat/xmlformat-1.04.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/xmlformat/xmlformat-1.04.ebuild')
-rw-r--r--app-text/xmlformat/xmlformat-1.04.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-text/xmlformat/xmlformat-1.04.ebuild b/app-text/xmlformat/xmlformat-1.04.ebuild
new file mode 100644
index 000000000000..e774cbcd0e1c
--- /dev/null
+++ b/app-text/xmlformat/xmlformat-1.04.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+inherit ruby-single
+
+DESCRIPTION="Reformat XML documents to your custom style"
+SRC_URI="http://www.kitebird.com/software/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.kitebird.com/software/xmlformat/"
+
+SLOT="0"
+LICENSE="xmlformat"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="ruby? ( ${RUBY_DEPS} )
+ !ruby? ( dev-lang/perl )"
+RDEPEND=${DEPEND}
+IUSE="ruby doc"
+
+src_install() {
+ dobin xmlformat.pl
+
+ if use ruby
+ then
+ dobin xmlformat.rb
+ dosym xmlformat.rb /usr/bin/xmlformat
+ else
+ dosym xmlformat.pl /usr/bin/xmlformat
+ fi
+
+ dodoc BUGS ChangeLog README TODO
+
+ if use doc
+ then
+ # APIs
+ insinto /usr/share/doc/${PF}
+ doins -r docs/*
+ fi
+}
+
+src_test() {
+ if use ruby
+ then
+ ./runtest all || die "runtest for ruby failed."
+ else
+ ./runtest -p all || die "runtest for perl failed."
+ fi
+}