summaryrefslogtreecommitdiff
path: root/app-text/xmlformat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/xmlformat
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/xmlformat')
-rw-r--r--app-text/xmlformat/Manifest5
-rw-r--r--app-text/xmlformat/metadata.xml5
-rw-r--r--app-text/xmlformat/xmlformat-1.04.ebuild51
3 files changed, 61 insertions, 0 deletions
diff --git a/app-text/xmlformat/Manifest b/app-text/xmlformat/Manifest
new file mode 100644
index 000000000000..4287b03e2771
--- /dev/null
+++ b/app-text/xmlformat/Manifest
@@ -0,0 +1,5 @@
+DIST xmlformat-1.04.tar.gz 156498 SHA256 71a70397e44760d67645007ad85fea99736f4b6f8679067a3b5f010589fd8fef SHA512 e45471accf0c04e016d3a9a5bbc2f984a9a76e1d5406a80300bf9da9d04bd78b67716055271923669462b70a1713b94a1e1937318115dfd9eb9d258b69a3c14d WHIRLPOOL 0d509c8248ccfd17306f6a75017e2e8199b95d4b2c2dcd2fd622615e041aaac7ae914bc8e911d2a29c6b2aefe3d922698d490dfc89201b7cc76f73380ebcf5fd
+EBUILD xmlformat-1.04.ebuild 971 SHA256 c69a87ff9cb9138cfcf2364323502f34b0396a498cce91cb18179a14352e6c73 SHA512 17e172138d53d3c367a8c3ba238d91f71b63a499d19436ef68b3ad6b3ea08580de7b36cb608bd7f80db8756c37bd61c4897cd7c5334a2d307f8c023116fc97a7 WHIRLPOOL f703ebcfd50a1e3f16034765c53acd5e4cec62b5b3ed48947704060ed3f5e4cda329bb4a6c5e2c0c40307c4d600c36923f93a51dc332206ceb99afcc93e13391
+MISC ChangeLog 2678 SHA256 ef133ac9a87aa3562183d875961a47d6886bdd09b2c4f58f6d7578ced73e6248 SHA512 05cbc3b93a4dbb3b084af2d57613269d2ea2110bcbc5937b5671e808cac437f2f7f8c0cfd1b96bdbda074374f7aa24d48b72f99686b0deb9b16f64315ec934de WHIRLPOOL e22bf16a732573124b796b640f11dc61d9fb519c5ed19063d9582bf6081c04169d8f12e70e27f5282f63a3164d1a7c6284aca0edf5cc1dd56c4171a4eca20923
+MISC ChangeLog-2015 1926 SHA256 6cb306053c76c3e4d0817a1ede149cd2f4858473a4cd07686502a75649cfdc61 SHA512 9433ba6e4b36c15d9f3e342dbcfe5f8d2baaaca9d0214dbbab7f7ec4c6f3623914d4c20092bc9ba424bf4d0da4d5c21f496381eacf5908e57e9809135cbf9991 WHIRLPOOL a45ff0f098422b86c85485a0552adaf689db237e50b44278f4ded049ca4ad347ec3bffb36025a7f70bfdfb97051157d587754506aca8c5101409415da75caed6
+MISC metadata.xml 166 SHA256 2caff447f5bd2701d8456ada5cc633c41ef4373fa4bfeabeb73599d40bcc941b SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84 WHIRLPOOL 1ff70497eca6531f0e0614c72a19f4b8e5ff486a58d369f4f0b36308d1d6b01168f9da887740e3b9f536236be251d3fe05f904d27a9233a7cf613416ba882968
diff --git a/app-text/xmlformat/metadata.xml b/app-text/xmlformat/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-text/xmlformat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-text/xmlformat/xmlformat-1.04.ebuild b/app-text/xmlformat/xmlformat-1.04.ebuild
new file mode 100644
index 000000000000..e774cbcd0e1c
--- /dev/null
+++ b/app-text/xmlformat/xmlformat-1.04.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+inherit ruby-single
+
+DESCRIPTION="Reformat XML documents to your custom style"
+SRC_URI="http://www.kitebird.com/software/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.kitebird.com/software/xmlformat/"
+
+SLOT="0"
+LICENSE="xmlformat"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="ruby? ( ${RUBY_DEPS} )
+ !ruby? ( dev-lang/perl )"
+RDEPEND=${DEPEND}
+IUSE="ruby doc"
+
+src_install() {
+ dobin xmlformat.pl
+
+ if use ruby
+ then
+ dobin xmlformat.rb
+ dosym xmlformat.rb /usr/bin/xmlformat
+ else
+ dosym xmlformat.pl /usr/bin/xmlformat
+ fi
+
+ dodoc BUGS ChangeLog README TODO
+
+ if use doc
+ then
+ # APIs
+ insinto /usr/share/doc/${PF}
+ doins -r docs/*
+ fi
+}
+
+src_test() {
+ if use ruby
+ then
+ ./runtest all || die "runtest for ruby failed."
+ else
+ ./runtest -p all || die "runtest for perl failed."
+ fi
+}