summaryrefslogtreecommitdiff
path: root/app-text/unpaper/unpaper-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/unpaper/unpaper-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/unpaper/unpaper-9999.ebuild')
-rw-r--r--app-text/unpaper/unpaper-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/unpaper/unpaper-9999.ebuild b/app-text/unpaper/unpaper-9999.ebuild
new file mode 100644
index 000000000000..e2d4212348de
--- /dev/null
+++ b/app-text/unpaper/unpaper-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="libav test"
+
+RDEPEND="
+ libav? ( >=media-video/libav-10:0=[encode] )
+ !libav? ( >=media-video/ffmpeg-2:0=[encode] )"
+DEPEND="dev-libs/libxslt
+ app-text/docbook-xsl-ns-stylesheets
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+# gcc can generate slightly different code that leads to slightly different
+# images. Wait until we get a better testsuite.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}