summaryrefslogtreecommitdiff
path: root/app-text/unpaper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/unpaper
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/unpaper')
-rw-r--r--app-text/unpaper/Manifest4
-rw-r--r--app-text/unpaper/metadata.xml8
-rw-r--r--app-text/unpaper/unpaper-6.1-r1.ebuild36
-rw-r--r--app-text/unpaper/unpaper-9999.ebuild36
4 files changed, 84 insertions, 0 deletions
diff --git a/app-text/unpaper/Manifest b/app-text/unpaper/Manifest
new file mode 100644
index 000000000000..491977063db9
--- /dev/null
+++ b/app-text/unpaper/Manifest
@@ -0,0 +1,4 @@
+DIST unpaper-6.1.tar.xz 2655724 BLAKE2B df16261d37d5d493aa640cd940b63f55e90ba091e6028dc11dd0c685ec880a7be202d4056756ef0fa54b48b89f1845b9cf23aceeb87945a1b6a25eec4b7c0915 SHA512 afef705985d3c265672c9e42130acc34befc080c361f3169e299b5110c662d0b9845a9d0ca4fc3aad468f49967ded36fb60ffed296373569dd7337c3cb81e79c
+EBUILD unpaper-6.1-r1.ebuild 887 BLAKE2B 2e03001a8f2f169b862f825b8c044974b061fd72f760b7fd40dcadf64d2d93b10b86a71dda21b70cc00ca4abe6c86173d3a6e27425d6b7ab4fbb99002e808ac0 SHA512 ddf900c742cb27a56e61647d55ba6f16a5167c69cd4ef934934a3c1b3900df82d019d84b434894e970e91164aad77b0c2d92d8c1a861108169fb618d61ee328b
+EBUILD unpaper-9999.ebuild 887 BLAKE2B 2e03001a8f2f169b862f825b8c044974b061fd72f760b7fd40dcadf64d2d93b10b86a71dda21b70cc00ca4abe6c86173d3a6e27425d6b7ab4fbb99002e808ac0 SHA512 ddf900c742cb27a56e61647d55ba6f16a5167c69cd4ef934934a3c1b3900df82d019d84b434894e970e91164aad77b0c2d92d8c1a861108169fb618d61ee328b
+MISC metadata.xml 292 BLAKE2B 5a4427170ed656c135d0cd81f46c3d472e306760c322c95f85e6183eeac77be6036d154791c2ce04ac28473c77974ebd2f26b302e5fa825a6c1db2437b1e6ee0 SHA512 67a23847327391a27c4acbb895e63063fa541de6fdf062887b1aa25a731bf2096e26f26c6cd62720bdc84fcbde256dbe6c9cc44687a7931d5e1a657ea684348a
diff --git a/app-text/unpaper/metadata.xml b/app-text/unpaper/metadata.xml
new file mode 100644
index 000000000000..5c69cff947ef
--- /dev/null
+++ b/app-text/unpaper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">Flameeyes/unpaper</remote-id>
+ <bugs-to>https://github.com/Flameeyes/unpaper/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/unpaper/unpaper-6.1-r1.ebuild b/app-text/unpaper/unpaper-6.1-r1.ebuild
new file mode 100644
index 000000000000..e2d4212348de
--- /dev/null
+++ b/app-text/unpaper/unpaper-6.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="libav test"
+
+RDEPEND="
+ libav? ( >=media-video/libav-10:0=[encode] )
+ !libav? ( >=media-video/ffmpeg-2:0=[encode] )"
+DEPEND="dev-libs/libxslt
+ app-text/docbook-xsl-ns-stylesheets
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+# gcc can generate slightly different code that leads to slightly different
+# images. Wait until we get a better testsuite.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
diff --git a/app-text/unpaper/unpaper-9999.ebuild b/app-text/unpaper/unpaper-9999.ebuild
new file mode 100644
index 000000000000..e2d4212348de
--- /dev/null
+++ b/app-text/unpaper/unpaper-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="libav test"
+
+RDEPEND="
+ libav? ( >=media-video/libav-10:0=[encode] )
+ !libav? ( >=media-video/ffmpeg-2:0=[encode] )"
+DEPEND="dev-libs/libxslt
+ app-text/docbook-xsl-ns-stylesheets
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+# gcc can generate slightly different code that leads to slightly different
+# images. Wait until we get a better testsuite.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}