summaryrefslogtreecommitdiff
path: root/app-text/sgrep
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-07 13:23:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-07 13:23:59 +0100
commit27a61babf89122aeb64d52f4ea8f6f068b928da4 (patch)
tree56cc72dcfb76f622af8103ed350c61f432d5f686 /app-text/sgrep
parentbbdc49d5ccd04563006a608c87c870413f75057e (diff)
gentoo auto-resync : 07:10:2022 - 13:23:59
Diffstat (limited to 'app-text/sgrep')
-rw-r--r--app-text/sgrep/Manifest3
-rw-r--r--app-text/sgrep/files/sgrep-1.94a-clang16.patch11
-rw-r--r--app-text/sgrep/sgrep-1.94a-r1.ebuild (renamed from app-text/sgrep/sgrep-1.94a.ebuild)15
3 files changed, 23 insertions, 6 deletions
diff --git a/app-text/sgrep/Manifest b/app-text/sgrep/Manifest
index eb34430688c9..138ad2b69af2 100644
--- a/app-text/sgrep/Manifest
+++ b/app-text/sgrep/Manifest
@@ -1,3 +1,4 @@
+AUX sgrep-1.94a-clang16.patch 332 BLAKE2B db943a01e40f19b224767d27df8bc172a0b1fc3a5c1c71248ca247462864c86797065b422d2062bf560d088944612e4ee161e5a734dc694fd10d81ff3932d775 SHA512 4c8ecfc695564807cc681eaadc61a4a11fabbcc83b2fe95f60e5886ae01c9ee1b1d0d7a99e23448123dad24dcfd83f74fbad2aa2601ea344bd87e4026ad71297
DIST sgrep-1.94a.tar.gz 193267 BLAKE2B fe37f62e2cb5c2ccad88df8ee3000d937357b5801ac6c55938a575f77735db7f94c0475e2eaa2521dfbae194132dcda4efe009db32e23b50c13acbc359b9abaf SHA512 8d2571a738c6a87cc34aea3a0692d15aea1d4a0439401b97368da2a021992ef8d0754e91e10409c1c059712bfe69ac4188e3be856211e48f8e6d528b5684283a
-EBUILD sgrep-1.94a.ebuild 707 BLAKE2B 6ea4827c2dcedfb6c2c73b4761bc157328aa45a0729c8b0fe2fac2ff8701c1eb27d577a4a905fe6a56e5060ae4777e6332a153734bf4a203c445914d622de14f SHA512 f5ede16338af4744ba9444b0508a442ddc20fbc4248ba5fc6e0593c370297e2cc877ab3d41d9b5294ebaf457661d072f5e8e2047ab9b4f171099b35cab10f71a
+EBUILD sgrep-1.94a-r1.ebuild 755 BLAKE2B f23b0ab5c3dfa30e4568db0a8f92b15a8243e1c1ca734df5fbd60cc63b058fe04c874ca3aa58a847c52876b3354bec2a3c97dc7ecd7f20e47c80ba9443b61988 SHA512 e893588a5079dc2a8924c814725c9d77d2e89b7ffb1c0041547774701951b013b274983376386fed6d4944923e994a54cd991d92b75aad7cfb287e70e78fb7c7
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/app-text/sgrep/files/sgrep-1.94a-clang16.patch b/app-text/sgrep/files/sgrep-1.94a-clang16.patch
new file mode 100644
index 000000000000..8892f79bbb01
--- /dev/null
+++ b/app-text/sgrep/files/sgrep-1.94a-clang16.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/871036
+--- a/sgrep.h
++++ b/sgrep.h
+@@ -20,2 +20,3 @@
+ #include <stdlib.h>
++#include <string.h>
+ #include <assert.h>
+@@ -616,2 +617,3 @@
+ int create_index(const IndexOptions *options);
++int index_query(IndexOptions *options, int argc, char *argv[]);
+ int add_region_to_index(struct IndexWriterStruct *writer,
diff --git a/app-text/sgrep/sgrep-1.94a.ebuild b/app-text/sgrep/sgrep-1.94a-r1.ebuild
index 9facab819c5c..eb45eb4f246a 100644
--- a/app-text/sgrep/sgrep-1.94a.ebuild
+++ b/app-text/sgrep/sgrep-1.94a-r1.ebuild
@@ -1,20 +1,24 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Use structural criteria to grep and index text, SGML, XML and HTML and filter"
-SRC_URI="ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/${P}.tar.gz"
HOMEPAGE="https://www.cs.helsinki.fi/u/jjaakkol/sgrep.html"
+SRC_URI="ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
src_prepare() {
default
- sed -i -e "s:/usr/lib:/etc:g" sgrep.1 || die
+
+ sed -i "s:/usr/lib:${EPREFIX}/etc:g" sgrep.1 || die
}
src_configure() {
@@ -25,6 +29,7 @@ src_install() {
dobin sgrep
doman sgrep.1
dodoc AUTHORS ChangeLog NEWS README sample.sgreprc
+
insinto /etc
newins sample.sgreprc sgreprc
}