summaryrefslogtreecommitdiff
path: root/app-text/sgrep/sgrep-1.94a-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/sgrep/sgrep-1.94a-r1.ebuild')
-rw-r--r--app-text/sgrep/sgrep-1.94a-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/sgrep/sgrep-1.94a-r1.ebuild b/app-text/sgrep/sgrep-1.94a-r1.ebuild
new file mode 100644
index 000000000000..eb45eb4f246a
--- /dev/null
+++ b/app-text/sgrep/sgrep-1.94a-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use structural criteria to grep and index text, SGML, XML and HTML and filter"
+HOMEPAGE="https://www.cs.helsinki.fi/u/jjaakkol/sgrep.html"
+SRC_URI="ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "s:/usr/lib:${EPREFIX}/etc:g" sgrep.1 || die
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX}"/etc
+}
+
+src_install() {
+ dobin sgrep
+ doman sgrep.1
+ dodoc AUTHORS ChangeLog NEWS README sample.sgreprc
+
+ insinto /etc
+ newins sample.sgreprc sgreprc
+}