summaryrefslogtreecommitdiff
path: root/app-text/gspell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-29 16:39:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-29 16:39:59 +0100
commit303f772eff7a30f470d9fb207d69b6a1207b8cab (patch)
treea84db02471adef284e4e5e557037794f024fb1fd /app-text/gspell
parentaf951a33bb81b1d784c3f4ea7bb7ca472e5b8d2b (diff)
gentoo auto-resync : 29:07:2023 - 16:39:59
Diffstat (limited to 'app-text/gspell')
-rw-r--r--app-text/gspell/Manifest2
-rw-r--r--app-text/gspell/gspell-1.12.2.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 4aade90265bf..cfd04e0ec0bc 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,3 +1,5 @@
DIST gspell-1.12.1.tar.xz 442912 BLAKE2B 727db08f0523a9c222ac763e2ae995112862fac772c9208fd42bed535624450efbfe6c8c63d5dc3521f148cd3f6ea591761a8729d1f8f4337ce00e6dbdcff80e SHA512 1498399059b29bd8fe03396a45eb7ea1f00ece7761a63a29ba3e9559f8e3e9e4607022534280bc2ba239fa8cf118f67028b0368b706855fb513172388d951e1c
+DIST gspell-1.12.2.tar.xz 442824 BLAKE2B 6a574339dfa4930e5506d63d5f0cf27d8433c2914ce1204edc8366992ebf05bf78d4777029fa17f05be73291510897862c63479e59e72522a4c4943647f66539 SHA512 c13df805f6128cfd19c41e4936fbb49516f80e09d27e79380d5638cbd1a8a3bfc6aae5ef8a4faa748495fe529bde92805bbd5530610b113c58daa36f273a5af8
EBUILD gspell-1.12.1.ebuild 1528 BLAKE2B 215a767adf8a0023477a5b0a3dca24b0564303e5c0341b294cef2f0f7c914d84317ff6ca3135f0f112ec8d1e5851c6a89793800bf8c23e2daf2343461bb0c111 SHA512 1f68677c9dffd2d75f978906dc6e69c80e771e27a951ded55307f34cc9d16b4e30f6fb94b8c4c1a67aecd90d70e73a0b8e38cb74b004930b564f14ccacf20be1
+EBUILD gspell-1.12.2.ebuild 1535 BLAKE2B 861cbbffb45329d18e0ccdf6332fabf127a685093ebd962717e743f8b1fbec93e674b6100a51c72113af3b516468118f93c0272cc7048efed9eb8704d1f6dc52 SHA512 9da3cb3d3273851c02dfd171f0963392463ebca4be964c564ebdced9ecfc4cd682462d320205f55e9949fbf3c5be86c112604d3b1680700b39b8e22035f9695d
MISC metadata.xml 347 BLAKE2B 3b91db6ff2ea521010e0437fc23b5f69567011240291483423ec748b70cf2baba234824c41cc493f8d30106dad208b9e4b376e69ca3d8e495072b97dd2f271de SHA512 4691f9bc67d5e5372945a4aa319185c4478b58e463c9c1b853a2503c80ab7dacebc433c8ffc247d0fce9e7b2f0f03fd4e0216d27e135598efa26e2988ac7bc73
diff --git a/app-text/gspell/gspell-1.12.2.ebuild b/app-text/gspell/gspell-1.12.2.ebuild
new file mode 100644
index 000000000000..16d18c659738
--- /dev/null
+++ b/app-text/gspell/gspell-1.12.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-2.2:2
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ dev-libs/icu:=
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? (
+ app-text/enchant:2[hunspell]
+ || (
+ app-dicts/myspell-en[l10n_en(+)]
+ app-dicts/myspell-en[l10n_en-US(+)]
+ )
+ )
+"
+# Tests require a en_US dictionary and fail with deprecated enchant aspell backend:
+# So enchant[hunspell] + myspell-en ensure they pass (hunspell is ordered before aspell),
+# however a different backend like hspell or nuspell + their en_US dict might be fine too,
+# but we don't support them at this time (2020-04-12) in enchant:2
+
+src_prepare() {
+ use vala && vala_setup
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx dbus-run-session emake check
+}