summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-29 16:39:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-29 16:39:59 +0100
commit303f772eff7a30f470d9fb207d69b6a1207b8cab (patch)
treea84db02471adef284e4e5e557037794f024fb1fd /app-text
parentaf951a33bb81b1d784c3f4ea7bb7ca472e5b8d2b (diff)
gentoo auto-resync : 29:07:2023 - 16:39:59
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin48405 -> 48396 bytes
-rw-r--r--app-text/gspell/Manifest2
-rw-r--r--app-text/gspell/gspell-1.12.2.ebuild61
-rw-r--r--app-text/xml2rfc/Manifest4
-rw-r--r--app-text/xml2rfc/xml2rfc-3.16.0.ebuild54
-rw-r--r--app-text/xml2rfc/xml2rfc-3.17.4.ebuild2
6 files changed, 65 insertions, 58 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index dc7d3a67dda9..5e4ea8953909 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 4aade90265bf..cfd04e0ec0bc 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,3 +1,5 @@
DIST gspell-1.12.1.tar.xz 442912 BLAKE2B 727db08f0523a9c222ac763e2ae995112862fac772c9208fd42bed535624450efbfe6c8c63d5dc3521f148cd3f6ea591761a8729d1f8f4337ce00e6dbdcff80e SHA512 1498399059b29bd8fe03396a45eb7ea1f00ece7761a63a29ba3e9559f8e3e9e4607022534280bc2ba239fa8cf118f67028b0368b706855fb513172388d951e1c
+DIST gspell-1.12.2.tar.xz 442824 BLAKE2B 6a574339dfa4930e5506d63d5f0cf27d8433c2914ce1204edc8366992ebf05bf78d4777029fa17f05be73291510897862c63479e59e72522a4c4943647f66539 SHA512 c13df805f6128cfd19c41e4936fbb49516f80e09d27e79380d5638cbd1a8a3bfc6aae5ef8a4faa748495fe529bde92805bbd5530610b113c58daa36f273a5af8
EBUILD gspell-1.12.1.ebuild 1528 BLAKE2B 215a767adf8a0023477a5b0a3dca24b0564303e5c0341b294cef2f0f7c914d84317ff6ca3135f0f112ec8d1e5851c6a89793800bf8c23e2daf2343461bb0c111 SHA512 1f68677c9dffd2d75f978906dc6e69c80e771e27a951ded55307f34cc9d16b4e30f6fb94b8c4c1a67aecd90d70e73a0b8e38cb74b004930b564f14ccacf20be1
+EBUILD gspell-1.12.2.ebuild 1535 BLAKE2B 861cbbffb45329d18e0ccdf6332fabf127a685093ebd962717e743f8b1fbec93e674b6100a51c72113af3b516468118f93c0272cc7048efed9eb8704d1f6dc52 SHA512 9da3cb3d3273851c02dfd171f0963392463ebca4be964c564ebdced9ecfc4cd682462d320205f55e9949fbf3c5be86c112604d3b1680700b39b8e22035f9695d
MISC metadata.xml 347 BLAKE2B 3b91db6ff2ea521010e0437fc23b5f69567011240291483423ec748b70cf2baba234824c41cc493f8d30106dad208b9e4b376e69ca3d8e495072b97dd2f271de SHA512 4691f9bc67d5e5372945a4aa319185c4478b58e463c9c1b853a2503c80ab7dacebc433c8ffc247d0fce9e7b2f0f03fd4e0216d27e135598efa26e2988ac7bc73
diff --git a/app-text/gspell/gspell-1.12.2.ebuild b/app-text/gspell/gspell-1.12.2.ebuild
new file mode 100644
index 000000000000..16d18c659738
--- /dev/null
+++ b/app-text/gspell/gspell-1.12.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-2.2:2
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ dev-libs/icu:=
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? (
+ app-text/enchant:2[hunspell]
+ || (
+ app-dicts/myspell-en[l10n_en(+)]
+ app-dicts/myspell-en[l10n_en-US(+)]
+ )
+ )
+"
+# Tests require a en_US dictionary and fail with deprecated enchant aspell backend:
+# So enchant[hunspell] + myspell-en ensure they pass (hunspell is ordered before aspell),
+# however a different backend like hspell or nuspell + their en_US dict might be fine too,
+# but we don't support them at this time (2020-04-12) in enchant:2
+
+src_prepare() {
+ use vala && vala_setup
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx dbus-run-session emake check
+}
diff --git a/app-text/xml2rfc/Manifest b/app-text/xml2rfc/Manifest
index fc57167c79c8..ca8d59420348 100644
--- a/app-text/xml2rfc/Manifest
+++ b/app-text/xml2rfc/Manifest
@@ -1,8 +1,6 @@
AUX xml2rfc-Remove-broken-test.patch 3455 BLAKE2B a5faf688b52a7dc34a99e096a56433103e01f28f8c4b4cf75b4816683b1e7fcd60131d2170f5fdf65fc1c4621099694de682e5b017d6d045bc795bf3f8ecbd31 SHA512 9f54ef323f7f89f89b847fc00731115d2ee8302b7352c43549176cbdcafd79edd8a91dcf2e329e690833bb19f0f6ed0fd8ca5ee22e92299df54b505f2af0aaa7
-DIST xml2rfc-3.16.0.gh.tar.gz 2859379 BLAKE2B 537815a648b9f5ed59b37a82a29ee092b7e2ad3d10c191a08c752a43d3aed0b81270a855b3a3ee1df935a1d14192715e62f82fe15c2de98eddf329ac554a4ba5 SHA512 893a71bd33c6971103188e624b91d1370f8324bb2316a542fa9496c02368875582b57336e57abd8753e207d80a5aed508c15407ea734056f91002dde9aafdad2
DIST xml2rfc-3.17.1.gh.tar.gz 2856471 BLAKE2B 81c0ba0788e6a7e5211186f87d06bf76622fae57557e62bfe3a9fbb9c3aa31de0e1e99302b28b81d4e7280a2f29704389c6a0936b20b0aee219576eff9bfc803 SHA512 d502afc37e350dfd4c578d160e3942c3a33ebf45941db1478cd8e88b3f00470ab457a44667dd0eb955a270e31ae528a73d3625f1a61aabb166705b3d367df62a
DIST xml2rfc-3.17.4.gh.tar.gz 2858770 BLAKE2B b29b8a102668a5aa943a32b28a9d1669e2a6b0af03085a550c21a08e5bfb5ff3ee8979b03a3d7ae8e820ac8bf60455682914fd06a882e17183ca51aaf1dedf86 SHA512 3fc620eed12fc2a7f6015df8b6a5b1aa422cd8c26807e01d75498aee9257faad1bca68606f77598fb040a8dae074e35ffa0e2994a1ae8d59ee27d25fc6a755e5
-EBUILD xml2rfc-3.16.0.ebuild 1454 BLAKE2B 6a30e22f22a50951b2eece3aab0cef0b95e054b7b7c230dd885a194ddfbe14b71a7cd822128273f2b1aa8c4a256d568472fbfcde531e4382d4edfc80aadd5089 SHA512 3ae5deb47dd25b989667ffb3c979f1bf57aea577e6f49558c81eef4ff609bc26491f89fa0615541f14063a840456c02c3df36f89966c4d42e42db02aad61ab54
EBUILD xml2rfc-3.17.1.ebuild 1441 BLAKE2B 9ddcc426bce06b6f16130f9ad07386e245b1fb5edd563727a0a40190998b74965b35279b5b3db3ea09f0f31a0b4b3d883152951b95dba22adfbf333fc6a61cdb SHA512 ab21a0dbbaaae09f66e1d91308ada52e64faa9c9029a474c8ae5c158d253b55a6a1570d6ccbd0e72ad4c9f28b048c8884597dd9e7701281534918dda6e471118
-EBUILD xml2rfc-3.17.4.ebuild 1463 BLAKE2B 4feb72cc205dbc2ca958be8120ec71dae362802d0eea03add1f74762489c8b1ccb1306f9a06cd645d83cf5f9ca40cea6fe34ba78c8cc7075f4d72c6c16a1a6f9 SHA512 904e255b62c97f9b9b6151e182f7dc8a7fbe45d619932a31a6f5439346da919f3f1c6648e5fe4da89a2d15b38b943ea285b60ecaff950dc1304df4d60d9e4e32
+EBUILD xml2rfc-3.17.4.ebuild 1462 BLAKE2B fe65e9102f5df75bf13c31ceb76cb0b26516fcee144646abc81b8b3152f3521145b3310f1779227473af2f574541e1aa2ba3d5561eabaaead94b3533e3afc001 SHA512 437da193162e5ad93dba2cbbfc2e8b970c4db1f03b1ee3ca3565f0224a792ea48b6904f66db911775372edbac8cd8a5ee09c946f54d4d757a01ba6bbd00cc6f0
MISC metadata.xml 374 BLAKE2B 3514fd485c7ca895f1b9f4a809ed97bb55396c1abd6a52ae6602e61b836fac3a0fbcbeec7dcb0789a6510cabb9920a33bfae4dfeb9bfba86ad9d02fbf917a720 SHA512 0e4697e08615993939416355b5d112f5f6ab1aad0bc74a3e33f6d3e7d0178ddf9b5fba70aa50fc6babed1ca27d89d1b0bff53223c1a55e636e82b6c617860cb9
diff --git a/app-text/xml2rfc/xml2rfc-3.16.0.ebuild b/app-text/xml2rfc/xml2rfc-3.16.0.ebuild
deleted file mode 100644
index 6136dbb33773..000000000000
--- a/app-text/xml2rfc/xml2rfc-3.16.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Generates RFCs and IETF drafts from document source in XML"
-HOMEPAGE="https://ietf-tools.github.io/xml2rfc/ https://github.com/ietf-tools/xml2rfc"
-SRC_URI="https://github.com/ietf-tools/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-RESTRICT="!test? ( test )"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64"
-
-BDEPEND="
- test? (
- >=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/dict2xml[${PYTHON_USEDEP}]
- dev-python/weasyprint[${PYTHON_USEDEP}]
- media-fonts/noto[cjk]
- )
-"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/ConfigArgParse[${PYTHON_USEDEP}]
- dev-python/intervaltree[${PYTHON_USEDEP}]
- dev-python/google-i18n-address[${PYTHON_USEDEP}]
- >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
- dev-python/pycountry[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/xml2rfc-Remove-broken-test.patch"
-)
-
-distutils_enable_tests setup.py
-
-#src_test() {
- # https://github.com/ietf-tools/xml2rfc/issues/561
-# emake tests-no-network
-#}
diff --git a/app-text/xml2rfc/xml2rfc-3.17.4.ebuild b/app-text/xml2rfc/xml2rfc-3.17.4.ebuild
index 3b8c97ef1ad8..4e0aa2aed4e5 100644
--- a/app-text/xml2rfc/xml2rfc-3.17.4.ebuild
+++ b/app-text/xml2rfc/xml2rfc-3.17.4.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/ietf-tools/${PN}/archive/refs/tags/v${PV}.tar.gz ->
RESTRICT="!test? ( test )"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
BDEPEND="
test? (