summaryrefslogtreecommitdiff
path: root/app-text/bibletime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-08 04:37:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-08 04:37:19 +0100
commit8bba0fff0bc9709d45aeb68336998e11d118ab05 (patch)
tree028aab3e3fe08bcbb0cbbd5dd1696ef5e68823d7 /app-text/bibletime
parentd6afc0279cc61e309c2696d5bd758451f97b6a5b (diff)
gentoo auto-resync : 08:09:2022 - 04:37:19
Diffstat (limited to 'app-text/bibletime')
-rw-r--r--app-text/bibletime/Manifest2
-rw-r--r--app-text/bibletime/bibletime-3.0.3-r3.ebuild60
-rw-r--r--app-text/bibletime/files/bibletime-3.0.3-no_indirect_deps.patch20
3 files changed, 82 insertions, 0 deletions
diff --git a/app-text/bibletime/Manifest b/app-text/bibletime/Manifest
index 2cc5ebb803b1..8942ad73b606 100644
--- a/app-text/bibletime/Manifest
+++ b/app-text/bibletime/Manifest
@@ -1,3 +1,5 @@
+AUX bibletime-3.0.3-no_indirect_deps.patch 481 BLAKE2B eb0e8f5397346f916131f369b943a385bde7a82aedc426c548a764169f2b4b1f36c977ccbaa968481023177f9cb6bd7ec09f3378a6fde813fc7c6037bedf763b SHA512 875351e3d4d53c95c100f555a73eec329224f3151258f5ebbc4ec38473ef9c3d9b5ce44ba3720cf8a0ed16f957e0d77ae762f893072da28c6ea5506140ba08dd
DIST bibletime-3.0.3.tar.xz 1620012 BLAKE2B 5f2f5bb071d7ffb625bd687c99a328ba758f8e842138204aa770714f830594fe49c61a45e51f7de69d865b95b154ad934da7af49f391b22907773a1435e4fbbf SHA512 553549b39bf3341dbf310908b24db246d88ba01524d424de14ece35c12160565185547fc0250fe8bb248a32d8a012b99afbc022d9a513dcc916c3e8089f72090
EBUILD bibletime-3.0.3-r2.ebuild 1176 BLAKE2B 08bdfb05292ea3585124507e679616dae31825cfa05901d275c339bd0a5e76a9fa44834a66c89909d0dd1092d55f66cc8a3470f4ff3e210270969c9139594b77 SHA512 c12406d49f2dd42ad6d7a225c9f25df7e9ee7693861bd75036166c6895b1da0e925c01b8a1df46fe412e5d7ad0d35cf98ea334938fbd74358695d34325776d21
+EBUILD bibletime-3.0.3-r3.ebuild 1206 BLAKE2B db3a9139a061a0af4556310b2b7543b0994c404c03c9854d678cf4983a9cbc1ffd94f260315556b199bd9d14e538d7577f8546ae8db08d8542dac96a05dd2900 SHA512 9d81071a7316a4536de03cd4f409d28b1c2e233f1a0038c7a904aea54070dd39caf74917a4504feaba52111c3754973cf546f681ce904816c2f100ecef6e4f8c
MISC metadata.xml 657 BLAKE2B d60c79c16a34ae0cbd43eb5de895cd675727712be5cc5b5a7f969a6d7e222e5cf1f1583308a2dbf3fee604f3bebdaa85ec97e94fcb0230ee856a988ad14ee175 SHA512 ce660bf9ad657a9f7409620d823655c4021492f4f9eb7f9621696600590a81a70c2e41a7e4a9ec156b3c7e75e2a427c0fa2cb183732efed5a9032fecb23664db
diff --git a/app-text/bibletime/bibletime-3.0.3-r3.ebuild b/app-text/bibletime/bibletime-3.0.3-r3.ebuild
new file mode 100644
index 000000000000..7c4cc4b09136
--- /dev/null
+++ b/app-text/bibletime/bibletime-3.0.3-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt Bible-study application using the SWORD library"
+HOMEPAGE="https://bibletime.info/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-text/sword-1.8.1[curl,icu]
+ dev-cpp/clucene
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-qt/qttest:5"
+BDEPEND="dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.3-no_indirect_deps.patch
+)
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
+ -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_HANDBOOK_HTML=no
+ -DBUILD_HANDBOOK_PDF=no
+ -DBUILD_HOWTO_HTML=no
+ -DBUILD_HOWTO_PDF=no
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/app-text/bibletime/files/bibletime-3.0.3-no_indirect_deps.patch b/app-text/bibletime/files/bibletime-3.0.3-no_indirect_deps.patch
new file mode 100644
index 000000000000..87a129c9d80b
--- /dev/null
+++ b/app-text/bibletime/files/bibletime-3.0.3-no_indirect_deps.patch
@@ -0,0 +1,20 @@
+According to documentation upstream build scripts only look for these
+packages to try and guess whether support for them has been enabled
+in app-text/sword.
+
+--- a/platforms/common/core/core.pro
++++ b/platforms/common/core/core.pro
+@@ -173,13 +173,5 @@
+ # Clucene
+ include(../../common/clucene/clucene.pro)
+
+-# CURL
+-# optional
+-curl:include(../../common/curl/curl.pro)
+-
+-# ICU
+-# optional
+-icu:include(../../common/icu/icu.pro)
+-
+ # Sword
+ include(../../common/sword/sword.pro)