summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-08 04:37:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-08 04:37:19 +0100
commit8bba0fff0bc9709d45aeb68336998e11d118ab05 (patch)
tree028aab3e3fe08bcbb0cbbd5dd1696ef5e68823d7 /app-text
parentd6afc0279cc61e309c2696d5bd758451f97b6a5b (diff)
gentoo auto-resync : 08:09:2022 - 04:37:19
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin48360 -> 48363 bytes
-rw-r--r--app-text/bibletime/Manifest2
-rw-r--r--app-text/bibletime/bibletime-3.0.3-r3.ebuild60
-rw-r--r--app-text/bibletime/files/bibletime-3.0.3-no_indirect_deps.patch20
-rw-r--r--app-text/enscript/Manifest3
-rw-r--r--app-text/enscript/enscript-1.6.6-r1.ebuild (renamed from app-text/enscript/enscript-1.6.6.ebuild)3
-rw-r--r--app-text/enscript/files/enscript-1.6.2-implicit-function-decl.patch20
-rw-r--r--app-text/xmlto/Manifest2
-rw-r--r--app-text/xmlto/files/xmlto-0.0.28-fix-warnings.patch116
-rw-r--r--app-text/xmlto/xmlto-0.0.28-r9.ebuild56
10 files changed, 280 insertions, 2 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index ae87fa7ab19c..7f8debc11e76 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/bibletime/Manifest b/app-text/bibletime/Manifest
index 2cc5ebb803b1..8942ad73b606 100644
--- a/app-text/bibletime/Manifest
+++ b/app-text/bibletime/Manifest
@@ -1,3 +1,5 @@
+AUX bibletime-3.0.3-no_indirect_deps.patch 481 BLAKE2B eb0e8f5397346f916131f369b943a385bde7a82aedc426c548a764169f2b4b1f36c977ccbaa968481023177f9cb6bd7ec09f3378a6fde813fc7c6037bedf763b SHA512 875351e3d4d53c95c100f555a73eec329224f3151258f5ebbc4ec38473ef9c3d9b5ce44ba3720cf8a0ed16f957e0d77ae762f893072da28c6ea5506140ba08dd
DIST bibletime-3.0.3.tar.xz 1620012 BLAKE2B 5f2f5bb071d7ffb625bd687c99a328ba758f8e842138204aa770714f830594fe49c61a45e51f7de69d865b95b154ad934da7af49f391b22907773a1435e4fbbf SHA512 553549b39bf3341dbf310908b24db246d88ba01524d424de14ece35c12160565185547fc0250fe8bb248a32d8a012b99afbc022d9a513dcc916c3e8089f72090
EBUILD bibletime-3.0.3-r2.ebuild 1176 BLAKE2B 08bdfb05292ea3585124507e679616dae31825cfa05901d275c339bd0a5e76a9fa44834a66c89909d0dd1092d55f66cc8a3470f4ff3e210270969c9139594b77 SHA512 c12406d49f2dd42ad6d7a225c9f25df7e9ee7693861bd75036166c6895b1da0e925c01b8a1df46fe412e5d7ad0d35cf98ea334938fbd74358695d34325776d21
+EBUILD bibletime-3.0.3-r3.ebuild 1206 BLAKE2B db3a9139a061a0af4556310b2b7543b0994c404c03c9854d678cf4983a9cbc1ffd94f260315556b199bd9d14e538d7577f8546ae8db08d8542dac96a05dd2900 SHA512 9d81071a7316a4536de03cd4f409d28b1c2e233f1a0038c7a904aea54070dd39caf74917a4504feaba52111c3754973cf546f681ce904816c2f100ecef6e4f8c
MISC metadata.xml 657 BLAKE2B d60c79c16a34ae0cbd43eb5de895cd675727712be5cc5b5a7f969a6d7e222e5cf1f1583308a2dbf3fee604f3bebdaa85ec97e94fcb0230ee856a988ad14ee175 SHA512 ce660bf9ad657a9f7409620d823655c4021492f4f9eb7f9621696600590a81a70c2e41a7e4a9ec156b3c7e75e2a427c0fa2cb183732efed5a9032fecb23664db
diff --git a/app-text/bibletime/bibletime-3.0.3-r3.ebuild b/app-text/bibletime/bibletime-3.0.3-r3.ebuild
new file mode 100644
index 000000000000..7c4cc4b09136
--- /dev/null
+++ b/app-text/bibletime/bibletime-3.0.3-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt Bible-study application using the SWORD library"
+HOMEPAGE="https://bibletime.info/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-text/sword-1.8.1[curl,icu]
+ dev-cpp/clucene
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-qt/qttest:5"
+BDEPEND="dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.3-no_indirect_deps.patch
+)
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
+ -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_HANDBOOK_HTML=no
+ -DBUILD_HANDBOOK_PDF=no
+ -DBUILD_HOWTO_HTML=no
+ -DBUILD_HOWTO_PDF=no
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/app-text/bibletime/files/bibletime-3.0.3-no_indirect_deps.patch b/app-text/bibletime/files/bibletime-3.0.3-no_indirect_deps.patch
new file mode 100644
index 000000000000..87a129c9d80b
--- /dev/null
+++ b/app-text/bibletime/files/bibletime-3.0.3-no_indirect_deps.patch
@@ -0,0 +1,20 @@
+According to documentation upstream build scripts only look for these
+packages to try and guess whether support for them has been enabled
+in app-text/sword.
+
+--- a/platforms/common/core/core.pro
++++ b/platforms/common/core/core.pro
+@@ -173,13 +173,5 @@
+ # Clucene
+ include(../../common/clucene/clucene.pro)
+
+-# CURL
+-# optional
+-curl:include(../../common/curl/curl.pro)
+-
+-# ICU
+-# optional
+-icu:include(../../common/icu/icu.pro)
+-
+ # Sword
+ include(../../common/sword/sword.pro)
diff --git a/app-text/enscript/Manifest b/app-text/enscript/Manifest
index 8c5e0d9d13f8..8d377836c452 100644
--- a/app-text/enscript/Manifest
+++ b/app-text/enscript/Manifest
@@ -1,9 +1,10 @@
AUX ebuild.st 6047 BLAKE2B 661a427601920a448b829bbbeb8472199f4ba17cccf698eb206e0651247eb9a115afd50553116f542b31d7ce6436f4bfce3ceef3a894b40087ae7a7c5c6080cc SHA512 1c01943ec901dc4ea314715232fac279fa051b441b39e8cc5bca759b67dda87c4982eba23a37f3b60b041815c347ea85faf774e5574471232e4e941eb186caf5
+AUX enscript-1.6.2-implicit-function-decl.patch 787 BLAKE2B d426fba4d3e4d988a71c7e788dda5f1c751af4d6f98468765b1f2bc74eb23e53458c79a196e47a558947bba204c406976d8ac39893ad283edff043bdb24f16ce SHA512 bc3c2f372ebbef9479bf809b459403014e2b569646f2e0f0361df4a4f067cd59dd4acb914d25899c2e3d5a014c53fa519081c344d0dd64147be3c14421f1ac1f
AUX enscript-1.6.2-ruby.patch 588 BLAKE2B 24b450e360861f8c747979cf84d06921252aff6bcb5faec1187bf9ab5b0135a41e01c40079e5da5620b6ccc43a5c889157c349a4cd112eac60a42243d154a60e SHA512 76bd21efc3f252fb2b6488af25d1f5721e4a05975b4f0f3b6b4062726e505a2a583517400f39bedcdcb1bb4f92da4a10cf747c98e97c7e8e8c0edf147d6c4ec9
AUX enscript-1.6.4-ebuild.st.patch 292 BLAKE2B db5048eac6d3ebfe1b5a3bdd50148f4975b95e19e64523a461f1db5244d5e3b40ac2962890802c24199d6d6aa1f4d51264bad6173743642ba553fdf561e9cd81 SHA512 c033340f988731717f8e0bba7e94e5625089af7184e2bf28e99cfa758c1c794174a1948f0bf7d83580f677452a30f82cf32813f7b39c98982297a00c52064aa6
AUX enscript-1.6.4-fsf-gcc-darwin.patch 836 BLAKE2B 88248e38e4963dc7d5d00cab8739c0f955d59c67ed725836c7444b239ccfcc9483861757de5d3adfe71a2a4a5e64e9eca77473554a30083b16d85ded5c077365 SHA512 282b87be1e71df04d3f8161386f41d29f808de33e2709f2ef143a678a4cf752c0394921f51ea9f51a90b6949fe60757b26e7d2f24fd13ca7f0522f6e460d1324
AUX enscript-1.6.5.2-php.st.patch 210 BLAKE2B 85f6531797d84e8b6ad3933785e5a019c9ef0b36e716ba1714892408cbb370b2cbe11dc7badbe6a8ee5dea1654cd214e7c65fcfcc03fcd1fc9d1e07c1fb6f294 SHA512 8440c2bcf761b4e2151b1c6caa31aa4019b329253b7cc8ce1a0181c310908e1cae471b1ea0f1d2bb0bd24c206688b76b1d235a7fddea6afc5d00c7b61fe8a505
AUX ruby.st 3904 BLAKE2B 854c86166a43715e85e91802f2d82eae71773d9caabf604bd5edc0e53046ed0fa9944ec61c5ff7516e22740cc90ac73dc1d8edbdc0e9722ec876be3a129d2183 SHA512 43af0998ebe95530129aec126b9f91878bbbf7dd52530cb162b25f5779f9eb5b870f41727665e66dd5cf42a6d5e790899bf03c38c1a914adf2b0eecac83154e2
DIST enscript-1.6.6.tar.gz 1330493 BLAKE2B 02e333271ac6716e049402d5904b0ad6926b31d4533c813a9e5bcf76045d4100def2476426b97c52585e8f5c0a741159fb3e78de79c817e75de81ebd464c0d61 SHA512 bf1c2b9ea7723518a1ef312145ddcd6ffdef0c6e8b5795ea84cb55d76fccc02f441d0c2dc6897e970368186e6a829ab74a090716624e0f7a8f575653fa495ebc
-EBUILD enscript-1.6.6.ebuild 1248 BLAKE2B 74c2fb68de023bde9b491da0271cbfdd89fbee2b8b2ced2649d93863d6efdf4f3b3bc69127bd7eb03ad346d18fdbb88724756d6a4037dd2a5851403f6a8f7f55 SHA512 f1b8557d1e0d46cc18ff1033916f35be598f2f66e49103df7f63342ccb58009fb631974c1cbcf5e752bf44718da4df1dbb5011ddb827a47e37a899ce4271d774
+EBUILD enscript-1.6.6-r1.ebuild 1304 BLAKE2B fb16c54147f6ae46e27b135c57803e611c477d9e58113811cc1f78c5396624a1944a6aa57fa0e001f9f9d5e0333a2db23d700267a76d7629f96d84e4c4465e13 SHA512 9954ba339e91ab6c2208305686f315fcd32c509ceda451e0a3db7847d4ac1202337d4202a278da8b90facab87d541a7f494509458e2750d6f2e5a503f9a465b1
MISC metadata.xml 256 BLAKE2B 16ea76357721c3ab7d672ade29d27338ddf9da983571e4ca4efe2520c741fc71315d9609b711850b00c19ed4eea848dea0d5b3955eecb401c42c4db257c300bf SHA512 2748afab7ffea0b3ddadf72dc720f7d83a1d76453fa569091abffe834ec187144a47f9365ccb4a97f676dbcfd799a6be92671f283b179fe4589d95486d7fd24d
diff --git a/app-text/enscript/enscript-1.6.6.ebuild b/app-text/enscript/enscript-1.6.6-r1.ebuild
index bb889e8b0db3..f7a75d380afc 100644
--- a/app-text/enscript/enscript-1.6.6.ebuild
+++ b/app-text/enscript/enscript-1.6.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.6.4-ebuild.st.patch
"${FILESDIR}"/${PN}-1.6.5.2-php.st.patch
"${FILESDIR}"/${PN}-1.6.4-fsf-gcc-darwin.patch
+ "${FILESDIR}"/${PN}-1.6.2-implicit-function-decl.patch
)
src_prepare() {
diff --git a/app-text/enscript/files/enscript-1.6.2-implicit-function-decl.patch b/app-text/enscript/files/enscript-1.6.2-implicit-function-decl.patch
new file mode 100644
index 000000000000..90868d182023
--- /dev/null
+++ b/app-text/enscript/files/enscript-1.6.2-implicit-function-decl.patch
@@ -0,0 +1,20 @@
+https://cgit.openembedded.org/meta-openembedded/plain/meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch?h=master-next&id=6c251848590867debaaf87bfe12bed572d8f6a8d
+
+From faec0206611f8ea4ca6f70987866077ac8c3c6c1 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 2 Sep 2022 21:24:27 -0700
+Subject: [PATCH] getopt: Include string.h for strcmp/stcncmp functions
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/compat/getopt.c
++++ b/compat/getopt.c
+@@ -43,6 +43,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h> /* strcmp */
+
+ /* Comment out all this code if we are using the GNU C Library, and are not
+ actually compiling the library itself. This code is part of the GNU C
diff --git a/app-text/xmlto/Manifest b/app-text/xmlto/Manifest
index 4a91764316e2..7988265519df 100644
--- a/app-text/xmlto/Manifest
+++ b/app-text/xmlto/Manifest
@@ -1,6 +1,8 @@
AUX xmlto-0.0.22-format_fo_passivetex_check.patch 2286 BLAKE2B eb004b4fa394840b8e6fd792bfacfee75d180a1493d960348a33c7737a33a15a809fff28f4b6ade3deb045b629eb48a675b56037da56a7fabcd20718dfdaa6a4 SHA512 c8eeb3dc909431dd2fb9f5286b6ee98a40dce80a29606a9884bdab50c039ac90097720b9b968dfac76546492844de0b72f2f6c937da14b47142ad81b897023f4
AUX xmlto-0.0.28-allow-links.patch 535 BLAKE2B 71412bff616c9499ed6cf045a5d7ea1e6c697db791c58c1a56a1fea3bd7c1619814e20cf58e3549609fc104b0223f80c9a84ef4f4b203da90d5a8dc3b6c943b8 SHA512 cc3ccd209872a54cd3d91a1e261348ce412efab3d9d6d0d9199bd40396fa9c8de5e1ba6a5fef2e5d23d2819ae74bc19e2705b54792296eb7a3b8dc82b8637f22
AUX xmlto-0.0.28-dont-hardcode-paths.patch 845 BLAKE2B 37618989b609bc7dd2d94d22fad0562d6e0580541d8f6ec2a222316da89a6744a16cac9b4cd446ef80f58cf415f4a784aefedf53349ea85e98cf33000b7799b6 SHA512 9947787a1c3ebbd0a73e271ebab3dfcd01b7aad3bcaa627e7a236947bc7edbc23696c38f96aae62785013e2ac8c5171ce6f386f655676a4cde8d820f49d5df7d
+AUX xmlto-0.0.28-fix-warnings.patch 3085 BLAKE2B 2c9e6323dda3fed36bdd999e10d76b8cfcc3c2bef3893ec044588c22519609889101d65f656f8ebb7b70a2819d009fb81d1f34ad2659b1398d7d3c7b9d565ffc SHA512 b16699d6e592c74ca7400f1a4a0ff6b158eb44cb6e77b73bebab03e10535f44890241bfd53d16382266da4102a42c4db7905481115324a76e667d1b91ec61fe1
DIST xmlto-0.0.28.tar.bz2 127921 BLAKE2B 12ef3e2e1436c330e7b003d08f4a4d4032d70255777956949eb8b47b6f5466e7c158b0f85dc87069c1e379603cac0b01c88589f98ca1ef9e862f0aef31169f6d SHA512 6e0c4968d4f1b7a3b132904182aa72a73f6167553eabdeb65cfafa6295ef7b960541685769d04144207963cca77b0c44db4f9fbb2796348ffcb37b3b399f18f1
EBUILD xmlto-0.0.28-r8.ebuild 1495 BLAKE2B fb48fd354d2837e842b3400014f768119d962345f9dd37cba16ef65517d8bf3c9933ed306d558f408809e513d171727383f7a54c207edd773dd46a15d4880fd9 SHA512 09a4b2c9467c8dc35301dd733207f82bc7f6ccdd9f764da50bfdba5de120ce66c388e181e709ae22e08164e5fdde79ea74aca8a95bf8658b6004e3bf1645022f
+EBUILD xmlto-0.0.28-r9.ebuild 1596 BLAKE2B 8b9bf3d3249c7985e9e0f7afa7166e704452f09a92d786aaeaa28839ac66689ec64f971a0840c0a930054ea87f1068863c4e37eb3dfc24c85de6ca8f41017856 SHA512 3833b6f2d10c22237a2fce8e7717db020695b6b1b51b7ab211dca02194ff7b6ba24c1fa8da3686d5a9a186edde53644701160a7c6c841c01d6e15565c2812b4f
MISC metadata.xml 324 BLAKE2B 3cabb2600d6843ebecec023a16fef87a40432202ff195a6130e57f97802d4c0ed2e82ffee506c65afe554291f05c64c7ae2fe524c708db7a9c6bf4a71c4c8710 SHA512 19ed2fabc04f96b1b61495e2fdba674ca4b4a9a1cee11b3cb13baec6d9e7fe0d82b653a0cbb523de3fcd4ed1ef18d8111686f8b618db9924674ee274ae5a21ed
diff --git a/app-text/xmlto/files/xmlto-0.0.28-fix-warnings.patch b/app-text/xmlto/files/xmlto-0.0.28-fix-warnings.patch
new file mode 100644
index 000000000000..b90eea1f42df
--- /dev/null
+++ b/app-text/xmlto/files/xmlto-0.0.28-fix-warnings.patch
@@ -0,0 +1,116 @@
+https://bugs.gentoo.org/869080
+
+https://pagure.io/xmlto/c/1375e2df75530cd198bd16ac3de38e2b0d126276?branch=master
+https://pagure.io/xmlto/c/412f97cdc00d2bbf7e8121012b49fc07b3fe3d2b?branch=master
+https://pagure.io/xmlto/c/8e34f087bf410bcc5fe445933d6ad9bae54f24b5?branch=master
+https://pagure.io/xmlto/c/6fa6a0e07644f20abf2596f78a60112713e11cbe?branch=master
+
+From 1375e2df75530cd198bd16ac3de38e2b0d126276 Mon Sep 17 00:00:00 2001
+From: Thomas Kuehne <thomas@kuehne.cn>
+Date: Dec 11 2021 20:45:45 +0000
+Subject: fix -Wimplicit-int for ifsense
+
+
+fixes:
+xmlif/xmlif.l:46:8: warning: type defaults to ‘int’ in declaration of ‘ifsense’ [-Wimplicit-int]
+ 46 | static ifsense; /* sense of last `if' or unless seen */
+ | ^~~~~~~
+
+Signed-off-by: Thomas Kuehne <thomas@kuehne.cn>
+
+--- a/xmlif/xmlif.l
++++ b/xmlif/xmlif.l
+@@ -43,7 +43,7 @@
+
+ static char **selections; /* selection tokens */
+ static int nselections; /* number of selections */
+-static ifsense; /* sense of last `if' or unless seen */
++static int ifsense; /* sense of last `if' or unless seen */
+ static char *attribute; /* last attribute scanned */
+
+ struct stack_t {
+
+
+From 412f97cdc00d2bbf7e8121012b49fc07b3fe3d2b Mon Sep 17 00:00:00 2001
+From: Thomas Kuehne <thomas@kuehne.cn>
+Date: Dec 11 2021 20:45:59 +0000
+Subject: fix extra ‘;’ outside of a function
+
+
+Fixes:
+xmlif/xmlif.l:240:24: warning: ISO C does not allow extra ‘;’ outside of a function [-Wpedantic]
+ 240 | int yywrap() {exit(0);};
+ | ^
+
+Signed-off-by: Thomas Kuehne <thomas@kuehne.cn>
+
+--- a/xmlif/xmlif.l
++++ b/xmlif/xmlif.l
+@@ -237,7 +237,7 @@ WS [ \t\n]*
+
+ #include "config.h"
+
+-int yywrap() {exit(0);};
++int yywrap() {exit(0);}
+
+ main(int argc, char *argv[])
+ {
+
+
+From 8e34f087bf410bcc5fe445933d6ad9bae54f24b5 Mon Sep 17 00:00:00 2001
+From: Thomas Kuehne <thomas@kuehne.cn>
+Date: Dec 11 2021 20:56:00 +0000
+Subject: Fix return type of main function
+
+
+Fixes:
+xmlif/xmlif.l:242:1: warning: return type defaults to ‘int’ [-Wimplicit-int]
+ 242 | main(int argc, char *argv[])
+ | ^~~~
+
+Signed-off-by: Thomas Kuehne <thomas@kuehne.cn>
+
+--- a/xmlif/xmlif.l
++++ b/xmlif/xmlif.l
+@@ -239,7 +239,7 @@ WS [ \t\n]*
+
+ int yywrap() {exit(0);}
+
+-main(int argc, char *argv[])
++int main(int argc, char *argv[])
+ {
+ int i;
+
+@@ -265,7 +265,7 @@ main(int argc, char *argv[])
+ exit(1);
+ }
+
+- yylex();
++ return yylex();
+ }
+
+ /*
+
+From 6fa6a0e07644f20abf2596f78a60112713e11cbe Mon Sep 17 00:00:00 2001
+From: Thomas Kuehne <thomas@kuehne.cn>
+Date: Dec 11 2021 21:03:42 +0000
+Subject: add strings.h import
+
+
+Fixes:
+xmlif/xmlif.l:162:13: warning: implicit declaration of function ‘strncasecmp’; did you mean ‘strncmp’? [-Wimplicit-function-declaration]
+ 162 | if (strncasecmp(selections[i], attr, eqoffset) == 0)
+ | ^~~~~~~~~~~
+
+Signed-off-by: Thomas Kuehne <thomas@kuehne.cn>
+
+--- a/xmlif/xmlif.l
++++ b/xmlif/xmlif.l
+@@ -37,6 +37,7 @@
+ */
+ #include <string.h>
+ #include <stdlib.h>
++#include <strings.h>
+
+ #define TRUE 1
+ #define FALSE 0
diff --git a/app-text/xmlto/xmlto-0.0.28-r9.ebuild b/app-text/xmlto/xmlto-0.0.28-r9.ebuild
new file mode 100644
index 000000000000..1ac025998449
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.28-r9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Script for converting XML and DocBook documents to a variety of output formats"
+HOMEPAGE="https://pagure.io/xmlto"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="latex text"
+
+RDEPEND="
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ || ( sys-apps/util-linux app-misc/getopt )
+ text? ( || ( virtual/w3m www-client/elinks www-client/links www-client/lynx ) )
+ latex? ( dev-texlive/texlive-formatsextra )
+"
+DEPEND="${RDEPEND}"
+# We only depend on flex when we patch the input lexer.
+# We touch it in fix-warnings.patch.
+BDEPEND="sys-devel/flex"
+
+DOCS=( AUTHORS ChangeLog FAQ NEWS README THANKS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+ "${FILESDIR}"/${PN}-0.0.28-allow-links.patch
+ "${FILESDIR}"/${P}-dont-hardcode-paths.patch
+ "${FILESDIR}"/${P}-fix-warnings.patch
+)
+
+src_prepare() {
+ default
+
+ # fix symbol clash on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/\(attrib\|val\)/XMLTO\1/g' xmlif/xmlif.l || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # We don't want the script to detect /bin/sh if it is bash.
+ export ac_cv_path_BASH="${BASH}"
+ has_version sys-apps/util-linux || export GETOPT=getopt-long
+
+ econf
+}