summaryrefslogtreecommitdiff
path: root/app-shells/tmux-bash-completion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/tmux-bash-completion
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/tmux-bash-completion')
-rw-r--r--app-shells/tmux-bash-completion/Manifest2
-rw-r--r--app-shells/tmux-bash-completion/metadata.xml15
-rw-r--r--app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild25
3 files changed, 42 insertions, 0 deletions
diff --git a/app-shells/tmux-bash-completion/Manifest b/app-shells/tmux-bash-completion/Manifest
new file mode 100644
index 000000000000..cb0eb645ca0a
--- /dev/null
+++ b/app-shells/tmux-bash-completion/Manifest
@@ -0,0 +1,2 @@
+EBUILD tmux-bash-completion-9999.ebuild 520 SHA256 cc7668a89d1f6cb03be391b01c643c6cfbf9ddcf1a39615986685296c771bf4a SHA512 dc4b6d6be23e096d7603b3e610d2d4191a25ba444c7ac09c5a96bf1d93b86a97e3cfb4c1958a825a959f9abff2eb963719b19bec8ffc540c8b86c09f3c2273b2 WHIRLPOOL 83490d75e434e495994ca64681c11a9c841e0e76acf0929ab8849ec517e368912910e671690b8c342150289f7c10e35d68bd6d6d0ced02b45b399adf0c23deef
+MISC metadata.xml 466 SHA256 1a45ed5f15f15882cba83c467f9d4e0e677ceebd7fbb3b4faf8fcd05c4939b96 SHA512 43cc836a286e1a0af0dd8a0a5762ea88368c1cf601795febb9134f4ab9d257b3ebcdc5d62d7e1651c776cd94437a7dfdc082c2bfd4b5ff82227f3236738b6c27 WHIRLPOOL 800a308748a44bb3a80648a820c4d34fca76ad6b151d3967c948f51283c6e8750b5946868f040fd6a661dee8131aa40c888a48b7baa5df0777802a54052c554e
diff --git a/app-shells/tmux-bash-completion/metadata.xml b/app-shells/tmux-bash-completion/metadata.xml
new file mode 100644
index 000000000000..1f6ba86c16f2
--- /dev/null
+++ b/app-shells/tmux-bash-completion/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>imomaliev@github.com</email>
+ <name>Sardorbek Imomaliev</name>
+ </maintainer>
+ <remote-id type="github">imomaliev/tmux-bash-completion</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild b/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild
new file mode 100644
index 000000000000..da4498863deb
--- /dev/null
+++ b/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="bash-completion scripts for tmux"
+HOMEPAGE="https://github.com/imomaliev/tmux-bash-completion"
+EGIT_REPO_URI="https://github.com/imomaliev/tmux-bash-completion.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ >=app-misc/tmux-2.2
+ app-shells/bash-completion
+ "
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ dobashcomp "${S}"/completions/tmux
+}