summaryrefslogtreecommitdiff
path: root/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild')
-rw-r--r--app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild b/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild
new file mode 100644
index 000000000000..da4498863deb
--- /dev/null
+++ b/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="bash-completion scripts for tmux"
+HOMEPAGE="https://github.com/imomaliev/tmux-bash-completion"
+EGIT_REPO_URI="https://github.com/imomaliev/tmux-bash-completion.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ >=app-misc/tmux-2.2
+ app-shells/bash-completion
+ "
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ dobashcomp "${S}"/completions/tmux
+}