summaryrefslogtreecommitdiff
path: root/app-shells/sash/sash-3.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/sash/sash-3.8.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/sash/sash-3.8.ebuild')
-rw-r--r--app-shells/sash/sash-3.8.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/sash/sash-3.8.ebuild b/app-shells/sash/sash-3.8.ebuild
new file mode 100644
index 000000000000..6c2ee580ce04
--- /dev/null
+++ b/app-shells/sash/sash-3.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A small (static) UNIX Shell"
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="static"
+
+DEPEND="
+ static? ( sys-libs/zlib[static-libs] )
+ !static? ( >=sys-libs/zlib-1.2.3 )"
+RDEPEND="!static? ( ${DEPEND} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/sash-3.7-builtin.patch
+
+ sed \
+ -e "s:-O3:${CFLAGS}:" \
+ -e '/strip/d' \
+ -i Makefile || die
+ sed \
+ -e 's:linux/ext2_fs.h:ext2fs/ext2_fs.h:g' \
+ -i cmd_chattr.c || die
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ into /
+ dobin sash
+ doman sash.1
+ dodoc README
+}