summaryrefslogtreecommitdiff
path: root/app-shells/sash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/sash
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/sash')
-rw-r--r--app-shells/sash/Manifest4
-rw-r--r--app-shells/sash/files/sash-3.7-builtin.patch14
-rw-r--r--app-shells/sash/metadata.xml5
-rw-r--r--app-shells/sash/sash-3.8.ebuild45
4 files changed, 68 insertions, 0 deletions
diff --git a/app-shells/sash/Manifest b/app-shells/sash/Manifest
new file mode 100644
index 000000000000..0edac8cb7926
--- /dev/null
+++ b/app-shells/sash/Manifest
@@ -0,0 +1,4 @@
+AUX sash-3.7-builtin.patch 465 BLAKE2B 9665d97abbb0da68065dee7934f9604f59436af5522a45dad3331ec3540e86634c7e1415f18be2868297b3261f0fa829ba2e6329723c61746f18d913357b3165 SHA512 3c278b7a6570195d62aee65582edffa74e12a68cd684b7855256083b45c99a5a8f6506e2c59ab4edbd1ba094e7d512dfe7c90a79945f2be5261a5975d5b95d23
+DIST sash-3.8.tar.gz 53049 BLAKE2B 151e24e3f1f56231a12fa332505ad21586c97c7bb9cc3858e12ea4aa410d4e30da4af8201b4e24f0b960f2f142c964ac1996f3475ec9a104bdc52a5e1a55c010 SHA512 e544721dbb5d13d2184531a2caa4b90fb29fc360e2b80f64adb2433cbe4e5588171f3567bde03b520fbe7cbd0f3007e0e9c9c41cb16570709b03cedc2dfbe291
+EBUILD sash-3.8.ebuild 943 BLAKE2B 0b12e1b905a0e9105285105a94b756add018ce8f51a16c4297a5ea0a91c2293e47cdc7fc30d0e1102fd3f83b672254cced92bc8924d6d035100d9a5540b603ee SHA512 cea96aa1f7cbe08ec8a06ca668e0a09dc1348a09adf64b671b09d8f14aa4fb98a8c0b60e71e41ddfcf07a5b2cfd52122276adbf6605f94d60ac75fec81ce13e3
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-shells/sash/files/sash-3.7-builtin.patch b/app-shells/sash/files/sash-3.7-builtin.patch
new file mode 100644
index 000000000000..be943063efdf
--- /dev/null
+++ b/app-shells/sash/files/sash-3.7-builtin.patch
@@ -0,0 +1,14 @@
+diff -Nrup sash-3.7.orig/sash.c sash-3.7/sash.c
+--- sash-3.7.orig/sash.c 2004-01-14 00:08:03.000000000 -0500
++++ sash-3.7/sash.c 2004-10-31 00:05:59.000000000 -0400
+@@ -739,6 +739,10 @@ tryBuiltIn(const char * cmd)
+ while (*endCmd && !isBlank(*endCmd))
+ endCmd++;
+
++ /* FIXME: command line will segv with -c 12000bytes -solar */
++ if ((endCmd - cmd) >= sizeof(cmdName))
++ return FALSE;
++
+ memcpy(cmdName, cmd, endCmd - cmd);
+
+ cmdName[endCmd - cmd] = '\0';
diff --git a/app-shells/sash/metadata.xml b/app-shells/sash/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-shells/sash/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-shells/sash/sash-3.8.ebuild b/app-shells/sash/sash-3.8.ebuild
new file mode 100644
index 000000000000..6c2ee580ce04
--- /dev/null
+++ b/app-shells/sash/sash-3.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A small (static) UNIX Shell"
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="static"
+
+DEPEND="
+ static? ( sys-libs/zlib[static-libs] )
+ !static? ( >=sys-libs/zlib-1.2.3 )"
+RDEPEND="!static? ( ${DEPEND} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/sash-3.7-builtin.patch
+
+ sed \
+ -e "s:-O3:${CFLAGS}:" \
+ -e '/strip/d' \
+ -i Makefile || die
+ sed \
+ -e 's:linux/ext2_fs.h:ext2fs/ext2_fs.h:g' \
+ -i cmd_chattr.c || die
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ into /
+ dobin sash
+ doman sash.1
+ dodoc README
+}