summaryrefslogtreecommitdiff
path: root/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
commitf87d83ebb0d6ae5915c4775f762a0b5bceb9b2a5 (patch)
tree69b6db4e0c713061615ae368d69a16b0302e5bb9 /app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
parenta519cf56a0e5e456006d39c06f68de5e11c2f7e9 (diff)
gentoo auto-resync : 07:10:2023 - 18:01:02
Diffstat (limited to 'app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild')
-rw-r--r--app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild b/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
new file mode 100644
index 000000000000..f0151f7e8666
--- /dev/null
+++ b/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell tab completion and tooltip support for the dotnet CLI"
+HOMEPAGE="https://github.com/bergmeister/posh-dotnet/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/bergmeister/${PN}.git"
+else
+ if [[ "${PV}" == 1.2.3 ]] ; then
+ COMMIT="c017886cbad9c4f6ce1fbaa38ebbbcada664655b"
+
+ SRC_URI="https://github.com/bergmeister/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ SRC_URI="https://github.com/bergmeister/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ fi
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="${PV}"
+RESTRICT="test" # Tests fail.
+
+RDEPEND="virtual/pwsh:*"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins "${PN}.psd1" "${PN}.psm1"
+
+ einstalldocs
+}