summaryrefslogtreecommitdiff
path: root/app-shells/posh-dotnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
commitf87d83ebb0d6ae5915c4775f762a0b5bceb9b2a5 (patch)
tree69b6db4e0c713061615ae368d69a16b0302e5bb9 /app-shells/posh-dotnet
parenta519cf56a0e5e456006d39c06f68de5e11c2f7e9 (diff)
gentoo auto-resync : 07:10:2023 - 18:01:02
Diffstat (limited to 'app-shells/posh-dotnet')
-rw-r--r--app-shells/posh-dotnet/Manifest3
-rw-r--r--app-shells/posh-dotnet/metadata.xml13
-rw-r--r--app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild39
3 files changed, 55 insertions, 0 deletions
diff --git a/app-shells/posh-dotnet/Manifest b/app-shells/posh-dotnet/Manifest
new file mode 100644
index 000000000000..ccdf80802a48
--- /dev/null
+++ b/app-shells/posh-dotnet/Manifest
@@ -0,0 +1,3 @@
+DIST posh-dotnet-1.2.3.tar.gz 27996 BLAKE2B 88c6c771c5a8df6dc98785d11a586347b2ca167fd2353d373e371c40fa8b9f8385c6706ac9d9473a8a5d07a432a60e72644e69d806c298a9369dd2dc4e778266 SHA512 020d039ba3818cdc4861132514a2182f8093230be9647d1c18a015f095201d1df91b8622e5275db19b0ca5483357854ea5ecb840f2fdcf5a24a358705a3a5751
+EBUILD posh-dotnet-1.2.3.ebuild 909 BLAKE2B 68a4ac560db308a7adb12a4a9fd9eccc2a132765b8d2110c51436ca47dc45cf56bb025b62e9a8f9438ed67330ccd7a0c00763a33bfddd10ebc5489ed6ee5d346 SHA512 5f73ee0177108bcbd685fbce94222b4d9d5500088915e395441ca47cdfd171dcb44170684a0380332999cdb0c4c3ebfdce2b012ac023235d2b017c269544e538
+MISC metadata.xml 429 BLAKE2B ee88c7267a4fd56017a9b991130ba39b90c70f8dae1431656377989c084f08302f880003e2c8e2cdca04bd74f88af08a43ca590508ec990e7dc869933f15bffd SHA512 91ebc1ca45b1151537aa1d4bc5bacb83d8abded1a2f558e4c0ff8e9bfaa6b0d892e8892d31f5bd324d7e641840363ca4e4e0b21358fc811af4fb6cc32498719c
diff --git a/app-shells/posh-dotnet/metadata.xml b/app-shells/posh-dotnet/metadata.xml
new file mode 100644
index 000000000000..c5df59d0fe3b
--- /dev/null
+++ b/app-shells/posh-dotnet/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/bergmeister/posh-dotnet/issues/</bugs-to>
+ <remote-id type="github">bergmeister/posh-dotnet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild b/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
new file mode 100644
index 000000000000..f0151f7e8666
--- /dev/null
+++ b/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell tab completion and tooltip support for the dotnet CLI"
+HOMEPAGE="https://github.com/bergmeister/posh-dotnet/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/bergmeister/${PN}.git"
+else
+ if [[ "${PV}" == 1.2.3 ]] ; then
+ COMMIT="c017886cbad9c4f6ce1fbaa38ebbbcada664655b"
+
+ SRC_URI="https://github.com/bergmeister/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ SRC_URI="https://github.com/bergmeister/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ fi
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="${PV}"
+RESTRICT="test" # Tests fail.
+
+RDEPEND="virtual/pwsh:*"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins "${PN}.psd1" "${PN}.psm1"
+
+ einstalldocs
+}