summaryrefslogtreecommitdiff
path: root/app-shells/loksh/loksh-7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
commit32c16465e56b0122cf6e5a4625e9c7b56b107b07 (patch)
tree600c43152c825fda5f210dd7cb52b357eb6f2602 /app-shells/loksh/loksh-7.3.ebuild
parent607c0755d4f6476e326fb33795df7216a7bcff18 (diff)
gentoo auto-resync : 08:10:2023 - 06:02:21
Diffstat (limited to 'app-shells/loksh/loksh-7.3.ebuild')
-rw-r--r--app-shells/loksh/loksh-7.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-shells/loksh/loksh-7.3.ebuild b/app-shells/loksh/loksh-7.3.ebuild
new file mode 100644
index 000000000000..f591c53b2237
--- /dev/null
+++ b/app-shells/loksh/loksh-7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/loksh/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="
+ ${DEPEND}
+ !app-shells/ksh
+"
+
+src_prepare() {
+ default
+ sed -i "/install_dir/s@loksh@${PF}@" meson.build || die
+}
+
+src_configure() {
+ # we want it as /bin/ksh
+ meson_src_configure --bindir=../bin
+}