summaryrefslogtreecommitdiff
path: root/app-shells/loksh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
commit32c16465e56b0122cf6e5a4625e9c7b56b107b07 (patch)
tree600c43152c825fda5f210dd7cb52b357eb6f2602 /app-shells/loksh
parent607c0755d4f6476e326fb33795df7216a7bcff18 (diff)
gentoo auto-resync : 08:10:2023 - 06:02:21
Diffstat (limited to 'app-shells/loksh')
-rw-r--r--app-shells/loksh/Manifest2
-rw-r--r--app-shells/loksh/loksh-7.3.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-shells/loksh/Manifest b/app-shells/loksh/Manifest
index b8cedbc4b851..0e2aae281919 100644
--- a/app-shells/loksh/Manifest
+++ b/app-shells/loksh/Manifest
@@ -1,3 +1,5 @@
DIST loksh-7.1.tar.xz 211636 BLAKE2B 7604d6a5d3d3bce7dc51cde1d53ec10b927411afe700192e243e8dc022011cb3d89668768ba7940af22e97d95fd074638860e7b74fcacc8c83de4ad995654da4 SHA512 f46221f765f2799856049fbfe1650e6f3d13d597cf97843d4b54b9803b9ecedbf8a8c9364e1ba9b981b667004a8fe4da043006945f8b61f094678d3578518716
+DIST loksh-7.3.tar.xz 212120 BLAKE2B 2c1c56dcbfa664aa894b1f09f145b28f6861bf28f06274f32697eace30f24660dbcecdcf58938f6cae106e654d200ef0cb4cb2ecd309f3d60be4afc7fa6a6b9c SHA512 a054917c975f65dfb5f8eb35665044ddacacdbd2d1e1113e6bf62d5cd8d5f4fd775ff5f20e28191d2417016684a310f23115af102b834aa33083e2be41034477
EBUILD loksh-7.1.ebuild 608 BLAKE2B 80bac748b60c62a27d1a315da1b9e0488631891098d6d42fd59f924455204171ca5820d5c4d84785f207c02b11ce9d9615f919a1626883f542387e0fe33184c9 SHA512 015cd9b16cdd263a776f897188cd6624fa9838001f144574238cc938ea4afccc58a88ab492b87f69b8b26de9db34e25c78ed1b440fbea515764b18c723b1d9ce
+EBUILD loksh-7.3.ebuild 608 BLAKE2B 5bd751bdfd45126c9893f6ab14549ef48accc6da3a14e3b5234a8318a3f2ec35916a91137e1d8b079261dc0312d79273dcba718355f3edfe418bc4e6c6d408a5 SHA512 36a8e5a2e704b673c0ea6ba0905e9c5e88ba612f6034e56201b2a4703faf5f579acc0280f73bd9d5f5e607a223698c8f02a408468dd4cfe5dd7694d8d3c2bc92
MISC metadata.xml 249 BLAKE2B 142b02b03c614d9c821dc6367b16318494fecdb5b0f172c52661feb0239a404b6de757087be48910eeccba582942fcf4fc8adc95b665446d2d82d858536ec0e6 SHA512 cb8b29b51403536e9e2dad9337a0310d1f57123c9684c8372dacefccb23e389ba32c7e090efdb6404d1641b2b5a356bf11dd4f48b70f99f233700ce4b10db9aa
diff --git a/app-shells/loksh/loksh-7.3.ebuild b/app-shells/loksh/loksh-7.3.ebuild
new file mode 100644
index 000000000000..f591c53b2237
--- /dev/null
+++ b/app-shells/loksh/loksh-7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/loksh/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="
+ ${DEPEND}
+ !app-shells/ksh
+"
+
+src_prepare() {
+ default
+ sed -i "/install_dir/s@loksh@${PF}@" meson.build || die
+}
+
+src_configure() {
+ # we want it as /bin/ksh
+ meson_src_configure --bindir=../bin
+}