summaryrefslogtreecommitdiff
path: root/app-shells/ctypes-sh/ctypes-sh-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-shells/ctypes-sh/ctypes-sh-1.2.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-shells/ctypes-sh/ctypes-sh-1.2.ebuild')
-rw-r--r--app-shells/ctypes-sh/ctypes-sh-1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-shells/ctypes-sh/ctypes-sh-1.2.ebuild b/app-shells/ctypes-sh/ctypes-sh-1.2.ebuild
new file mode 100644
index 000000000000..a64a6db88110
--- /dev/null
+++ b/app-shells/ctypes-sh/ctypes-sh-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Foreign function interface for bash"
+HOMEPAGE="http://ctypes.sh/"
+SRC_URI="https://github.com/taviso/${PN/-/.}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ app-shells/bash[plugins(-)]
+ dev-libs/libffi
+ virtual/libelf
+"
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_test() {
+ pushd test >/dev/null || die
+ PATH="${S}:${PATH}" \
+ LD_LIBRARY_PATH="${S}/src/.libs" \
+ make CC="$(tc-getCC)" || die "make check failed"
+ popd > /dev/null || die
+}