summaryrefslogtreecommitdiff
path: root/app-shells/ctypes-sh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-shells/ctypes-sh
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-shells/ctypes-sh')
-rw-r--r--app-shells/ctypes-sh/Manifest5
-rw-r--r--app-shells/ctypes-sh/ctypes-sh-1.2.ebuild (renamed from app-shells/ctypes-sh/ctypes-sh-1.1.ebuild)27
-rw-r--r--app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch18
3 files changed, 15 insertions, 35 deletions
diff --git a/app-shells/ctypes-sh/Manifest b/app-shells/ctypes-sh/Manifest
index 9288f202ac96..a7b0eda90e9f 100644
--- a/app-shells/ctypes-sh/Manifest
+++ b/app-shells/ctypes-sh/Manifest
@@ -1,4 +1,3 @@
-AUX ctypes-sh-1.1-makefile-fix.patch 893 BLAKE2B a665dbb0278fa98408da8e68c0a6fcd7c4558d1b99efc99bee5946f41a2ab864112fb5f7d9f44db5e182b0e190481da44e17a17fba5d954bb3f5b8e353936097 SHA512 4acbc4639058b628c09082aafeb7592b1f85e3db5ffe77d6db8807a6b4ae787c24685f305149ed9a76c5558c01e3d17fd6714aa1103c435364166b76df7baa26
-DIST ctypes-sh-1.1.tar.gz 437637 BLAKE2B d4279812d613a771ed405499dc623fce5faa00c22e75067857cea0a31e4a36a1531f7b27a1edff89075961bf5e8183bf0787a703cb36c1a8cbd7c03d8a18710f SHA512 0e136f5b9fc342875d02b1087daed60eed46f411765538f185d1da61430205113db72994ecdb125aded3eae114b3f487e7af398c1326334efdd197ee7de18a61
-EBUILD ctypes-sh-1.1.ebuild 740 BLAKE2B a4464f179f13d0763e24b4b13bc45679e7a1d63147e1b10240392779379982299b030166b382c63bcfc6ae1c9a1730df21897bd86aef4482df988c37eb6bee01 SHA512 7a698c3831b7c4f551e803c6d1d1fc7f28b293d316a92d2b5b738802bcdfd925bd31aef83cc8ad6f8e706e30ee90f164a553bee46cd4032a7d29f7f14d9e1382
+DIST ctypes-sh-1.2.tar.gz 475531 BLAKE2B 6fe00415244227629b952a0c18f9c95659a3fb22b9f17e109554f11084d27bf4c23eca5bfc49679b63367fa9fe74a20f206ac79955ed6588418033f37b776729 SHA512 23e9c30acc8ed5b4fe93fe1427c406e7c7b18067bbfc3f948126683910efc645cc69e426d771beb715148b54dffce75351b7773d8b54ac13f74d9787db8529f6
+EBUILD ctypes-sh-1.2.ebuild 731 BLAKE2B cbdee5849bad59fcf3a0ab7956e31e0323c4ec0dab15693e05257f2f2982dd6409857b08b9ef31f4f07c9d39777894c2c3f682eb2b5f50eb9fce39054f1ba97e SHA512 901d2817e18509b6a7470a6d48e22b6e3fe65dbb21133ad487d5d0996ddf023684bb28ef4f767fa133e1b653786ac5faa92521bc613e7dc22fda513b8684e655
MISC metadata.xml 558 BLAKE2B 820b7e4f6e8c7fec2ba02cc164090f20464b78a137f53697532224a360c63952e219c77aebfad40f75673e2c8e82b08100358232290701d47fdf6b66426bfebb SHA512 514d59c04f3c419abcf7ab54a8860506bbcca810c2cafb911b4dcf468cb7b81f63e6f5c01b92c3bb5b2d10c2266bb7adf0ba264aba3bfe632aebcf7d1d3fb1a7
diff --git a/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild b/app-shells/ctypes-sh/ctypes-sh-1.2.ebuild
index e737d10f3e87..a64a6db88110 100644
--- a/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild
+++ b/app-shells/ctypes-sh/ctypes-sh-1.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools toolchain-funcs
@@ -13,17 +13,16 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="virtual/libffi
- virtual/libelf
- app-arch/xz-utils
+RDEPEND="
app-arch/bzip2
- app-shells/bash[plugins]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${P}-makefile-fix.patch"
-)
+ app-arch/xz-utils
+ app-shells/bash[plugins(-)]
+ dev-libs/libffi
+ virtual/libelf
+"
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
src_prepare() {
default
@@ -31,9 +30,9 @@ src_prepare() {
}
src_test() {
- pushd test
+ pushd test >/dev/null || die
PATH="${S}:${PATH}" \
LD_LIBRARY_PATH="${S}/src/.libs" \
make CC="$(tc-getCC)" || die "make check failed"
- popd
+ popd > /dev/null || die
}
diff --git a/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch b/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch
deleted file mode 100644
index 9a2965a62bc5..000000000000
--- a/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-commit 5e305160cc219fa63658148e3d258cb62dd043a3
-Author: rtlanceroad <rtlanceroad@gmail.com>
-Date: Wed Jul 27 14:49:21 2016 +0800
-
- fix Makefile.am in src dir
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 8a9b682..71347bb 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -11,6 +11,6 @@ ctypes_la_LIBADD += libstruct.la
- noinst_LTLIBRARIES += libstruct.la
- noinst_HEADERS += struct/dutil.h struct/dwarves.h struct/elf_symtab.h struct/gobuffer.h struct/hash.h struct/list.h struct/rbtree.h struct/strings.h
- libstruct_la_SOURCES = struct/dutil.c struct/dwarves.c struct/gobuffer.c struct/struct.c struct/strings.c struct/dwarf_loader.c struct/dwarves_fprintf.c struct/elf_symtab.c struct/rbtree.c
--libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE
-+libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE $(FFI_CFLAGS)
- libstruct_la_CPPFLAGS = -I../include -I../lib
- endif