summaryrefslogtreecommitdiff
path: root/app-mobilephone/adb-sync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-mobilephone/adb-sync
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-mobilephone/adb-sync')
-rw-r--r--app-mobilephone/adb-sync/Manifest2
-rw-r--r--app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/app-mobilephone/adb-sync/Manifest b/app-mobilephone/adb-sync/Manifest
index aafa39356252..a88dde943c26 100644
--- a/app-mobilephone/adb-sync/Manifest
+++ b/app-mobilephone/adb-sync/Manifest
@@ -1,3 +1,5 @@
DIST adb-sync-0_p20181127.tar.gz 13952 BLAKE2B b9097f44eebd76e54cee41f097933f85151399e99275268274252b53f47ab241ecb888f3631dd9f657213160f02e9f3638d782fb24de8e38631d0e2a81b6b03e SHA512 007b9ec089170f3e679a26f23952043ad922a2f988532183200ddd15792858d4d38c6dbd617b32ff0e17d01b37b246c173e4a3f8c008f7cf4bca551e64cd0ca3
+DIST adb-sync-0_p20190101.tar.gz 13956 BLAKE2B 380109fa302fc5376de8124aa31c3fa03a27ece22d7f2d74638a5387820ad7c2b294daa6e8185f6eef49524e987d7a7f1222a1ee3b6550247993ebcc7c1ac98d SHA512 8bd5eb514c63327860017402f509231a0882cd3624ed3350039b2383f38e503abc6cd319ff41a47d70031958b0b38b973c36272fc4af6e69cce54e15e6bb6990
EBUILD adb-sync-0_p20181127-r1.ebuild 718 BLAKE2B 9efd5a0aed0e299d5e710fd29c286ab41f7ffc4c8665e2f6b02dc32a924696b745ac337d40a3c153228b28380f6358ec86400fe2023ea2dfe9f2ccbf7b8838df SHA512 0e87cb5d3ca8598c3b93a9874fef68ed7e53f236859679732883602cf3779b79e0c78f3bc3fd6ef9d74042ea5ea63363fef3a8598d1a78db55277fcc97760ba4
+EBUILD adb-sync-0_p20190101.ebuild 753 BLAKE2B 1337750e5cbcc15b762cc0c18e3dceb6e079d7b73696646838d427638969dc4e50a7d22f91e89e0ff48b16d61d25705dce97f98a82c09bb605751acbe03516a5 SHA512 bc07953f6d675d5400ea15f6603155c606fcafae5465acfbb18418c06be758d707cf5ee8cdc0354c7552bdb561ab0086b2dbe0e643cb6f069ec475ccf4aa76bc
MISC metadata.xml 483 BLAKE2B 0b7ef2215754e8d77ba39a0ae635d74ddefab07eafbb00c5a1a806eb533fdc8224edcb0d0100c70017c4af3115db22dad81e66b9c37a3c89bb9928a023e518e0 SHA512 f4be0d74af3c6fa0a982de8c3410c2c4fa0f19dd77d368ddce8169e9c3db4e2a89c01d8c651212851e2a30e30b5b5133f8c740ce120bf8cff5fb84ec68c11bd7
diff --git a/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
new file mode 100644
index 000000000000..9ad99a6a5711
--- /dev/null
+++ b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+COMMIT=fb7c549753de7a5579ed3400dd9f8ac71f7bf1b1
+
+DESCRIPTION="Synchronize files between a PC and an Android device using ADB"
+HOMEPAGE="https://github.com/google/adb-sync"
+SRC_URI="https://github.com/google/adb-sync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+channel"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-util/android-tools
+ channel? ( net-misc/socat )"
+DEPEND=""
+
+S="${WORKDIR}/adb-sync-${COMMIT}"
+
+src_install() {
+ dodoc README.md
+ python_doscript adb-sync
+ use channel && dobin adb-channel
+}