summaryrefslogtreecommitdiff
path: root/app-mobilephone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-mobilephone
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/Manifest.gzbin2395 -> 2390 bytes
-rw-r--r--app-mobilephone/adb-sync/Manifest2
-rw-r--r--app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild32
-rw-r--r--app-mobilephone/sobexsrv/Manifest3
-rw-r--r--app-mobilephone/sobexsrv/files/init.d_sobexsrv6
-rw-r--r--app-mobilephone/sobexsrv/sobexsrv-1.0.1-r3.ebuild72
-rw-r--r--app-mobilephone/vmoconv/Manifest2
-rw-r--r--app-mobilephone/vmoconv/metadata.xml4
8 files changed, 112 insertions, 9 deletions
diff --git a/app-mobilephone/Manifest.gz b/app-mobilephone/Manifest.gz
index 20114d157a77..3da9bb69fa3d 100644
--- a/app-mobilephone/Manifest.gz
+++ b/app-mobilephone/Manifest.gz
Binary files differ
diff --git a/app-mobilephone/adb-sync/Manifest b/app-mobilephone/adb-sync/Manifest
index aafa39356252..a88dde943c26 100644
--- a/app-mobilephone/adb-sync/Manifest
+++ b/app-mobilephone/adb-sync/Manifest
@@ -1,3 +1,5 @@
DIST adb-sync-0_p20181127.tar.gz 13952 BLAKE2B b9097f44eebd76e54cee41f097933f85151399e99275268274252b53f47ab241ecb888f3631dd9f657213160f02e9f3638d782fb24de8e38631d0e2a81b6b03e SHA512 007b9ec089170f3e679a26f23952043ad922a2f988532183200ddd15792858d4d38c6dbd617b32ff0e17d01b37b246c173e4a3f8c008f7cf4bca551e64cd0ca3
+DIST adb-sync-0_p20190101.tar.gz 13956 BLAKE2B 380109fa302fc5376de8124aa31c3fa03a27ece22d7f2d74638a5387820ad7c2b294daa6e8185f6eef49524e987d7a7f1222a1ee3b6550247993ebcc7c1ac98d SHA512 8bd5eb514c63327860017402f509231a0882cd3624ed3350039b2383f38e503abc6cd319ff41a47d70031958b0b38b973c36272fc4af6e69cce54e15e6bb6990
EBUILD adb-sync-0_p20181127-r1.ebuild 718 BLAKE2B 9efd5a0aed0e299d5e710fd29c286ab41f7ffc4c8665e2f6b02dc32a924696b745ac337d40a3c153228b28380f6358ec86400fe2023ea2dfe9f2ccbf7b8838df SHA512 0e87cb5d3ca8598c3b93a9874fef68ed7e53f236859679732883602cf3779b79e0c78f3bc3fd6ef9d74042ea5ea63363fef3a8598d1a78db55277fcc97760ba4
+EBUILD adb-sync-0_p20190101.ebuild 753 BLAKE2B 1337750e5cbcc15b762cc0c18e3dceb6e079d7b73696646838d427638969dc4e50a7d22f91e89e0ff48b16d61d25705dce97f98a82c09bb605751acbe03516a5 SHA512 bc07953f6d675d5400ea15f6603155c606fcafae5465acfbb18418c06be758d707cf5ee8cdc0354c7552bdb561ab0086b2dbe0e643cb6f069ec475ccf4aa76bc
MISC metadata.xml 483 BLAKE2B 0b7ef2215754e8d77ba39a0ae635d74ddefab07eafbb00c5a1a806eb533fdc8224edcb0d0100c70017c4af3115db22dad81e66b9c37a3c89bb9928a023e518e0 SHA512 f4be0d74af3c6fa0a982de8c3410c2c4fa0f19dd77d368ddce8169e9c3db4e2a89c01d8c651212851e2a30e30b5b5133f8c740ce120bf8cff5fb84ec68c11bd7
diff --git a/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
new file mode 100644
index 000000000000..9ad99a6a5711
--- /dev/null
+++ b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+COMMIT=fb7c549753de7a5579ed3400dd9f8ac71f7bf1b1
+
+DESCRIPTION="Synchronize files between a PC and an Android device using ADB"
+HOMEPAGE="https://github.com/google/adb-sync"
+SRC_URI="https://github.com/google/adb-sync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+channel"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-util/android-tools
+ channel? ( net-misc/socat )"
+DEPEND=""
+
+S="${WORKDIR}/adb-sync-${COMMIT}"
+
+src_install() {
+ dodoc README.md
+ python_doscript adb-sync
+ use channel && dobin adb-channel
+}
diff --git a/app-mobilephone/sobexsrv/Manifest b/app-mobilephone/sobexsrv/Manifest
index 801a8cb8ff84..834626dd2617 100644
--- a/app-mobilephone/sobexsrv/Manifest
+++ b/app-mobilephone/sobexsrv/Manifest
@@ -1,7 +1,8 @@
AUX conf.d_sobexsrv 1095 BLAKE2B 858ca7030f7809c7eabc1ccd5b856b010a79bc693ef279232ecafa07ccfd99006a72190785308c27c6cd6d9f0422c1fb252e4e85ccb1be11c7445aad59cd2c9e SHA512 c38b6105826208c72392b7e781831ec28e93c60ba63f95e6042c3de9a3097af1e370ccdb832f1993b6e85a0224180b36a92ba97cf9af8a606044a61d9ddf7a05
-AUX init.d_sobexsrv 1473 BLAKE2B f5ed1fccc6de4419a62185fee1460b2acbd101602c09b516c7944a84507f84912b4a493dd9483611ecafbb6ee5083300ba6bf5354e7645240759845c102d6a1f SHA512 0ab5c6020af3c8de1e7f302f1f9b1fb6c8d9f6ef8518f878c48ee396032aa96f2da148e197655a1235a072abf30767e3db8047d0c9c6d7d3606bf9ad30398ec4
+AUX init.d_sobexsrv 1471 BLAKE2B eaf115c6303ede41dbeeaa60561082ac07b9d908f391eb4ca72fb65773a842aa8abd0ca63bb411d6a7db97db7e2dad995b956816845242b9e408701a7daf517b SHA512 6e1beb275bddac1b5e37c82a825e0b1fbb830127401963129bd59b03999136b10ac538e3231b49c50c19dde8e407ef93e0040c62ac0ecaf714b771578f00bd41
AUX sobexsrv-1.0.1-openobex16.patch 1346 BLAKE2B ec63105eb6db6fd959044134fd66b8b3018093a5efec4b6b6b63c45d9bcca84c678addc56bfefaad0fca1696c148107513a1640473cb37f5320c2fab9a623ded SHA512 a1db1a916c0c2f6f237a4434bf1f11b0b6f540ad62fa9687d886e4ff97f6bb916be7763a24bdc56bf8fd3334ead426e0ed2003c0208c3c743f49b13b2bf8ab2a
DIST sobexsrv-1.0.1-fix64.patch 25040 BLAKE2B 9796779fdde39c79371a978d4bdb9d6761f9467ecc353096c3d1b13fe1d5aa4f7ceef137d07c52467a175b7bc756e6c747a2800a2dbb2dcd281be463499106c9 SHA512 9d555bee8d03c13061bbe132df6442daa4d8817ef713e92e5150b1994af110c5b01b34f8bcc1c3ae734529e36bb70f56976ab261f860e95e3de3ffe440a7b393
DIST sobexsrv-1.0.1.tar.gz 27683 BLAKE2B f1aa103aa8a70ea7408ced7b0a3944d0ba61dc9750425160ee95bb69e1f1cf4479fbecef7be3ba4b6cbec2a7f518bed18318ca694545a4606888e7663adb0d38 SHA512 52fe5eff812596caa1f4b8579740ce8b2591db17950d68c093cfdb33ca5b899bfc5c142594843948a29ae0b1bdbe4499a1e24c270c92e61d02fd07a02d9d40cd
EBUILD sobexsrv-1.0.1-r2.ebuild 2005 BLAKE2B 28fedfe5d4f64bc696d1f481a9855c57bbeb0ae8e6ca0fa9cd493b718051089abb3f17ee96c526f07600d33050bd57c6940d1b7d9178310d2c6735a6dde51071 SHA512 1a60a31ea11f4b21039fcd5e4694fa0d5c5b91c11fccb09d362a8d7862885f2c628f6f52b736db4347fd29a3e6a63b2375868d5771363c2dde272eac2e692637
+EBUILD sobexsrv-1.0.1-r3.ebuild 1515 BLAKE2B eb243e86f5debb674db06630bc856b96ae84f077cbee6512cb3a52198e4005b0af78ca9dbff2d27f04c207d03407d7089174b8e36973666367cc0af5cde2dd3b SHA512 f73a9a9058aa6fe0a4615a34d5472bafd75eba3cb770f3d3fb030be400451c9976a2a38bcc4e3aa7298e6bf6776189637cb22c076e445385288af24cc33423be
MISC metadata.xml 920 BLAKE2B ac1ea1fc1f85d7dd43c548d89ef3473bb5b78f2e3ab4275c28db702865e492261db1ab908496661ebda406771d7d8080e9057bed865b703b9920ee86b48c8b34 SHA512 30b149f3e197dc0a45cd27a618a0dcc6c9968dae44576c47dd6ebdedda06d5fed8b03ae1e0f94133804551366a90a97614d5d5eca334dbdabd4398278645aab9
diff --git a/app-mobilephone/sobexsrv/files/init.d_sobexsrv b/app-mobilephone/sobexsrv/files/init.d_sobexsrv
index e02530314ca8..fa27e19ef116 100644
--- a/app-mobilephone/sobexsrv/files/init.d_sobexsrv
+++ b/app-mobilephone/sobexsrv/files/init.d_sobexsrv
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
depend() {
@@ -17,7 +17,7 @@ check_config() {
return 1
fi
- if [ ${CHROOT} = "yes" ] ; then
+ if [ "${CHROOT}" = "yes" ] ; then
if [ ! -u /usr/bin/sobexsrv ] ; then
eerror "The \$CHROOT option requires /usr/bin/sobexsrv to be suid root!"
return 1
@@ -47,7 +47,7 @@ start() {
OPTIONS="-I -r ${INBOX} ${OPTIONS} ${SOBEXSRV_OPT}"
- start-stop-daemon --chuid ${USER}:${GROUP} --start --quiet --exec /usr/bin/sobexsrv -- $OPTIONS
+ start-stop-daemon --user ${USER}:${GROUP} --start --quiet --exec /usr/bin/sobexsrv -- $OPTIONS
eend $?
}
diff --git a/app-mobilephone/sobexsrv/sobexsrv-1.0.1-r3.ebuild b/app-mobilephone/sobexsrv/sobexsrv-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..e748963f7b5d
--- /dev/null
+++ b/app-mobilephone/sobexsrv/sobexsrv-1.0.1-r3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${P/_pre/pre}"
+
+DESCRIPTION="Scripting/Secure OBEX Server (for BlueZ Linux)"
+SRC_URI="http://www.mulliner.org/bluetooth/${MY_P}.tar.gz
+ https://dev.gentoo.org/~joker/${P}-fix64.patch"
+HOMEPAGE="http://www.mulliner.org/bluetooth/sobexsrv.php"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ >=dev-libs/openobex-1.7.2-r1
+ net-wireless/bluez
+"
+RDEPEND="${DEPEND}
+ acct-user/sobexsrv
+ acct-group/sobexsrv
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${DISTDIR}/${P}"-fix64.patch
+ "${FILESDIR}/${P}"-openobex16.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e 's:/usr/man/man8:/usr/share/man/man8:' \
+ -e 's/install: all/install:/' \
+ -i Makefile || die
+
+ sed -e 's/^CFLAGS =/CFLAGS +=/' \
+ -e 's/^CC =/CC ?=/' \
+ -e 's/$(CC) $(CFLAGS)/$(CC) $(LDFLAGS) $(CFLAGS)/' \
+ -i src/Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake -C src
+}
+
+src_install() {
+ default
+ dodoc AUTHOR CONFIG SECURITY THANKS
+ rm "${D}/usr/bin/sobexsrv_handler" || die
+
+ newinitd "${FILESDIR}/init.d_sobexsrv" sobexsrv
+ newconfd "${FILESDIR}/conf.d_sobexsrv" sobexsrv
+}
+
+pkg_postinst() {
+ elog
+ elog "/usr/bin/sobexsrv is *NOT* installed set-uid root by"
+ elog "default. suid is required for the chroot option (-R)."
+ elog
+ elog "Execute the following commands to enable suid:"
+ elog
+ elog "chown root:sobexsrv /usr/bin/sobexsrv"
+ elog "chmod 4710 /usr/bin/sobexsrv"
+ elog
+}
diff --git a/app-mobilephone/vmoconv/Manifest b/app-mobilephone/vmoconv/Manifest
index 87b8de0be234..4172cb631bb6 100644
--- a/app-mobilephone/vmoconv/Manifest
+++ b/app-mobilephone/vmoconv/Manifest
@@ -3,4 +3,4 @@ AUX vmoconv-1.0-flags.patch 683 BLAKE2B 9320d396eaf46480c7473fa52934c8786ca31dac
AUX vmoconv-1.0-glibc28.patch 876 BLAKE2B 5d58b8ddda99b268748bdcea1004dfc4ddb48547ea502fd5a3f98683338230f23a15584d854bfa2147e702be06a22621a03767c9563522cf6c350155c7e13cfd SHA512 14477a9c13fabae162dfe8fc4b701019fb52e387198c70542275b1e9562a683532f8b88a96a9b8c7d9aea8e5f27224baa27046a04ce164adcd2d260f0a22e011
DIST vmoconv-1.0.tar.gz 315028 BLAKE2B c31d2f4f5c45511b52a80b829b9c632519eccaf6aeb3bb74deef8ff9cdf0aea244e52c82751f8d23865e5250004d33dfc2c0b101fd03ce7cf0c08f94c3a79ce2 SHA512 c4bd65f2c034317e43736198eaea6a3cfbbc6be015dc1ac5efa51633c2779bf5af87ea037084173b377a7521538e4a235f264b5f09fedcdaf7f4a815289a7ec2
EBUILD vmoconv-1.0-r1.ebuild 752 BLAKE2B 22f7972256f0bf71c839357c95e08e980fe2e319d1ab16170466660d1e88e9553d6bf165db90edfee75979fd6e5b7a5c29c942b950515b1fbd1100932e880d2a SHA512 e8e28d1de9e9c58fcf80313bbf9feb8e0fd23981574b512f268cbcc9792cff861c09cbdfd86745e75b9fbc066c6aecd9477889ea71f3dc719d2370a97835ac91
-MISC metadata.xml 296 BLAKE2B 1d34ceee0f682bb05def16df979d321f3da6ac51a494dc1656aaeacffa37d4964a8520de1818d0f838c473e24419536dc02ae587b8224fd27d0d5e6b99514a3b SHA512 725dd98a8cdf1814e9a91472eb7f51131193c3825fdce5507a397b1a833040de9fb067b9fc8b3fac3459b3e14f61257032164ed63c1fadaaa5107a508f5a069e
+MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/app-mobilephone/vmoconv/metadata.xml b/app-mobilephone/vmoconv/metadata.xml
index fd8646d07b57..7a38bb900964 100644
--- a/app-mobilephone/vmoconv/metadata.xml
+++ b/app-mobilephone/vmoconv/metadata.xml
@@ -2,8 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
- <longdescription lang="en">
- A tool that converts Siemens phones VMO and VMI audio files to gsm and
- wav.
- </longdescription>
</pkgmetadata>