summaryrefslogtreecommitdiff
path: root/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
commit0c764edfecb7e9e124d4669acd98bed09e23b6c0 (patch)
tree2862ab17d2f88cb7c9614b7fbe579f25ae604b8d /app-misc/pipeworks/pipeworks-0.4-r2.ebuild
parentae1bf373db295b495e1f685d116e3411bf10df0b (diff)
gentoo auto-resync : 01:08:2022 - 03:14:32
Diffstat (limited to 'app-misc/pipeworks/pipeworks-0.4-r2.ebuild')
-rw-r--r--app-misc/pipeworks/pipeworks-0.4-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/pipeworks/pipeworks-0.4-r2.ebuild b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
new file mode 100644
index 000000000000..bcef6fb41379
--- /dev/null
+++ b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A small utility that measures throughput between stdin and stdout"
+HOMEPAGE="http://pipeworks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pipeworks/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin pipeworks
+ doman pipeworks.1
+ dodoc Changelog README
+}