summaryrefslogtreecommitdiff
path: root/app-misc/pipeworks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
commit0c764edfecb7e9e124d4669acd98bed09e23b6c0 (patch)
tree2862ab17d2f88cb7c9614b7fbe579f25ae604b8d /app-misc/pipeworks
parentae1bf373db295b495e1f685d116e3411bf10df0b (diff)
gentoo auto-resync : 01:08:2022 - 03:14:32
Diffstat (limited to 'app-misc/pipeworks')
-rw-r--r--app-misc/pipeworks/Manifest3
-rw-r--r--app-misc/pipeworks/files/pipeworks-0.4-makefile.patch26
-rw-r--r--app-misc/pipeworks/pipeworks-0.4-r2.ebuild (renamed from app-misc/pipeworks/pipeworks-0.4-r1.ebuild)12
3 files changed, 33 insertions, 8 deletions
diff --git a/app-misc/pipeworks/Manifest b/app-misc/pipeworks/Manifest
index 4f8d927872f7..43d2bcd0f4b8 100644
--- a/app-misc/pipeworks/Manifest
+++ b/app-misc/pipeworks/Manifest
@@ -1,3 +1,4 @@
+AUX pipeworks-0.4-makefile.patch 680 BLAKE2B 11460e4d0f1b571382bdc6b70da7283c4647ef0909e3109fe1b5f2c9fcabdde712b0c5f355890ab89bc7f02d969fd9ef33df0f6ef810f8841eec53e4493d5b9f SHA512 43b74343817fb773d1c58d4f7476817c686bd0806ddc068a62337eabe95bd1bd50ccfdbf6b5908e35f6613dbf97a6d5e159092d9870ab30369fb270e0cf99af9
DIST pipeworks-0.4.tar.gz 11560 BLAKE2B ddc28cc26e4f6305eacf6f888cb11a205f1ec64b180a328dda7e250cfef8d98f52374301066ef844739f7f85a4d344307d21d4704c33f450db2740121a631182 SHA512 ddd9875deab26d0f0b673846c7838733a2c3ec573fbd06d85e4058adb3b0d5274daeac1165b573743b8b3da6aa05c24b9ecc0ac788b24a42cf0f379a8eb56ebd
-EBUILD pipeworks-0.4-r1.ebuild 585 BLAKE2B c79b30c4d364983309fc8c4f918c6080972222f6640a34ca4f5fed9f4aea28f8265f817e7473161b7f16aa00064023039f38558586590c70d2525267df48884b SHA512 5b80795cd23c8cefab68a23b3f6728159312e2b28413c6b951fdba8a0f51069a86da5280b8ff8f3550801ee88815b7e0d33a07cb996dfdb0702843ac7eb29ab6
+EBUILD pipeworks-0.4-r2.ebuild 563 BLAKE2B 6a8dfe30092cdbd04e65d4e3fcde09832a2c65817e657e7c9db513d08f874cf81dacd72af8a7063bc91fa862380b708eac1fa8d0f6816964a859530201e33976 SHA512 290eb875228967b2173f35561bd4cabb5a4a05241718722bc2364663bacac54a7549755e8b62d82c3f1b482e0efc2b27405bdc20a7a6480a438ae1dc821dac90
MISC metadata.xml 521 BLAKE2B ea598bd7cb8b9e9bc6ba9da992721a28ef435bbb056666d2cecc169c94f523e07f6d12008d335898ce4a251028b0f946067a8b79c80864777f4295ee9a673500 SHA512 96ef55e452a24baeb824b0b19b025b7397794feb6f7c1330cfb819de33a48c1f6cfbc01cd31bff2bd04c9021bf8467d6e9778d812b0bcd68ca8818ec0f3a5022
diff --git a/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch b/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch
new file mode 100644
index 000000000000..8a52d158b0e4
--- /dev/null
+++ b/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch
@@ -0,0 +1,26 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,21 +18,11 @@
+ # along with pipeworks; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+-CC= gcc -Wall
++CFLAGS += -Wall
+
+ all: pipeworks
+
+-filesize.o: Makefile filesize.h filesize.c
+- $(CC) -c -o filesize.o filesize.c
+-
+-timemanip.o: Makefile timemanip.h timemanip.c
+- $(CC) -c -o timemanip.o timemanip.c
+-
+-pipeworks.o: Makefile pipeworks.c filesize.h
+- $(CC) -c -o pipeworks.o pipeworks.c
+-
+-pipeworks: pipeworks.o filesize.o timemanip.o
+- $(CC) -o pipeworks pipeworks.o filesize.o timemanip.o
++pipeworks: filesize.o timemanip.o
+
+ clean:
+ rm -f *.o *~ pipeworks
diff --git a/app-misc/pipeworks/pipeworks-0.4-r1.ebuild b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
index 28c0a7a154e0..bcef6fb41379 100644
--- a/app-misc/pipeworks/pipeworks-0.4-r1.ebuild
+++ b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -12,13 +12,11 @@ SRC_URI="mirror://sourceforge/pipeworks/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-src_compile() {
- emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+src_configure() {
+ tc-export CC
}
src_install() {