summaryrefslogtreecommitdiff
path: root/app-misc/chkcrontab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-27 01:01:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-27 01:01:27 +0000
commit0b8b325c6d134a9f66de2ba751280e6480e609af (patch)
tree8b5d0bd7281bce9f308fec636204d20a29b4752a /app-misc/chkcrontab
parent82fd88ea93e273f4b02580552f808b6305d1e840 (diff)
gentoo auto-resync : 27:03:2024 - 01:01:27
Diffstat (limited to 'app-misc/chkcrontab')
-rw-r--r--app-misc/chkcrontab/Manifest3
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild33
-rw-r--r--app-misc/chkcrontab/files/chkcrontab-man.patch12
-rw-r--r--app-misc/chkcrontab/files/chkcrontab-py312.patch23
4 files changed, 71 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/Manifest b/app-misc/chkcrontab/Manifest
index d7a6cec070a9..3b4372f55029 100644
--- a/app-misc/chkcrontab/Manifest
+++ b/app-misc/chkcrontab/Manifest
@@ -1,3 +1,6 @@
+AUX chkcrontab-man.patch 288 BLAKE2B 73c04cf73f574927a8b02666ed40b66d3e6898559b3b37c63ea09b0a8d1ea8bf710524f935761c2cb07e5a29f495cffe3c374765dcb8154ab9fe5fd0c350f647 SHA512 4bf02cd64deb226ce19f95890df994b6477d84a53e1e237b5d042d95c2b58636fe6a73f212bb1a7821fbf97a30495719da60d7cf21b9000aab3c6eb8dae0fd26
+AUX chkcrontab-py312.patch 1094 BLAKE2B 207e069317b3d05562ef50bb45cabec3db29c7f32708faf0f3f304cab4c818f811a51b561db6f6060e30bc17e069876d183a74b775be8e7071c4868e3d70bde9 SHA512 cb14d85518c36b200f70dc9a2b0ddf0a4492e976d4be3fc5f2f3344d270fceab6d36fbece2175646b97448b0756c4ea6558512b0d2c5692b09b12adf6a3c3725
DIST chkcrontab-1.7.tar.gz 25088 BLAKE2B 5e3cffcbcd064cfe8e9898dc74c215b14bdd69a4c110a91b73777cb024dd6dfe8d10ce862e82752baad65a8daf88dc45bee06f8e736393e0f973ee2f79f7bd96 SHA512 5236b1996a8d4f5d3861bf3d8a1bafafa271237965721ea4ff61e6712ee4546b9d0484483a0dac25f9d920904f899f2930b46df16d656083b422d95a1d6de0c0
EBUILD chkcrontab-1.7-r2.ebuild 574 BLAKE2B 863ac499329b7b0b37762a5dbd6b31be909198d7fb42c80d6aa440f74a4e9dc4e863af2ba43890278cb1877ccbcb865b64b80d58dec951374cf02ba9390a4db2 SHA512 6ec4a5bc54d54da69c5c49dbd3a7ed8908db0333110b5edbca19024482813c7abda58af924ea3f500c1a11ac372a036f025860c0e9a3c7f2d46d922efe2a0e1c
+EBUILD chkcrontab-1.7-r3.ebuild 741 BLAKE2B ac4e1b2b960ca6520d7c3dbb7764b205f5f2438010f20b62bfdfeb0dce67600da9a040a2c9b97dd1a367e5d9e46f78cf7f8d265b9482ab8d5baa0411eea051db SHA512 0597507a655f11f1a19722679e05b58fb8dcc6350102946be109ed7725f3da103d0605324ae2dd00c7009e07f7b57a8f579e0df747011ae0f2a892a7b97dc5ca
MISC metadata.xml 494 BLAKE2B d64708f16c16bfcdac262a422caced009d236322b8f4536536cc8f82508850ad43d6d9308a4d4a1c473dc55657c88871bd0d610351f0edba33fef046b0b4f470 SHA512 7176af9fe8f23aadc753d8ebd0a95caf8e7ce82a7c6d487300904d00a8b4c5615188e543200a88fa87f24fec7fb1870f73f8843c16f0753fe0b7644dd322a0b5
diff --git a/app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild b/app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild
new file mode 100644
index 000000000000..8c5c3735dc75
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-man.patch"
+ "${FILESDIR}/${PN}-py312.patch"
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i 's/assertEquals/assertEqual/g' tests/test_check.py || die
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}
diff --git a/app-misc/chkcrontab/files/chkcrontab-man.patch b/app-misc/chkcrontab/files/chkcrontab-man.patch
new file mode 100644
index 000000000000..83e4a41e1b48
--- /dev/null
+++ b/app-misc/chkcrontab/files/chkcrontab-man.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index df72a6a..b2082c6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -143,6 +143,7 @@ class InstallCmd(install):
+
+ def run(self):
+ install.run(self)
++ return
+ manpages = ['doc/chkcrontab.1']
+ if self.manprefix:
+ for manpage in manpages:
diff --git a/app-misc/chkcrontab/files/chkcrontab-py312.patch b/app-misc/chkcrontab/files/chkcrontab-py312.patch
new file mode 100644
index 000000000000..b384549b3489
--- /dev/null
+++ b/app-misc/chkcrontab/files/chkcrontab-py312.patch
@@ -0,0 +1,23 @@
+# https://github.com/gregorg/chkcrontab/pull/1
+diff --git a/chkcrontab_lib.py b/chkcrontab_lib.py
+index 57a7c1f..6334a77 100755
+--- a/chkcrontab_lib.py
++++ b/chkcrontab_lib.py
+@@ -822,12 +822,12 @@ def ParseLine(self, line, options ):
+ Returns:
+ A CronLine* class (must have a ValidateAndLog method).
+ """
+- chkcrontab_cmd = re.compile('##*\s*chkcrontab:\s*(.*)=(.*)')
+- assignment_line_re = re.compile('[a-zA-Z_][a-zA-Z0-9_]*\s*=(.*)')
+- at_line_re = re.compile('@(\S+)\s+(\S+)\s+(.*)')
+- cron_time_field_re = '[\*0-9a-zA-Z,/-]+'
++ chkcrontab_cmd = re.compile(r'##*\s*chkcrontab:\s*(.*)=(.*)')
++ assignment_line_re = re.compile(r'[a-zA-Z_][a-zA-Z0-9_]*\s*=(.*)')
++ at_line_re = re.compile(r'@(\S+)\s+(\S+)\s+(.*)')
++ cron_time_field_re = r'[\*0-9a-zA-Z,/-]+'
+ time_field_job_line_re = re.compile(
+- '^\s*(%s)\s+(%s)\s+(%s)\s+(%s)\s+(%s)\s+(\S+)\s+(.*)' %
++ r'^\s*(%s)\s+(%s)\s+(%s)\s+(%s)\s+(%s)\s+(\S+)\s+(.*)' %
+ (cron_time_field_re, cron_time_field_re, cron_time_field_re,
+ cron_time_field_re, cron_time_field_re))
+