summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-27 01:01:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-27 01:01:27 +0000
commit0b8b325c6d134a9f66de2ba751280e6480e609af (patch)
tree8b5d0bd7281bce9f308fec636204d20a29b4752a /app-misc
parent82fd88ea93e273f4b02580552f808b6305d1e840 (diff)
gentoo auto-resync : 27:03:2024 - 01:01:27
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/Manifest.gzbin50780 -> 50779 bytes
-rw-r--r--app-misc/chkcrontab/Manifest3
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild33
-rw-r--r--app-misc/chkcrontab/files/chkcrontab-man.patch12
-rw-r--r--app-misc/chkcrontab/files/chkcrontab-py312.patch23
-rw-r--r--app-misc/tmuxp/Manifest2
-rw-r--r--app-misc/tmuxp/tmuxp-1.45.0.ebuild51
7 files changed, 124 insertions, 0 deletions
diff --git a/app-misc/Manifest.gz b/app-misc/Manifest.gz
index 95df8654a7d7..29af2798a2cb 100644
--- a/app-misc/Manifest.gz
+++ b/app-misc/Manifest.gz
Binary files differ
diff --git a/app-misc/chkcrontab/Manifest b/app-misc/chkcrontab/Manifest
index d7a6cec070a9..3b4372f55029 100644
--- a/app-misc/chkcrontab/Manifest
+++ b/app-misc/chkcrontab/Manifest
@@ -1,3 +1,6 @@
+AUX chkcrontab-man.patch 288 BLAKE2B 73c04cf73f574927a8b02666ed40b66d3e6898559b3b37c63ea09b0a8d1ea8bf710524f935761c2cb07e5a29f495cffe3c374765dcb8154ab9fe5fd0c350f647 SHA512 4bf02cd64deb226ce19f95890df994b6477d84a53e1e237b5d042d95c2b58636fe6a73f212bb1a7821fbf97a30495719da60d7cf21b9000aab3c6eb8dae0fd26
+AUX chkcrontab-py312.patch 1094 BLAKE2B 207e069317b3d05562ef50bb45cabec3db29c7f32708faf0f3f304cab4c818f811a51b561db6f6060e30bc17e069876d183a74b775be8e7071c4868e3d70bde9 SHA512 cb14d85518c36b200f70dc9a2b0ddf0a4492e976d4be3fc5f2f3344d270fceab6d36fbece2175646b97448b0756c4ea6558512b0d2c5692b09b12adf6a3c3725
DIST chkcrontab-1.7.tar.gz 25088 BLAKE2B 5e3cffcbcd064cfe8e9898dc74c215b14bdd69a4c110a91b73777cb024dd6dfe8d10ce862e82752baad65a8daf88dc45bee06f8e736393e0f973ee2f79f7bd96 SHA512 5236b1996a8d4f5d3861bf3d8a1bafafa271237965721ea4ff61e6712ee4546b9d0484483a0dac25f9d920904f899f2930b46df16d656083b422d95a1d6de0c0
EBUILD chkcrontab-1.7-r2.ebuild 574 BLAKE2B 863ac499329b7b0b37762a5dbd6b31be909198d7fb42c80d6aa440f74a4e9dc4e863af2ba43890278cb1877ccbcb865b64b80d58dec951374cf02ba9390a4db2 SHA512 6ec4a5bc54d54da69c5c49dbd3a7ed8908db0333110b5edbca19024482813c7abda58af924ea3f500c1a11ac372a036f025860c0e9a3c7f2d46d922efe2a0e1c
+EBUILD chkcrontab-1.7-r3.ebuild 741 BLAKE2B ac4e1b2b960ca6520d7c3dbb7764b205f5f2438010f20b62bfdfeb0dce67600da9a040a2c9b97dd1a367e5d9e46f78cf7f8d265b9482ab8d5baa0411eea051db SHA512 0597507a655f11f1a19722679e05b58fb8dcc6350102946be109ed7725f3da103d0605324ae2dd00c7009e07f7b57a8f579e0df747011ae0f2a892a7b97dc5ca
MISC metadata.xml 494 BLAKE2B d64708f16c16bfcdac262a422caced009d236322b8f4536536cc8f82508850ad43d6d9308a4d4a1c473dc55657c88871bd0d610351f0edba33fef046b0b4f470 SHA512 7176af9fe8f23aadc753d8ebd0a95caf8e7ce82a7c6d487300904d00a8b4c5615188e543200a88fa87f24fec7fb1870f73f8843c16f0753fe0b7644dd322a0b5
diff --git a/app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild b/app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild
new file mode 100644
index 000000000000..8c5c3735dc75
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-man.patch"
+ "${FILESDIR}/${PN}-py312.patch"
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i 's/assertEquals/assertEqual/g' tests/test_check.py || die
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}
diff --git a/app-misc/chkcrontab/files/chkcrontab-man.patch b/app-misc/chkcrontab/files/chkcrontab-man.patch
new file mode 100644
index 000000000000..83e4a41e1b48
--- /dev/null
+++ b/app-misc/chkcrontab/files/chkcrontab-man.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index df72a6a..b2082c6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -143,6 +143,7 @@ class InstallCmd(install):
+
+ def run(self):
+ install.run(self)
++ return
+ manpages = ['doc/chkcrontab.1']
+ if self.manprefix:
+ for manpage in manpages:
diff --git a/app-misc/chkcrontab/files/chkcrontab-py312.patch b/app-misc/chkcrontab/files/chkcrontab-py312.patch
new file mode 100644
index 000000000000..b384549b3489
--- /dev/null
+++ b/app-misc/chkcrontab/files/chkcrontab-py312.patch
@@ -0,0 +1,23 @@
+# https://github.com/gregorg/chkcrontab/pull/1
+diff --git a/chkcrontab_lib.py b/chkcrontab_lib.py
+index 57a7c1f..6334a77 100755
+--- a/chkcrontab_lib.py
++++ b/chkcrontab_lib.py
+@@ -822,12 +822,12 @@ def ParseLine(self, line, options ):
+ Returns:
+ A CronLine* class (must have a ValidateAndLog method).
+ """
+- chkcrontab_cmd = re.compile('##*\s*chkcrontab:\s*(.*)=(.*)')
+- assignment_line_re = re.compile('[a-zA-Z_][a-zA-Z0-9_]*\s*=(.*)')
+- at_line_re = re.compile('@(\S+)\s+(\S+)\s+(.*)')
+- cron_time_field_re = '[\*0-9a-zA-Z,/-]+'
++ chkcrontab_cmd = re.compile(r'##*\s*chkcrontab:\s*(.*)=(.*)')
++ assignment_line_re = re.compile(r'[a-zA-Z_][a-zA-Z0-9_]*\s*=(.*)')
++ at_line_re = re.compile(r'@(\S+)\s+(\S+)\s+(.*)')
++ cron_time_field_re = r'[\*0-9a-zA-Z,/-]+'
+ time_field_job_line_re = re.compile(
+- '^\s*(%s)\s+(%s)\s+(%s)\s+(%s)\s+(%s)\s+(\S+)\s+(.*)' %
++ r'^\s*(%s)\s+(%s)\s+(%s)\s+(%s)\s+(%s)\s+(\S+)\s+(.*)' %
+ (cron_time_field_re, cron_time_field_re, cron_time_field_re,
+ cron_time_field_re, cron_time_field_re))
+
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 3fd5766eb18f..2ffb64bb72b8 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -4,10 +4,12 @@ DIST tmuxp-1.37.0.tar.gz 869834 BLAKE2B 2e13b609704c726d5da6f614cfa94d3ffef31935
DIST tmuxp-1.38.0.tar.gz 869977 BLAKE2B 6bbb44ceea34af68a7cac0acdf35ee19de74611c9cc53ebbbef61951cca79a5efa14b2eec74b381caf77ac7afe8abd8139453ae4d0f55497cc372bedc9b2fe62 SHA512 d0999bd06498ca458d0cd30709c8d1e4786f98744860e547673cdc917d8e2f8924b1d14681118c594ee767a2e27cafc72f32444158b61ab882a1e2fa7adcbea1
DIST tmuxp-1.40.0.tar.gz 870034 BLAKE2B ab2e6c08ea328e622713e355ff30e9781f2487b9a762ebd7c36195cd8522eee9eab70d66736a1f687e6336f317fdd556d8ee45e9921bd9b1b501189b540e92bb SHA512 6e8564ed2b57122772f1c7b73425b49b6d521141b8e4a3ff6b65d3fb57e6952dfdbb90941242d6d5d8fff70bf7a4533e60ec3dc0abae39637366f035aa237984
DIST tmuxp-1.43.0.tar.gz 869217 BLAKE2B ebaa230723288a37334ee55c9b615610d66aacc5b01d6bf70576de38e9aa1ecc29a7d26299b55880e9ede403855304de080ddec6a16798a269d6bb8d4629498c SHA512 2dec0c941e919258fd884374fe89cf8e558483a50d53a4c6e3148f7639057aa365a959c062ea6929301dcd893b8a6794c002102f030d77fb904eeaa31ec30edd
+DIST tmuxp-1.45.0.tar.gz 869918 BLAKE2B e0f402ec8add4119e3d49b774e0dca0879a54f2f7d3b492979d7e46652ae07bba005c0a5d4784049d8a6c91c83ebf0346aac959ef730f35c63b8fba12459f680 SHA512 426d58c24330f184205a3f6ecbfc0e6871b8372ed882847272a336283f5e02f3461da0e01b0c47c8800a757486fd15f22b02f7175bdd128d5a7aab11a25080b7
EBUILD tmuxp-1.27.0.ebuild 1001 BLAKE2B 7b59c11b0f24ab2f753672043793f1ce4fd4225f63eaf8f5af93a07b0bd7958a9585de01dc8b865ed7aea03e86be3f56c47bf9ad6f69d4124f4120b838822e8d SHA512 292cfa09fa327721b17146fe969b566a9e548078c18dd66ac4c1ff4e736df1596fe6380a19108f590a3a5dd3331622643915cfe03fc3f7d96e4d58377e9858c7
EBUILD tmuxp-1.36.0.ebuild 1095 BLAKE2B 885337da7a3801e938b1772b0e8fdce56be7a8697a03f091e97085b453b2318b3f3cefb25b02844d6101e228504fc7d38fda2238e83bd2c81bfac7f2ee15f0da SHA512 c31d42f5d8a0961752e4128a453a244f3bb8031856a4dc8d4e43b178a470dab86f2e05895285b17340fd03d29dec1993b7272f14c9e910e0d9d73934bdf7e896
EBUILD tmuxp-1.37.0.ebuild 1095 BLAKE2B 5fe69848f18c992656a5e1dda454244d820868d5dd48276000d2dd685d238ab733530802317c5f8d6aa63c08907d5fc00550f50d6aac52a7e56efb5979d1a2b7 SHA512 d7102e2ff85ccff01ca10a61f8118108bd85d85c5f0cf113431c983acd4e5fb493ef564a165d64f6e32ce6b990cf4acedf5e106c4c0e14b52fb2dbe6737dc8ea
EBUILD tmuxp-1.38.0-r1.ebuild 1237 BLAKE2B b87bd4ebc3ac23078b19afd0b099ca7c1d2b1809e996fea87de16d82809c8b72c9700c2fa3a65bffdfe94149cec3358e43e139af10eb42e1725c4705dec5cc06 SHA512 f23eb36c26ca2a268a8123ba7f2367d4bc9a0b628ab0edd7b7bbf9615b54313a0f4d09cf18d096fa2324f8f10bac2335075d9ac81e127651fc20661191b24569
EBUILD tmuxp-1.40.0.ebuild 1237 BLAKE2B 5777dc12fc87401a0247a2f5592f5d3f23401c30c52b0ff0325ad31cd14c916af08af43f121adf0bc9632629206933ec3820cde01bab6129e3ba7061041ec8a2 SHA512 5bf652a104677f2ab5039bde79352db8f6cd77fea8ddda880d4297efb270358e663f3c9c9611212e29452104abb4d7e874c68bef43ef463da3a4807aa136b39f
EBUILD tmuxp-1.43.0.ebuild 1237 BLAKE2B c9162068808af8d9cc75ea1365f3d8bc681d8d348f3a241dc1a828c3b88786840886a4568d99dcf15a0331521884fb4aa1235b0c75440679c8c287ca6adb6360 SHA512 f87e80a3cefef627519f04896ada9692b8de07e36d517229386af0ccb53ca1ffbdf97a0010a919b90d2fee6b80391ee15e3270e32b530e1e81ff374dc63511f7
+EBUILD tmuxp-1.45.0.ebuild 1292 BLAKE2B 2fd546ec3f6eb7810a112996161aab1e6f6cf1a66bf7539cc263c7838b73eeb447eea6e65249ff7cd2c7ac1318df81c0b8dea8f225e2d5b350882f9f56dfeedb SHA512 6fdaadba8eb7ca3cb73e184a7ac392eb5f155bfa611be10172e3995228ce894014c602aa883240b8f56f49bfed92813b0514ab17c28cf91879bee7e284f63abb
MISC metadata.xml 342 BLAKE2B 6f33d048b63facba621c206b518ee9dd2eab4d42d5279d55a42b79555356253a28e337c0e67f16a5f8488bb1848e2808889e3c282c346fb139503f250a897f77 SHA512 f3428680ad98ec20e8fa6131e0935f8ed43d4ddfab8944bb65f66bdba1864dd173f6c99a32d316526d4e40527e04ffc106ba57d261b3ab0dc459e2c9e3e8f5a4
diff --git a/app-misc/tmuxp/tmuxp-1.45.0.ebuild b/app-misc/tmuxp/tmuxp-1.45.0.ebuild
new file mode 100644
index 000000000000..b77d79f89706
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.45.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.36*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6.2.5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.14.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]' 3.{9..10})
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r -e 's:libtmux = "~[0-9.]+":libtmux = "~0.30":' \
+ -i pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}