summaryrefslogtreecommitdiff
path: root/app-i18n/libchewing/libchewing-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/libchewing/libchewing-0.5.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/libchewing/libchewing-0.5.1.ebuild')
-rw-r--r--app-i18n/libchewing/libchewing-0.5.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/libchewing/libchewing-0.5.1.ebuild b/app-i18n/libchewing/libchewing-0.5.1.ebuild
new file mode 100644
index 000000000000..1d3529dc744e
--- /dev/null
+++ b/app-i18n/libchewing/libchewing-0.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/chewing/libchewing"
+fi
+
+DESCRIPTION="Intelligent phonetic (Zhuyin/Bopomofo) input method library"
+HOMEPAGE="http://chewing.im/ https://github.com/chewing/libchewing"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/chewing/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
+IUSE="static-libs test"
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ test? ( sys-libs/ncurses[unicode] )"
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ # libchewing.a is required for building of tests.
+ econf \
+ --with-sqlite3 \
+ $(if use static-libs || use test; then echo --enable-static; else echo --disable-static; fi)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+ use static-libs || find "${D}" -name "*.a" -delete || die
+}