summaryrefslogtreecommitdiff
path: root/app-i18n/libchewing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/libchewing
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/libchewing')
-rw-r--r--app-i18n/libchewing/Manifest4
-rw-r--r--app-i18n/libchewing/libchewing-0.5.1.ebuild52
-rw-r--r--app-i18n/libchewing/libchewing-9999.ebuild52
-rw-r--r--app-i18n/libchewing/metadata.xml11
4 files changed, 119 insertions, 0 deletions
diff --git a/app-i18n/libchewing/Manifest b/app-i18n/libchewing/Manifest
new file mode 100644
index 000000000000..4e2d2eff234b
--- /dev/null
+++ b/app-i18n/libchewing/Manifest
@@ -0,0 +1,4 @@
+DIST libchewing-0.5.1.tar.bz2 3141084 BLAKE2B 28f9e803c8815c0e1b1a1134becffe12f92c1ae24b4b6d4163769d898861fec024db8332befe7130487a72fc20859b6292837e9d68ab1b6477de4cf4f789f2ee SHA512 a6551661bb5e56bba59730b93b373db56af7d42f2ab4881fbfff8727689dd2604d42d2e5c0b04820df66a431dfb5fcb73cc5c9b538615da76198ee3635501c1f
+EBUILD libchewing-0.5.1.ebuild 1133 BLAKE2B 69e6ebe58d26ab7f69e3c76c096af888d1726fb218fb34b12fadfbcdc19d498f3b17c1c34ca4dff2a11db59e4011e62c24cb79c6136a0235b09bfe9c62123a62 SHA512 c34891aecf91306810278c0ad7e21d34da6a1dd93195fc23b23e871f3dfd9791c0da317fac2c96d2ea63898c1e82e94fe7837a75b7eede5923f4be3b563e52e8
+EBUILD libchewing-9999.ebuild 1102 BLAKE2B 20874411d7bbae1684458fc28a83af4b20620409612c5401982e28c070761da991000f5a144f8a71e8967d6afabc788da0b1eae8803d2033785e5559b394410f SHA512 a6b0d950c98c5635e87557f3b7a59b38363345111ade7679f2f8d289c61fe15accc7e771e911a205dfe4934b1ca63839ef45c7b55a839e0f738df0c8130388ab
+MISC metadata.xml 327 BLAKE2B 3f9b234590aef775dc0ae62f4eef42cc1e363e04c3dabc2464eee9cfb44ec0b1fc4fe9b233f781c15784b3a699537d67e884ee7f1648a62b3a863480a5e831cd SHA512 c9ab28ab34d940a30e97b989fd96904d2e0816e4b1bc5b843b082d64d6cd476335d9402640e71f2cf8f57f44dcae9af66d5e07075b189fa74f21faba40d819e3
diff --git a/app-i18n/libchewing/libchewing-0.5.1.ebuild b/app-i18n/libchewing/libchewing-0.5.1.ebuild
new file mode 100644
index 000000000000..1d3529dc744e
--- /dev/null
+++ b/app-i18n/libchewing/libchewing-0.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/chewing/libchewing"
+fi
+
+DESCRIPTION="Intelligent phonetic (Zhuyin/Bopomofo) input method library"
+HOMEPAGE="http://chewing.im/ https://github.com/chewing/libchewing"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/chewing/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
+IUSE="static-libs test"
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ test? ( sys-libs/ncurses[unicode] )"
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ # libchewing.a is required for building of tests.
+ econf \
+ --with-sqlite3 \
+ $(if use static-libs || use test; then echo --enable-static; else echo --disable-static; fi)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+ use static-libs || find "${D}" -name "*.a" -delete || die
+}
diff --git a/app-i18n/libchewing/libchewing-9999.ebuild b/app-i18n/libchewing/libchewing-9999.ebuild
new file mode 100644
index 000000000000..3dbd6c51e6fe
--- /dev/null
+++ b/app-i18n/libchewing/libchewing-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/chewing/libchewing"
+fi
+
+DESCRIPTION="Intelligent phonetic (Zhuyin/Bopomofo) input method library"
+HOMEPAGE="http://chewing.im/ https://github.com/chewing/libchewing"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/chewing/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/3"
+KEYWORDS=""
+IUSE="static-libs test"
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ test? ( sys-libs/ncurses[unicode] )"
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ # libchewing.a is required for building of tests.
+ econf \
+ --with-sqlite3 \
+ $(if use static-libs || use test; then echo --enable-static; else echo --disable-static; fi)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+ use static-libs || find "${D}" -name "*.a" -delete || die
+}
diff --git a/app-i18n/libchewing/metadata.xml b/app-i18n/libchewing/metadata.xml
new file mode 100644
index 000000000000..baa53a1242c5
--- /dev/null
+++ b/app-i18n/libchewing/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">chewing/libchewing</remote-id>
+ </upstream>
+</pkgmetadata>