summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild')
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild
new file mode 100644
index 000000000000..f7913c7825a9
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-unikey.git"
+fi
+
+DESCRIPTION="Vietnamese Unikey input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-unikey"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE="+macro-editor"
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ virtual/libintl
+ macro-editor? (
+ >=app-i18n/fcitx-qt5-1.1:4
+ >=dev-qt/qtcore-5.7:5
+ >=dev-qt/qtgui-5.7:5
+ >=dev-qt/qtwidgets-5.7:5
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT=$(usex macro-editor)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}