summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-unikey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-unikey
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-unikey')
-rw-r--r--app-i18n/fcitx-unikey/Manifest4
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild55
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild55
-rw-r--r--app-i18n/fcitx-unikey/metadata.xml18
4 files changed, 132 insertions, 0 deletions
diff --git a/app-i18n/fcitx-unikey/Manifest b/app-i18n/fcitx-unikey/Manifest
new file mode 100644
index 000000000000..ff137c4ec1d8
--- /dev/null
+++ b/app-i18n/fcitx-unikey/Manifest
@@ -0,0 +1,4 @@
+DIST fcitx-unikey-0.2.7.tar.xz 75204 BLAKE2B a0d70747a560b2493a3b7f7e06ff35f7e465bb4c4c8d22cb4db02f70a6298c49780fd0045874faeba1f20ad188a01a81fefc67a4f6ac9d6946d959f731a376a4 SHA512 1bb78e4f27f0cda1e3aa5a633be45e0a26d121d5b472b1325b0c028ff65ca156d23e7ffee0367badeac1dd21ba1743ee8a2c9c27c629ae0996e84e0062b67ad2
+EBUILD fcitx-unikey-0.2.7.ebuild 1049 BLAKE2B 24b568cee0b18cc4d9ad97a650ef5e552a5f6dd4af31d2dbe72f5457dd77108436b02a6b6e9b74b7806e1b1be09be9b33e7b55118c399d3a4880d06aa056ace6 SHA512 af52165f01a63702a40cfeca059c5068af5669b844c92138baf21c945f8bc9cdf2ed128b3ebe1a755c935f114b282c6509733eee313d76d8e453fb2aaa336bf6
+EBUILD fcitx-unikey-4.9999.ebuild 1030 BLAKE2B a3db834d78b8b53efc64a8279ac3977e94bf4e7d512768effc0ce30379cfbd225936d79a7514d35feba68b82a5a5a5d98fc580da73127a25d4b0fd92fe3dc30a SHA512 14ab05070cc7efa9ffc65ee0946d40258b0e1dcc12a023f37424a156221ad059a01255b1ad4d447f5794e4925110ba58a34a02ac2a5003f2b431e1261896d0e1
+MISC metadata.xml 522 BLAKE2B 09311ebf711ad2116d9c2554f848f6543271a7b03e55087a9370869d4623657c7ecb97aa3e70464be8117ea187923d79ee9b776251151e342047f05b8a117563 SHA512 f8ce2b6e53593d05676e34ea4cfa9451fb6f026c5fced25b3787e9f828518ca784dd8d2b00ea09793976bd7596a9af075e3af57828b286ac484dbfc2c95adf8c
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild
new file mode 100644
index 000000000000..df756e31e6e0
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-unikey.git"
+fi
+
+DESCRIPTION="Vietnamese Unikey input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-unikey"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="+macro-editor"
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ virtual/libintl
+ macro-editor? (
+ >=app-i18n/fcitx-qt5-1.1:4
+ >=dev-qt/qtcore-5.7:5
+ >=dev-qt/qtgui-5.7:5
+ >=dev-qt/qtwidgets-5.7:5
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT=$(usex macro-editor)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild
new file mode 100644
index 000000000000..f7913c7825a9
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-unikey.git"
+fi
+
+DESCRIPTION="Vietnamese Unikey input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-unikey"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE="+macro-editor"
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ virtual/libintl
+ macro-editor? (
+ >=app-i18n/fcitx-qt5-1.1:4
+ >=dev-qt/qtcore-5.7:5
+ >=dev-qt/qtgui-5.7:5
+ >=dev-qt/qtwidgets-5.7:5
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT=$(usex macro-editor)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-unikey/metadata.xml b/app-i18n/fcitx-unikey/metadata.xml
new file mode 100644
index 000000000000..92ad94a4b881
--- /dev/null
+++ b/app-i18n/fcitx-unikey/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <use>
+ <flag name="macro-editor">Install macro editor</flag>
+ </use>
+ <upstream>
+ <remote-id type="gitlab">fcitx/fcitx-unikey</remote-id>
+ </upstream>
+</pkgmetadata>