summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-lua
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-25 13:34:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-25 13:34:50 +0000
commit479921825a5c44a5fbcd5441f00ee98e54db9bac (patch)
treea40800c43ce47a1158369633f7d432b2bd365743 /app-i18n/fcitx-lua
parentfa5cba104ab90ce81be0cb7e9992447a10e76013 (diff)
gentoo auto-resync : 25:12:2023 - 13:34:50
Diffstat (limited to 'app-i18n/fcitx-lua')
-rw-r--r--app-i18n/fcitx-lua/Manifest3
-rw-r--r--app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild46
-rw-r--r--app-i18n/fcitx-lua/metadata.xml31
3 files changed, 80 insertions, 0 deletions
diff --git a/app-i18n/fcitx-lua/Manifest b/app-i18n/fcitx-lua/Manifest
new file mode 100644
index 000000000000..22e16ad6f0f0
--- /dev/null
+++ b/app-i18n/fcitx-lua/Manifest
@@ -0,0 +1,3 @@
+DIST fcitx-lua-5.0.11.tar.xz 34320 BLAKE2B 9140e96362d8a294149028946c3072c195145ccdf4f350d438904305dcca3fb4b3c70f205bd2ff83f700ae8822b2bd99efc5ec77009f5636c72d7ea10d6d15f4 SHA512 c69391efb910cc476608022d15d6e06323bef6cf50c9c63297827969a796b153ad82c7953c3a8fc4432bb887323aa15456d4a8fc246814e165efa54307fa7efe
+EBUILD fcitx-lua-5.0.11.ebuild 843 BLAKE2B 76dce6a989ef38ee79b56e729b723b8c54436f986c61c2a32f35e58653f0166d9f692930284697687cebefdbb119ba88251f412323611e67a0c9891381142166 SHA512 40b56c98f1b2e02c62024f096114bb022a7c5717a35d05d7c2b9763fea459594465904230980ae974545dffe9920a8a0eea3b3690c0ea369f1602272e0d711aa
+MISC metadata.xml 1018 BLAKE2B 64a202bdb4addde0999963a134ae283b62945b4448b7942994c6aa6809f5506220461d697398cd5562123a5aa902f56f83f0ad2c65e708e9daa969475fc37387 SHA512 35777f31006124a5970656be244de8bd1134d0f7cfc24ae5a7ee576e9d2841af36a5a2bd239d36ef9a3accb19a75c20710f720151c23f2b3f08d98de6ce27ce0
diff --git a/app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild b/app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild
new file mode 100644
index 000000000000..4dc09a6886b7
--- /dev/null
+++ b/app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{3,4} )
+
+MY_PN="fcitx5-lua"
+
+inherit cmake lua-single xdg
+
+DESCRIPTION="Lua support for fcitx"
+HOMEPAGE="https://github.com/fcitx/fcitx5-lua"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dlopen test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${LUA_DEPS}
+ app-i18n/fcitx:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ lua-single_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DLOPEN=$(usex dlopen)
+ -DENABLE_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/app-i18n/fcitx-lua/metadata.xml b/app-i18n/fcitx-lua/metadata.xml
new file mode 100644
index 000000000000..152073f668d9
--- /dev/null
+++ b/app-i18n/fcitx-lua/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fcitx/fcitx5-lua</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Lua support for fcitx.
+ It tries to support lua in fcitx in two ways.
+ 1. An addon loader for lua, which supports Type=Lua addon.
+ 2. The googlepinyin api, which is provided by imeapi addon.
+ You may put your lua file under
+ $HOME/.local/share/fcitx5/lua/imeapi/extensions
+ to make the addon find your scripts.
+ </longdescription>
+ <use>
+ <flag name="dlopen">Use dlopen to load lua library</flag>
+ </use>
+</pkgmetadata>