summaryrefslogtreecommitdiff
path: root/app-i18n
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-25 13:34:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-25 13:34:50 +0000
commit479921825a5c44a5fbcd5441f00ee98e54db9bac (patch)
treea40800c43ce47a1158369633f7d432b2bd365743 /app-i18n
parentfa5cba104ab90ce81be0cb7e9992447a10e76013 (diff)
gentoo auto-resync : 25:12:2023 - 13:34:50
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/Manifest.gzbin17683 -> 18358 bytes
-rw-r--r--app-i18n/fcitx-chinese-addons/Manifest3
-rw-r--r--app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.2.ebuild57
-rw-r--r--app-i18n/fcitx-chinese-addons/metadata.xml26
-rw-r--r--app-i18n/fcitx-lua/Manifest3
-rw-r--r--app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild46
-rw-r--r--app-i18n/fcitx-lua/metadata.xml31
-rw-r--r--app-i18n/fcitx-table-extra/Manifest4
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.0.ebuild28
-rw-r--r--app-i18n/fcitx-table-extra/metadata.xml9
-rw-r--r--app-i18n/fcitx-table-other/Manifest3
-rw-r--r--app-i18n/fcitx-table-other/fcitx-table-other-5.1.0.ebuild28
-rw-r--r--app-i18n/fcitx-table-other/metadata.xml19
-rw-r--r--app-i18n/libime/Manifest5
-rw-r--r--app-i18n/libime/files/libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch79
-rw-r--r--app-i18n/libime/files/libime-1.1.3-use-c++11-for-kenlm.patch17
-rw-r--r--app-i18n/libime/libime-1.1.3.ebuild54
-rw-r--r--app-i18n/libime/metadata.xml19
18 files changed, 430 insertions, 1 deletions
diff --git a/app-i18n/Manifest.gz b/app-i18n/Manifest.gz
index 9250eaab7fcb..52ac8ec7693a 100644
--- a/app-i18n/Manifest.gz
+++ b/app-i18n/Manifest.gz
Binary files differ
diff --git a/app-i18n/fcitx-chinese-addons/Manifest b/app-i18n/fcitx-chinese-addons/Manifest
new file mode 100644
index 000000000000..06bf2fd85bc3
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/Manifest
@@ -0,0 +1,3 @@
+DIST fcitx5-chinese-addons-5.1.2_dict.tar.xz 883388 BLAKE2B 7db9fcd8b9fddce9db5b0cf23e5300d7a246183184c32d8292a92617f5b66bebd81a5876cb197508676266c39fbeae5a17fd659feadab0a41be1df948c9663fe SHA512 8a94b974b461dc0a20ee7c243d482295359be27a7cc2152755aebdde3330a62f579506666e231d15cd081e58794359f1791b674f8d9f873babf7c68f4dea81a1
+EBUILD fcitx-chinese-addons-5.1.2.ebuild 1274 BLAKE2B 2af102a3c19e1ff746c670c9b78f3bf380b721d5b0ec3c78f558d9f26e28658c0caa21bd747c6a2a781a853cf7e0057be750fb4f76990179c3a4d47c7338ecd7 SHA512 e66eb96dfb93b678d1af3f22ee5524711af1f3eb3bbbbd5a3eb5aaf12aa903266b06d41c8fbd8f18be527ed1d99d4485b6e2390e4cda0364b0ceb53a8a70456d
+MISC metadata.xml 955 BLAKE2B e89dc69c9d5eab99bd43448dae497433a7d2a56d7d2787e339329a851ff37f68cda6e9333f1f847d4bbabdb5fed398acdba995de536665ba8b2a49081e4f01e8 SHA512 34ee4cac10ea6ca79bd77cf7c56599902259f38be4e296c58e785d688c5860035763f68548044b3a37dc5e06078384bb27b52e5a255d8d9209bb82905f010179
diff --git a/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.2.ebuild b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.2.ebuild
new file mode 100644
index 000000000000..64a5b3a5b44e
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chinese-addons"
+
+inherit cmake xdg
+
+DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}_dict.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="5"
+IUSE="+gui webengine +cloudpinyin +qt5 lua +opencc test"
+REQUIRED_USE="
+ gui? ( qt5 )
+ webengine? ( gui )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.5:5
+ >=app-i18n/libime-1.1.3:5
+ >=dev-libs/boost-1.61:=
+ cloudpinyin? ( net-misc/curl )
+ lua? ( app-i18n/fcitx-lua:5 )
+ opencc? ( app-i18n/opencc:= )
+ gui? (
+ qt5? (
+ dev-qt/qtconcurrent:5
+ app-i18n/fcitx-qt:5[qt5,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BROWSER=$(usex webengine)
+ -DENABLE_CLOUDPINYIN=$(usex cloudpinyin)
+ -DENABLE_GUI=$(usex gui)
+ -DENABLE_OPENCC=$(usex opencc)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_WEBKIT=no
+ )
+ cmake_src_configure
+}
diff --git a/app-i18n/fcitx-chinese-addons/metadata.xml b/app-i18n/fcitx-chinese-addons/metadata.xml
new file mode 100644
index 000000000000..c73b7e1cf220
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <use>
+ <flag name="cloudpinyin">Build cloud pinyin addon</flag>
+ <flag name="gui">Enable GUI support (qt5 or qt6)</flag>
+ <flag name="opencc">Enable support for conversion between Traditional and Simplified Chinese</flag>
+ <flag name="qt5">Enable configure qt5</flag>
+ <flag name="webengine">Enable built-in browser using <pkg>dev-qt/qtwebengine</pkg></flag>
+ </use>
+<upstream>
+<remote-id type="github">fcitx/fcitx5-chinese-addons</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-i18n/fcitx-lua/Manifest b/app-i18n/fcitx-lua/Manifest
new file mode 100644
index 000000000000..22e16ad6f0f0
--- /dev/null
+++ b/app-i18n/fcitx-lua/Manifest
@@ -0,0 +1,3 @@
+DIST fcitx-lua-5.0.11.tar.xz 34320 BLAKE2B 9140e96362d8a294149028946c3072c195145ccdf4f350d438904305dcca3fb4b3c70f205bd2ff83f700ae8822b2bd99efc5ec77009f5636c72d7ea10d6d15f4 SHA512 c69391efb910cc476608022d15d6e06323bef6cf50c9c63297827969a796b153ad82c7953c3a8fc4432bb887323aa15456d4a8fc246814e165efa54307fa7efe
+EBUILD fcitx-lua-5.0.11.ebuild 843 BLAKE2B 76dce6a989ef38ee79b56e729b723b8c54436f986c61c2a32f35e58653f0166d9f692930284697687cebefdbb119ba88251f412323611e67a0c9891381142166 SHA512 40b56c98f1b2e02c62024f096114bb022a7c5717a35d05d7c2b9763fea459594465904230980ae974545dffe9920a8a0eea3b3690c0ea369f1602272e0d711aa
+MISC metadata.xml 1018 BLAKE2B 64a202bdb4addde0999963a134ae283b62945b4448b7942994c6aa6809f5506220461d697398cd5562123a5aa902f56f83f0ad2c65e708e9daa969475fc37387 SHA512 35777f31006124a5970656be244de8bd1134d0f7cfc24ae5a7ee576e9d2841af36a5a2bd239d36ef9a3accb19a75c20710f720151c23f2b3f08d98de6ce27ce0
diff --git a/app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild b/app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild
new file mode 100644
index 000000000000..4dc09a6886b7
--- /dev/null
+++ b/app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{3,4} )
+
+MY_PN="fcitx5-lua"
+
+inherit cmake lua-single xdg
+
+DESCRIPTION="Lua support for fcitx"
+HOMEPAGE="https://github.com/fcitx/fcitx5-lua"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dlopen test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${LUA_DEPS}
+ app-i18n/fcitx:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ lua-single_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DLOPEN=$(usex dlopen)
+ -DENABLE_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/app-i18n/fcitx-lua/metadata.xml b/app-i18n/fcitx-lua/metadata.xml
new file mode 100644
index 000000000000..152073f668d9
--- /dev/null
+++ b/app-i18n/fcitx-lua/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fcitx/fcitx5-lua</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Lua support for fcitx.
+ It tries to support lua in fcitx in two ways.
+ 1. An addon loader for lua, which supports Type=Lua addon.
+ 2. The googlepinyin api, which is provided by imeapi addon.
+ You may put your lua file under
+ $HOME/.local/share/fcitx5/lua/imeapi/extensions
+ to make the addon find your scripts.
+ </longdescription>
+ <use>
+ <flag name="dlopen">Use dlopen to load lua library</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-i18n/fcitx-table-extra/Manifest b/app-i18n/fcitx-table-extra/Manifest
index 63ff15d6d423..49e38e166cdc 100644
--- a/app-i18n/fcitx-table-extra/Manifest
+++ b/app-i18n/fcitx-table-extra/Manifest
@@ -1,4 +1,6 @@
DIST fcitx-table-extra-0.3.8.tar.xz 3700736 BLAKE2B b8ce4b3aa04eba8b594b86958bb83e348758c30688828a4834643cf7bdd62852c2ca89bc4f75f0cb1b16ce969b0454c58e3abadff9c78318dc0953e0905c75fa SHA512 454798e9bd25c630ce98e2daf7296e82ba5fbc98027171038a5a7b9ac3169c153302a6703d9416718ec3a0b76db6d732caf3f03c6e6005841c9d7798702542df
+DIST fcitx-table-extra-5.1.0.tar.xz 7278796 BLAKE2B 150d9235de9c8786dce598b8c0b41216e1a793a69136c264623820042784bdd1d222e4dbe026010326a5d3db59d22c19afa3b29d233bc58ecf1796c4c049d709 SHA512 8f092b4e2cf568861fe29c08f08acac9685d2a07c95d2de228aad8353139e5c48a11fe3e50d5e83815b439dce8c0a757199a5a54fa86bc61630dd302feca7509
EBUILD fcitx-table-extra-0.3.8.ebuild 799 BLAKE2B 6fc1349116575e7e3d321cecc4ddc79291fb21f6c029ed79dd37fb82f4ae43be065c1c8497400276bc6b8dded972d35c96533271a9cf8d774115d247e3be2ac8 SHA512 42fbd0c40568c75a9e0f765b1dc1a5667c5878b5d1d9abdbcb445ca134a40d3f2f2e97b652ca8115e19f59243ddb7283074b975034de1b28f201c53ef8cfbf3a
EBUILD fcitx-table-extra-4.9999.ebuild 773 BLAKE2B 1debb5da1822ed6e17c62a3a37f2f80e079166b9434cd2f9840f8d0a9f747affbd556040bf7088951fd1a5851e7dbacc62d4f98c3d9961a7f28488b41d65d5c6 SHA512 fd3b5d55e45e0712211cf7ebb8808fde09ba373d7f3ae13a9c43b871fb5287133fc4bb26429f2916d0ca1883406a49003f7b3b400d1e2c2a85dccc281034ac26
-MISC metadata.xml 471 BLAKE2B 9d488d42b2d848a4bd3ed3ce1f7bcf83a52881006c2c70f61fddd93edb9295a86a77491b7cc68348034170da87f0e210a13f4119e28b701669e9dc9a55603a36 SHA512 6ae0dc202a27e5f23c17a4c06c7e31732bca86ed1f122f9506b37ece4832a6ded865a2b091eb5834b10bde00d60de864412519bc954ac414607e39d9fa63ec77
+EBUILD fcitx-table-extra-5.1.0.ebuild 612 BLAKE2B bed328f159886c1a98f8240fc256c3cd303e127b8a9b7ea40c2a717f80afe0444d5ae966ef40b29c21b570ce28fbeaad60a96bc2289fb31ab6489ef1bdb4209d SHA512 8ae735f2ffadc323c2ae6e409709cc6c00b41ab27dbd4e9b923f2aea2b99259967410356f7e44f3d265b304d008971b9cd1fd10ae98dd3f3b34c5c159ec26d74
+MISC metadata.xml 794 BLAKE2B fbfb8bd1017ea97c3b91ad0c4c026a4bd69be61335c0d7a0848171b0747846a54c20db9c074db0ffd57d83b38950813224bba60f4a5c9c06ebbba5537af988e1 SHA512 f9ba53ade10f716760b7a751fdd2388b40dd9abc7336c280d31b20e52f114f4a5b23e8d29d616caaa6ec677d15fca1213756d8066a1838b85884b521fa46d59d
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.0.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.0.ebuild
new file mode 100644
index 000000000000..317b31e134bb
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=fcitx5-table-extra
+
+inherit cmake xdg
+
+DESCRIPTION="Provides extra table for Fcitx, including Boshiamy, Zhengma, Cangjie, and Quick"
+HOMEPAGE="https://github.com/fcitx/fcitx5-table-extra"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-i18n/fcitx:5
+ app-i18n/libime
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
diff --git a/app-i18n/fcitx-table-extra/metadata.xml b/app-i18n/fcitx-table-extra/metadata.xml
index aab09de33596..161da38c5b8d 100644
--- a/app-i18n/fcitx-table-extra/metadata.xml
+++ b/app-i18n/fcitx-table-extra/metadata.xml
@@ -2,14 +2,23 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
<email>arfrever.fta@gmail.com</email>
<name>Arfrever Frehtes Taifersar Arahesis</name>
</maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<maintainer type="project">
<email>cjk@gentoo.org</email>
<name>Cjk</name>
</maintainer>
<upstream>
<remote-id type="github">fcitx/fcitx-table-extra</remote-id>
+ <remote-id type="github">fcitx/fcitx5-table-extra</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-i18n/fcitx-table-other/Manifest b/app-i18n/fcitx-table-other/Manifest
new file mode 100644
index 000000000000..6e48af6768e8
--- /dev/null
+++ b/app-i18n/fcitx-table-other/Manifest
@@ -0,0 +1,3 @@
+DIST fcitx-table-other-5.1.0.tar.xz 285864 BLAKE2B 22ccfe519d497fb12c929404632b4e683e0471f8e5183492e9e1607b7a09042c30fc4515d323c0a0d33bfa683ed93b59af988622bc83148fc89e825605626612 SHA512 91b1b38edad9eef862f0bd72423cd2caf343688563190b8b67a24d468d6a1b367847c5e87cc3f440ab5a41a03575721206f86a75b7568b3453e975d4457bf03b
+EBUILD fcitx-table-other-5.1.0.ebuild 610 BLAKE2B b75caccda54804ca7d9e24e28eb593a0540a2fac9f3f0eaf3b0cbc27049ff139a22b1914bc7243cab131eecafda284dea6ccb766fa21389ce5d8a1628bdbce38 SHA512 43fce805577b3e5e2deb4e8aaf5726f0ca3a6ab08f2834de5e84e405e1394a716930b9156de93c32063368c2c58064ef9444322600dc552b4324ad6e781c6bdd
+MISC metadata.xml 583 BLAKE2B 9e27f3a3ffa0da1affef2ccabd3535f69a10a13b1a79f1eec74005ae1b97b8b3b89be1a90117ff00b7d6e903acc6a6e8b1d1c10f5fc1b7e7274edf6bd40d80e0 SHA512 2705b85869a5827543d897de9861ce7630ffe67d6e9d51e2b571924aa39d05efe3f8b4296fe80fcbe427783bec673427c0e96ad87bb8535ecdbc7f1f8b100bfe
diff --git a/app-i18n/fcitx-table-other/fcitx-table-other-5.1.0.ebuild b/app-i18n/fcitx-table-other/fcitx-table-other-5.1.0.ebuild
new file mode 100644
index 000000000000..10200ecb1ff2
--- /dev/null
+++ b/app-i18n/fcitx-table-other/fcitx-table-other-5.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=fcitx5-table-other
+
+inherit cmake xdg
+
+DESCRIPTION="Provides some other tables for Fcitx, fork from ibus-table-others, scim-tables"
+HOMEPAGE="https://github.com/fcitx/fcitx5-table-other"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-i18n/fcitx:5
+ app-i18n/libime
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
diff --git a/app-i18n/fcitx-table-other/metadata.xml b/app-i18n/fcitx-table-other/metadata.xml
new file mode 100644
index 000000000000..f31494e90ff6
--- /dev/null
+++ b/app-i18n/fcitx-table-other/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fcitx/fcitx5-table-other</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-i18n/libime/Manifest b/app-i18n/libime/Manifest
new file mode 100644
index 000000000000..60ddd2dfa909
--- /dev/null
+++ b/app-i18n/libime/Manifest
@@ -0,0 +1,5 @@
+AUX libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch 2635 BLAKE2B d4c4390d030f4120d763d0a57e276609eafb7413048ce345dbb3f48f3eb84fc7407fcb23355bdbbd41891c480432d9d37d97bc8c99344843bdcaae95aebec4e7 SHA512 c1a04fc3dced63e00fbbbd0aafb5986cdebf175ca0a444f47208ee47fd72e166e96b11627b42adf9f12365ccf19f51c23098e05061fbd77da0a3014f7180ad4c
+AUX libime-1.1.3-use-c++11-for-kenlm.patch 800 BLAKE2B b2287dbc983c824fd4e3ba5f63faa2a0b2cd816f659832006c8a434200be46e329a411d37736fbba364c5954e49a97240151e66314aab13ccf0fd86514e5241d SHA512 ac9c1a847340437dafe994ccaa55f0d07f5fca276b4bdaab894ea21a8938c76208a94f27e06badb217965f80ad1f50a193c7d802dc287777c11002ceab9270da
+DIST libime-1.1.3_dict.tar.xz 36438528 BLAKE2B 2577362aeddf398b9ee7d29c71d157f7aef67b30d2463719ed020eaaa98e955c83b8a7df1e90e4519ae13d2146eff440dafdb93d723a2feaeb60f96e70633410 SHA512 5079721651df334292fbcc6275ded55d41c6380183ef5487be558e93b551a6a6d651fb0fa0456c1d40ffdae432bf51375058fdcf631ea8a93c8751530642fc92
+EBUILD libime-1.1.3.ebuild 992 BLAKE2B 5db2d923afe0153d3e3467f279e97c7b93d839ae3f21a4f4ddd006f4f96bd232f70377c161cc5b6a33c15aa77ae314e573f588e7ef0dba28a4fbf640c96e27e6 SHA512 bcad67154d8c12b3e7ff624dbad86aaf84c462c937ee97e1f44695cc0493322d81046206d8e40c34ae1dbe191589ba2fa26fdaa39f8ea60aac3d913938b263d2
+MISC metadata.xml 571 BLAKE2B ad0cb13fbb703f903e91d2ed74eb9ff35db255c93439a61f72b37b0ae5a2b070e22c574899d70290a666be1b1299c614fd6bfe00881c9ab9472c6d35a7defed4 SHA512 a31ab522b9c2e5be9b46d8ee3dd8d736f1fa7bf4ec983f4a7eeb35922dc88b74d02979d4ebf6bf81118df46d933f70b2cd73dfb66e92320b208e6ae844db7e38
diff --git a/app-i18n/libime/files/libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch b/app-i18n/libime/files/libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch
new file mode 100644
index 000000000000..73b94a07cff5
--- /dev/null
+++ b/app-i18n/libime/files/libime-1.1.3-fix-the-nanf-value-issue-on-musl.patch
@@ -0,0 +1,79 @@
+Backport of https://github.com/fcitx/libime/commit/59ae4a3ab4becdab164f29af07c502096c745b94.diff
+
+Backport upstream commit 59ae4a3 to fix the nanf value issue on musl
+
+--- a/src/libime/core/datrie.cpp
++++ b/src/libime/core/datrie.cpp
+@@ -47,12 +47,24 @@ struct NanValue {
+ static inline int32_t NO_PATH() { return -2; }
+ };
+
++// Musl doesn't have nanf implementation we need, just check if they are the
++// same value. If not, prefer old hardcoded value.
++bool isGoodNanf() {
++ int32_t noValue = decodeValue(std::nanf("1"));
++ int32_t noPath = decodeValue(std::nanf("2"));
++ return (noValue != noPath);
++}
++
+ template <>
+ struct NanValue<float> {
+ static_assert(std::numeric_limits<float>::has_quiet_NaN,
+ "Require support for quiet NaN.");
+- static inline int32_t NO_VALUE() { return decodeValue(std::nanf("1")); }
+- static inline int32_t NO_PATH() { return decodeValue(std::nanf("2")); }
++ static inline int32_t NO_VALUE() {
++ return isGoodNanf() ? decodeValue(std::nanf("1")) : 0x7fc00001;
++ }
++ static inline int32_t NO_PATH() {
++ return isGoodNanf() ? decodeValue(std::nanf("2")) : 0x7fc00002;
++ }
+ };
+
+ } // namespace
+@@ -1144,6 +1156,20 @@ bool DATrie<T>::isValid(value_type v) {
+ return !(isNoPath(v) || isNoValue(v));
+ }
+
++template <typename T>
++T DATrie<T>::noPath() {
++ typename DATriePrivate<T>::decorder_type d;
++ d.result = DATriePrivate<value_type>::CEDAR_NO_PATH;
++ return d.result_value;
++}
++
++template <typename T>
++T DATrie<T>::noValue() {
++ typename DATriePrivate<T>::decorder_type d;
++ d.result = DATriePrivate<value_type>::CEDAR_NO_VALUE;
++ return d.result_value;
++}
++
+ template <typename T>
+ size_t DATrie<T>::mem_size() const {
+ // std::cout << "tail" << d->m_tail.size() << std::endl
+--- a/src/libime/core/datrie.h
++++ b/src/libime/core/datrie.h
+@@ -136,6 +136,9 @@ class DATrie {
+ static bool isNoPath(value_type v);
+ static bool isNoValue(value_type v);
+
++ static value_type noPath();
++ static value_type noValue();
++
+ size_t mem_size() const;
+
+ private:
+--- a/test/testtrie.cpp
++++ b/test/testtrie.cpp
+@@ -40,8 +40,8 @@ int main() {
+ FCITX_ASSERT(trie.size() == 4);
+ DATrie<float>::position_type pos = 0;
+ auto result = trie.traverse("aaa", pos);
+- auto nan1 = std::nanf("1");
+- auto nan2 = std::nanf("2");
++ auto nan1 = trie.noValue();
++ auto nan2 = trie.noPath();
+ // NaN != NaN, we must use memcmp to do this.
+ FCITX_ASSERT(memcmp(&nan1, &result, sizeof(float)) == 0);
+ FCITX_ASSERT(trie.isNoValue(result));
diff --git a/app-i18n/libime/files/libime-1.1.3-use-c++11-for-kenlm.patch b/app-i18n/libime/files/libime-1.1.3-use-c++11-for-kenlm.patch
new file mode 100644
index 000000000000..15b0024c4668
--- /dev/null
+++ b/app-i18n/libime/files/libime-1.1.3-use-c++11-for-kenlm.patch
@@ -0,0 +1,17 @@
+Backport of https://github.com/fcitx/libime/commit/95c1433500b089b0c2edbdd17720f66e6eafd5e0
+
+Backport upstream commit 95c1433 in order to fix building with libcxx
+
+--- a/src/libime/core/CMakeLists.txt
++++ b/src/libime/core/CMakeLists.txt
+@@ -13,7 +13,9 @@ add_library(kenlm STATIC ${KENLM_SRCS})
+ target_include_directories(kenlm PUBLIC $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/kenlm>)
+ target_compile_definitions(kenlm PUBLIC -DKENLM_MAX_ORDER=3 PRIVATE -DNDEBUG)
+ target_link_libraries(kenlm PUBLIC Boost::boost PkgConfig::ZSTD)
+-set_target_properties(kenlm PROPERTIES POSITION_INDEPENDENT_CODE ON)
++set_target_properties(kenlm PROPERTIES
++ CXX_STANDARD 11
++ POSITION_INDEPENDENT_CODE ON)
+
+ if(UNIX)
+ check_library_exists(rt clock_gettime "clock_gettime from librt" HAVE_CLOCKGETTIME_RT)
diff --git a/app-i18n/libime/libime-1.1.3.ebuild b/app-i18n/libime/libime-1.1.3.ebuild
new file mode 100644
index 000000000000..3d962ae4153e
--- /dev/null
+++ b/app-i18n/libime/libime-1.1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fcitx5 Next generation of fcitx "
+HOMEPAGE="https://fcitx-im.org/"
+SRC_URI="https://download.fcitx-im.org/fcitx5/libime/libime-${PV}_dict.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.5:5
+ app-arch/zstd:=
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-fontutils
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-use-c++11-for-kenlm.patch"
+ "${FILESDIR}/${P}-fix-the-nanf-value-issue-on-musl.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOC=$(usex doc)
+ -DENABLE_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}
diff --git a/app-i18n/libime/metadata.xml b/app-i18n/libime/metadata.xml
new file mode 100644
index 000000000000..63181ec1c708
--- /dev/null
+++ b/app-i18n/libime/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fcitx/libime</remote-id>
+ </upstream>
+</pkgmetadata>