summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild')
-rw-r--r--app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild b/app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild
new file mode 100644
index 000000000000..9c41e81fefd2
--- /dev/null
+++ b/app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manages the {,/usr}/sbin/iptables symlink"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-iptables.git/"
+SRC_URI="https://dev.gentoo.org/~chutzpah/dist/iptables/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins iptables.eselect
+
+ local symlink
+ for symlink in {eb,arp}tables; do
+ dosym iptables.eselect /usr/share/eselect/modules/${symlink}.eselect
+ done
+}