summaryrefslogtreecommitdiff
path: root/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild')
-rw-r--r--app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild b/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild
new file mode 100644
index 000000000000..598b063ec466
--- /dev/null
+++ b/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN/-/_}
+
+DESCRIPTION="A Mozilla Gecko based version of Internet Explorer for Wine"
+HOMEPAGE="https://winehq.org"
+SRC_URI="
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${MY_PN}-${PV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${MY_PN}-${PV}-x86_64.msi )
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="${PV}"
+KEYWORDS="amd64 x86"
+IUSE="abi_x86_32 abi_x86_64"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install(){
+ insinto /usr/share/wine/gecko
+ use abi_x86_32 && doins "${DISTDIR}/${MY_PN}-${PV}-x86.msi"
+ use abi_x86_64 && doins "${DISTDIR}/${MY_PN}-${PV}-x86_64.msi"
+}