summaryrefslogtreecommitdiff
path: root/app-emulation/wine-gecko
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/wine-gecko
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/wine-gecko')
-rw-r--r--app-emulation/wine-gecko/Manifest4
-rw-r--r--app-emulation/wine-gecko/metadata.xml14
-rw-r--r--app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild28
3 files changed, 46 insertions, 0 deletions
diff --git a/app-emulation/wine-gecko/Manifest b/app-emulation/wine-gecko/Manifest
new file mode 100644
index 000000000000..14e12ea4d5a1
--- /dev/null
+++ b/app-emulation/wine-gecko/Manifest
@@ -0,0 +1,4 @@
+DIST wine_gecko-2.47-x86.msi 49266176 BLAKE2B 6b1d4ebf53fac422c2da9ae7f5b6ab9064d2b6cc20d57fe13707395e71305ac1607a440624d3a545fe1e0391bc92bf5b594173549e519eda967bb833b69b2f52 SHA512 e0d06102dcb8ec2d24e8c8c3f5c2ee5cb47c18e203dfb43d85de008d682ff874fb664fef1df909a5a7857de39c7e8ce5175e734a11964ec4cd35f8fbacaea3a4
+DIST wine_gecko-2.47-x86_64.msi 50806272 BLAKE2B 6f91d4661a322eca41042cb7a246d5bff76ab72b4bda67183fc36735c923bd6d76624f21fd3e59f63fd872704edcf0116a6e7ab4fa6f074f5098c8fb5307534c SHA512 7c2496b15a06bc6906bc60afb3ac082e3f9931207fa624e60297020211d66aa9b420a61e95730a0dbdcefbe4b26c811d0c896ecd9c363b5107d08c3fa22fef41
+EBUILD wine-gecko-2.47-r1.ebuild 740 BLAKE2B 006ddc878fff2849d14374543c081dd35efefe0918a560415154d2335cb54d0cf70c8df355aaba64768733a70443e2f6deb65f6d1f65e4345f01a481940307a4 SHA512 27f819db3e17355fc6194c7622dadbbb16cb6ba28a2891efed086f25ad474393248841256d0776e828b22d91791b33686d8f393e4769d4fe516262647f1164bb
+MISC metadata.xml 422 BLAKE2B ba34670321999a9c388e61d8377278b08bc2fcda1412a4e04fcb8ac6a083a2030a4fa602057ce2fd1c01599da4964556ccf94b8e0174c665248f2d26c37a3267 SHA512 b8a26dd6451de2c3a022c586e1b96bab179eb1d04c04b5622ae3911140d50a63ff1fcd94685e3c1db9089136153bc306a854e0a671d27e75cc2be6bdc47eaccf
diff --git a/app-emulation/wine-gecko/metadata.xml b/app-emulation/wine-gecko/metadata.xml
new file mode 100644
index 000000000000..41e683d85cb6
--- /dev/null
+++ b/app-emulation/wine-gecko/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>wine@gentoo.org</email>
+ <name>Wine</name>
+ </maintainer>
+ <longdescription>
+ A Mozilla Gecko based version of Internet Explorer for Wine
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">wine/wine-gecko</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild b/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild
new file mode 100644
index 000000000000..598b063ec466
--- /dev/null
+++ b/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN/-/_}
+
+DESCRIPTION="A Mozilla Gecko based version of Internet Explorer for Wine"
+HOMEPAGE="https://winehq.org"
+SRC_URI="
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${MY_PN}-${PV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${MY_PN}-${PV}-x86_64.msi )
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="${PV}"
+KEYWORDS="amd64 x86"
+IUSE="abi_x86_32 abi_x86_64"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install(){
+ insinto /usr/share/wine/gecko
+ use abi_x86_32 && doins "${DISTDIR}/${MY_PN}-${PV}-x86.msi"
+ use abi_x86_64 && doins "${DISTDIR}/${MY_PN}-${PV}-x86_64.msi"
+}