summaryrefslogtreecommitdiff
path: root/app-emulation/spice-html5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /app-emulation/spice-html5
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'app-emulation/spice-html5')
-rw-r--r--app-emulation/spice-html5/Manifest3
-rw-r--r--app-emulation/spice-html5/metadata.xml15
-rw-r--r--app-emulation/spice-html5/spice-html5-0.2.1.ebuild28
3 files changed, 46 insertions, 0 deletions
diff --git a/app-emulation/spice-html5/Manifest b/app-emulation/spice-html5/Manifest
new file mode 100644
index 000000000000..7d0f2bea7929
--- /dev/null
+++ b/app-emulation/spice-html5/Manifest
@@ -0,0 +1,3 @@
+DIST spice-html5-spice-html5-0.2.1.tar.gz 486871 BLAKE2B 4b44ad772ab5abf13e8d3fe7c651169b340c8978f4163b9b679046efaa554f86d5919d154f16262ea28ddb512ac55ea7b6651ae63f64cf6b69033d8306191dc3 SHA512 c6e17aa465da1a0b882184bb19f2560f43fd3b345fdc00ec71774c7aec37c3453fd87b2448202011e217dda21b602d20dd4d552d49d9a52b64cb91aff092eff7
+EBUILD spice-html5-0.2.1.ebuild 586 BLAKE2B da1af87390524e9c1676c1bbf2d5a43cd97017cb8b89aee9daebcd4dc3066eb36d98589cffa97f3390fe319813df1caf88010069ac6bddd78a2bb6f58fcc7bd1 SHA512 b1f53e33acbf8507fe19cbd6325b9a91ca14103a6fe304e4288db3c9d2ec0fb6a340395cf0309be734a00977bf976fd2beb2a869037c1f66a462c89eba093b20
+MISC metadata.xml 436 BLAKE2B ba9b5d8dd5d477fe7e33fb3559840cbe68c08b2034969d4bccbdcb93e4cb8b0dcced263f5e16fbae47899edb32c034d0271444dd23dbb9b4e6d22cb5c361aa0c SHA512 ac292d93a9b8b3beb239b6a1e91fc5d7440b7bf7318d91b8bc90a28722324852c4692e8fca1794fd66536b631e1df1f1682bad9cacd3d34276c25b5b023aaaaf
diff --git a/app-emulation/spice-html5/metadata.xml b/app-emulation/spice-html5/metadata.xml
new file mode 100644
index 000000000000..86afbba5af5e
--- /dev/null
+++ b/app-emulation/spice-html5/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ Spice Javascript client
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emulation/spice-html5/spice-html5-0.2.1.ebuild b/app-emulation/spice-html5/spice-html5-0.2.1.ebuild
new file mode 100644
index 000000000000..96b0048f7bd7
--- /dev/null
+++ b/app-emulation/spice-html5/spice-html5-0.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Spice Javascript client"
+HOMEPAGE="https://gitlab.freedesktop.org/spice/spice-html5"
+SRC_URI="https://gitlab.freedesktop.org/spice/${PN}/-/archive/${P}/${PN}-${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+# no compiling
+src_compile() {
+ true
+}
+
+src_install() {
+ insinto /usr/share/spice-html5
+ doins -r src apache.conf.sample spice.css spice.html spice_auto.html
+}